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Installation and Quick Star 

Installation 

Please refer to <CG-500 Quick Guide> to install the software. 

Quick Star 

After successfully installing the software, double-click on the CG-500 icon to launch the program. 

 

Please Note: 

1. Please ensure that the dongle is properly connected to the computer. When using 

CG-500 the dongle must be connected at all times, otherwise the software will not 

function correctly. 

2. When EDIUS is running, it is not possible to launch CG-500 independently. 

3. It is not possible to launch multiple CG-500 at the same time. 

Overview of functions 

Start Project Screen 

Open CG-500 independently, Start Project screen will appear. 
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Functions: 

1) History Project 

Show latest project. 

2) Layout List 

Show layout list of the selected history project. 
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3) Buttons 

New Project: click the button to open System Format Select screen 

Browse Project: allows you to browse and open local project 

Open Project: allows you to open the selected history project 

Close: exit CG-500 software 

Select Format Screen 

Click on the “New Project” button, System Format Select screen will appear.  

 

Three functions can be performed: 

1) Choosing a format. 

For example, PAL D1 50i or PAL Full HD 1080/50i 16:9. 

Note: if one format is frequently used it can be set as the default format. 

2) Add custem format 

Choose “Custom” format. 
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Set format parameters then click the “Add” button marked in red in the image above. 

 

3) Set Title parameters. 

  

Custom parameters can be set by clicking on "Custom", setting parameters, and then clicking 

on “Save as Default Parameters”. 

Note: If, once in CG-500, the format needs to be changed, you can: 

1. Use the shortcut Ctrl+Shift+P 

2. Click on the “Document Settings”  button. Once the format has been chosen, 

click on “OK” to proceed. 
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The Main Interface screen is divided into the following parts: 

 Menu Bar - this is the main tool bar 

 Layout List- lists all layouts 

 Edit Screen - allows you to directly edit objects and text 

 Timeline Window - shows duration items in every layout page 

 Properties Window - allows you to edit the properties of objects and text 

 Status Bar - provides basic layout information and interface tools 

The Menu Bar 

File Menu 

 

 

Undo: undoes action 

 

Redo: restores undone action 

 

Start Project 

 

New Project: creates new project 

 

Open Project: opens existing project 

 

Save: saves project 

 

Save As: saves project as “new name” 

 

Import Layout 
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Export Layout 

 

Add Layout 

 

Insert Layout 

 

Remove Layout 

 

Document Settings: set project 

settings 

  

Edit Menu 

 

 Copy  Paste 

 Cut  Delete 

 Align  Align Range 

 Screen Arrangement  Move Level: adjust object level 

 Group: creates a group of objects  Ungroup: separates a group of 

objects 

 Boolean: Boolean operations   

Object Menu 

 

 Select: choose an item  Shape: create object of certain 

shape 

 Line: create lines  Bezier: create Bezier curves 

 Text: create text  Morph Text: create 

multidimensional text 

 Curve Text: create curved text  Flag: create flag object 

 Image: create image  Clock: create clock 

 
Title PlugIn：Create PlugIn object   
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Options Menu 

 

 

Show/Hide Ruler 

 

Show/Hide Grid 

 

Show/Hide Safe Area 

 

Show/Hide Crossline 

 

Background: choose background 

 

System Options: choose background and other settings 

Roll/Crawl Menu 

 

 

Still: set as still 

 

Roll up 

 

Crawl left 

 

Crawl right 

 

Add One: adds one screen 

 

Add Half: adds half a screen 

 

Delete One: deletes one screen 

 

Delete Half: deletes half a 

screen 

 

Show/Hide Roll/Crawl Line 

 

Go to screen: quickly go to 

the desired roll/crawl screen 

Effect Menu 
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Select 

 

Translate: move the object 

 

Rotate: rotate the object 

 

Scale: adjust size 

 

Transparency 

 

3D View 

 

pivot 

 

3d Horizon 

 

Camera Output Window   

 This menu will appear when shifting to Effect Mode (shortcut F10). 

Text Editor Toolbar 

 

The Text Editor Toolbar allows you to set text parameters: 

 Font 

   Italics 

   Bold 

   Underline 

  Height 

  Width 

   Lock: lock height-width ratio 

   Align Left 

   Align Center 

   Align Right 

  Line Range 

  Character Range 

   Arrange: present text horizontally or vertically 

      Render: apply effects to whole text or to individual characters 

 Show/Hide Text Editor advanced functions 

 

 Enter left-right 

 Enter right-left 

 Enter top-down 

 Enter bottom-up 

 Font Mode 

 Fill Mode 

 Set vertical shear effect 

 Set horizontal shear effect 

 Small Caps 

 Unconstraint 
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 Constraint 

 Offset punctuation for vertical text 

 Donot offset punctuation for vertical text 

Layout List 

 

Use the Layout List to quickly edit several titles. 

Frequent operations are: 

View: click on a Layout to make it appear on the 

Edit Screen 

Add Layout: right click on a layout and choose 

“Add” 

Delete Layout: rightclick on layout and choose 

“Delete” 

Layout List right-click context menu: 
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Append: adds layout 

Insert: inserts layout 

Delete: deletes layout 

Rename: changes layout name 

Copy: copy layout 

Cut: cut layout 

Paste: paste layout 

Move Up 

Move Down 

Move Top: move layout to front 

Move Bottom: move layout to end 

Prev Screen: show previous screen 

Next Screen: show next screen 

Head Screen: show first screen 

Tail Screen: show final screen 

 

Graphics (still) Editing Mode 

 

Right-click on the Edit Screen 

1. The following context menu will appear 
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View Ruler 

View Grid 

View Safe Area 

View Cross Line 

Enable Guideline 

Fit Window Size 

Show Full Color 

Show Alpha Only 

Show Fill Color 

Paste 

Save Layout to Image File 

 

 

2. Object context menu 
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Make Group 

Ungroup 

Move Up 

Move Down 

Move Top 

Move Bottom 

Lock/Unlock 

Visible/Invisible 

Edit 

Cut 

Copy 

Paste 

Delete 

Paste To Group 

Delete 

Copy Shader Style 

Paste Shader Style 

Scale ShaderStyle Parameter 

Boolean 

Mix Option 

Align Objects 

Center Object Pivot 

Mirror Vertical 

Mirror Horizontal 

Reset morph Text 

Text Block 

Save Object to Image File 

Control Panel 

 
The Control Panel is used to operate items placed in the timeline tracks. Functions from left 

to right: 

     Fit Window 

     Actual Size 

     Custom Size 

  Choice Head - move to the start of chosen track 
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  Choice Tail - move to the end of chosen track 

   Play Start 

  Play 

 Loop - continuously replay 

   CG Preview Play  

    Show Full color 

    Show Alpha Only 

    Show Fill Color 

  Shift between 2D/3D Effect 

Left Time Code: current play time 

Right Time Code: total play time. 

Effect Editing Screen 

Press the “Effects Editing Screen” button (or type F10) to shift from the Graphics (Still) Editing 

Screen. Here you can set object keyframes. 

 

Adjusting screen angle: 

a. To change angle, hold “Alt”, left click and drag mouse. 

b. To reset angle, hold “Alt’ and double click. 

When using the blank function, right click for the following context menu: 
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Reset Current 3D View 

View 3D Horizon 

View Camera Output Window 

View Ruler 

View Grid 

View Safe Area 

View Cross Line 

View Zoom 

Show Full Color 

Show Alpha Only 

Show Fill Color 

Save Layout as Picture 

When using the displacement function, right click for the following context menu: 
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Translate Animation 

Insert Translate Keyframe 

Delete Translate Keyframe 

Go to Previous/Head Keyframe 

Go to Next/Tail Keyframe 

Reset Translate 

Smooth Vertex 

Sharp Vertex 

Speed Up 

Slow Down 

Speed Normal 

Ease in out 

Set Line With Prev Translate Keyframe 

Set Line With Next Translate Keyframe 

Invert All Translate Keyframe 

Uniform All Translate Keyframe 

Reset All Transform 

Reset Translate 

Reset Pivot 

Reset Scale 

Reset Rotate 

Reset Alpha 

When using the pivot function, right click to see the following context menu: 
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Pivot (XYZ) Animate 

Insert Pivot Keyframe 

Delete Pivot Keyframe 

Go to Previous/Head Keyframe 

Go to Next/Tail Keyframe 

Reset Pivot  

Invert All Pivot Keyframe 

Uniform All Pivot Keyframe 

Reset All Transform 

Reset Translate 

Reset Pivot 

Reset Scale 

Reset Rotate 

Reset Alpha 

When using the scale function, right click to see the following context menu: 

 

Scale(XYZ) Animate 

Insert Scale Keyframe 

Delete Scale Keyframe 

Go to Previous/Head Keyframe 

Go to Next/Tail Keyframe 

Reset Scale  

X scale value 

Y scale value 

Z scale value 

Invert All Scale Keyframe 

Uniform All Scale Keyframe 

Reset All Transform 

Reset Translate 

Reset Pivot 

Reset Scale 

Reset Rotate 

Reset Alpha 

When using the rotate function, right click for the following context menu: 
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Rotate(XYZ) Animate 

Insert Rotate Keyframe 

Delete Rotate Keyframe 

Go to Previous/Head Keyframe 

Go to Next/Tail Keyframe 

Reset Rotate 

X rotate value 

Y rotate value 

Z rotate value 

Invert All Rotate Keyframe 

Uniform All Rotate Keyframe 

Reset All Transform 

Reset Translate 

Reset Pivot 

Reset Scale 

Reset Rotate 

Reset Alpha 

When using the transparency function, right click for the following context menu: 

 

Alpha Animate 

Insert Alpha Keyframe 

Delete Alpha Keyframe 

Go to Previous/Head Keyframe 

Go to Next/Tail Keyframe 

Reset Alpha 

Invert All Alpha Keyframe 

Uniform All Alpha Keyframe 

Reset All Transform 

Reset Translate 

Reset Pivot 

Reset Scale 

Reset Rotate 

Reset Alpha 

Keyframe context menu 
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Reset Translate 

Delete this Keyframe 

Smooth Vertex 

Sharp Vertex 

Speed Up 

Slow Down 

Speed Normal 

Ease in out 

Properties Window 

Property Tab 

 

The Properties Window has five 

tabs: Property, Shader, Effect, Text 

and Roll/Crawl and CG property. 

Name/Describe: view selected 

object and describe 

Mix Style: select Mix Normal/Mix 

Penetrate 

Render as new layer 

Position: view position, make 

change 

Rotate: view rotate angle, make 

change. 

Scale: view scale parameters, or 

change value. Left-click on , 

changing to , scale XY change 

simultaneously. 

Shear: view shear value, or 

change. 

Pivot: view pivot position, or 

make change. 

Reset: reset selected value. 

Reset: reset all. By 

clicking on it will reset all values, 

but doesn't affect values in sub 

screen. 

Sub Window: marked place in the 

picture left. 

If choosing different object, sub 
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window will appear different 

accordingly. 

Set parameters by: 

a. Clicking on the field and typing in the numbers 

b. Dragging the cursor over the field 

Shader Tab 

 

 Shader preview 

Shader Style drop-down list 

Properties list: Face, Edge, 

Shadow, Depth 

 Add 

 Insert 

 Delete 

 Move Up 

 Move Down 

 You can set specific parameters in the 

properties list. 

 You can also use preset Shader templates 

 Set Dynamic Texture and Masking, found at 

the lower half of the tab. 

Use the or  button to add Face, Edge, Shadow or Depth, 
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Use the  button to remove Face, Edge, Shadow or Depth, 

 

Set order by clicking on the  and  buttons, 

 

Set Shader style by choosing from the drop-down list. 
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Effect Tab 

 

 

To the left: 3D Transform, 2D Pan 

and Screen In/Out areas 

 Expand 

 Reset 

 Fold/Expand 

 Delete 

 Save 

Screen In/Out area 

 Choose In method 

 Choose Stay method 

 Choose Out method 

 Add Effect 

 Delete Effect 

 Refresh 

 Show Text List 

Setting screen In effect:  

Click , choose an effect from the templates, then click . 
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Use the same method to apply “Stay” and “Out” effects. 

Text Tab 

         Whole text Line by line text 
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Edit text options: 

 Whole text  Line by line text 

 Create new  Open existing file 

 Save  Save As 

 Find and Replace  Create text 

 Create line by line text  Create single-line text 

 Replace All  Replace 

 Subtitle Setting  Font Style 

Roll/Crawl text editor menu: 

 

Set Heading: sets chosen text as heading 
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Set Content: sets chosen text as content 

Select Heading: pick out headings 

Select Content: pick out content 

Heading-Content: sets space between heading and content 

Content-Heading: sets space between content and heading 

Content-Content: sets space between content and content 

Apply Horizontally: applies horizontally 

Apply Vertically: applies vertically 

At the bottom of the tab you can see the list of texts that are in the Edit Screen. 

Left-click to edit. 
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Roll/Crawl Tab 

 

Roll In: set role in method 

Roll Out: set roll out method 

Custom: set roll time 

Loop: set loop time and count 

Speed Down: reduce roll speed. 

Liner: apply liner effect 

Ruler: set ruler size 

Full: restore liner to full screen 

Roll Area: 

Ruler: set roll limits 

Full: set ruler to full screen 

Left/Right/Top/Bottom: set roll 

limits 

Start/End Fade: set head/tail in/out 

position 

Mask: apply mask effect 

Invert: apply invert effect 

Blur: set blur parameters 
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CG Property Tab 

 

 

Object Type: choose object type 

ID Class: choose ID class 

ID: show ID 

Direction: choose roll/crawl method 

Speed: choose roll/crawl speed 

Interval: set interval 

Head Fade Pixel: set head fade pixel 

Tail Fade Pixel: set tail fade pixel 

Effect Option: choose effect 

method 

Duration: change effect duration 

Data Source: choose data source 

Text File: browse text file 

Edit: edit file 

Invalid File: show invalid file 

Loop Play 

Loop Count: set loop count 

Has play title text: enable “Has play 

title text” to use head symbol and 

tail symbol 

Data Field Mapping Option: 

use/unused source field and target 

field 

If choosing different data source, the tab will appear different accordingly. 

CSV File 

Set field counts and field symbol 



Datavideo Technologies Co., Ltd.                                                          34 

 

ODBC Dtabase 

Set DNS, SQL and edit SQL 

 

Timeline Window 

 

Timeline Window options: 

 Move object up  Move object down 

 Move object to top  Move object to bottom 

 
Move effect up 

 
Move effect down 

 

Render as new layer 
 

Normal object/replaceable object 

 Show animation track only  Show all tracks name 

 Set track as Visible/Invisible  Show/Hide object effect tracks 

 Enable 3D transform  Lock object to prevent editing 

 Enable Timeline Autosnap  Expand all tracks 

 :  



Datavideo Technologies Co., Ltd.                                                          35 

Adjust the Timeline using the bar shown or right click on the timeline, then drag the cursor. 

Click on the bar-button at the very left of the Timeline to open the Templates Library. 

3D Transform and Dynamic Texture tracks: 

 

 Enable/Disable 3D Transform Keyframe points. 

 Go to previous Keyframe 

 Add/Remove Keyframe 

 Go to next Keyframe 

Right click on an object track to see the context menu: 
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Move Up 

Move Down 

Move Top 

Move Bottom 

Lock/Unlock 

Visible/Invisible 

Render as new layer 

Rename 

Edit 

Set Object Duration 

Cut effect 

Copy effect 

Paste effect 

Delete effect 

Copy 3D Transform 

Paste 3D Transform 

Reset 3D Transform 

Copy All 

Paste all 

Reset to default 

Set subtitle pause point 

 Right click on an effect track to see the context menu: 
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Lock/Unlock  

Enable/Disable 

Show animation track only 

Cut effect 

Copy effect 

Paste effect 

Overlay effect 

Delete effect 

Reset effect 

Invert all keyframe 

Uniform all keyframe 

Set as Fade In point 

Set as Fade Out point 

Fade In/Out 

Right click on a text effect track to see the context menu: 

 

 

Enable area 

Add area 

Delete area 

Play by character (In) 

Play by character (Out) 

Play by line (In) 

Play by line (Out) 

Play by text 

Frequency value 

Uniform area 

Reset area 

Right-click the Dynamic Texture track to see the context menu: 
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Modify 

Fill Fit 

Add 

Insert 

Cut 

Copy 

Overlay 

Paste 

Delete 

Set speed 

Delete all 

Select all 

Set Dynamic Texture speed by choosing from the speed list. 

  
Right click on an empty track in the Timeline to see the context menu: 

 

Show/Hide track header 

Show/Hide Aux child view 

Show Timeline Pointer 

Timeline Auto Snap 

Expand all tracks 

Zoom fit (you can also double click on the timeline) 

Template Library 

 

Template Library options: 

 Add list  Delete list 
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 Rename  Move up 

 Move down  Add template 

 Delete template  Apply template 

 Import template  Export template 

 Refresh template library  Show/Hide template name 

 Replace Selected Template  Quick View 

   
Use the Zoom In/Out bar or “Zoom In/Out” buttons to zoom in/out of the template library. 

From the template Menu Bar you can choose different template catalogues, such as Shader 

Templates or Image Templates. 

 

Changing template name: 

Method 1: double click on the template name, enter a new name and then click on “OK” 

 

  Method 2: right click on the template and choose "Rename" from the context menu 
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System Library 

 

System Library options: 

 Add list  Delete list 

 Rename  Move up 

 Move down  Add file 

 Delete file  Apply file 

 Import file  Export file 

 Refrest System Library   

Right click on an empty space:  

 

Add file 

Import file 

Empty file 

Select all 

Invert selection 

Clear selection 

Refresh 

Small icon 

Middle icon 

Large icon 

Right click on a file: 
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Delete file 

Rename 

Apply file 

Export file 

Local file in explorer 

Move to previous file position 

Move next file position 

Move selection to 

Copy selection to 

To delete a file either: 

a. Select a file, then press Delete on the keyboard or right click and choose “Delete” 

from the context menu. 

b. Select a file and press the  button. 

To add a file either: 

a. Press on , or double click and choose a location to import from. 

b. Right click, then choose "Import" from the context menu. 

To edit a template name: 

1. Choose a catalogue 

  

2. Press on the  “Rename” button, then enter a new name 

  

3. Press “OK” to confirm. Press “Cancel” to exit without changing name. 
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Create Object 

CG-500 provides a large number of default objects, including shapes, Bezier shapes, 

horizontal/morph/curve titles, images, animation, clock object, etc. 

Operation flow 

Most object creation follows the same basic operation flow: 

1) Click on the object toolbar and select object type 

 

2) In Still Mode, click on the object and adjust size. 

  

Note: Hold Ctrl when adjusting to keep vertical/horizontal size proportional. 

3) Release object. 
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Shapes 

 Following the basic operation flow, other shapes can be created. 

 Shape properties 

 

 

In the lower half of the Properties 

Window you can find the shape's 

special properties. 

Activate/Deactivate the “Fill” option 

to set Line Width. 

Choose object shape in the drop-down 

list. Changes will also take effect in the 

Edit Screen. 

 Shapes with Fill mode deactivated. 
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 Changing shapes: rectangle to triangle 

1) In the Edit Screen, click on the 

rectangle. 

 

2) In the Properties Window 

drop-down list, select Triangle 

 

3) Object becomes triangle. 

 

Shapes with special properties: 

1. Round Rectangle: set Radius parameters 

 
 

2. Parallelogram: set Incline parameters 

 

 

3. Star 
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Depth: set Depth between points 

Face: set number of points 

Reset Parameters: resets all parameters 

 

Different Face parameters 

  

Different Depth parameters 

  
4. Polygon: Face parameters set the number of sides 

  

5. Pie Shape 

 

Angle: set Pie angle and angle size 

 

  Example 

 

 
Change angle 
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Change angle size 

 

6. Line: set Line Width 

 
 

Bezier Curve 

The way to create a Bezier Curve and a shape is not the same as for other objects. 

1) In the Object Menu Bar click on “Bezier” 

 

Note: The "Bezier Curve" icon is a drop-down button, click and select "PaintStroke" to create 

hand-drawn objects. For more complete instructions please see the " PaintStroke " Chapter. 

2) In Still Mode, set the Bezier Curve Anchor Points. 

   

Note: 

a. If you release the left mouse button straight away, both the Anchor and Control Points 

will be created 

b. If you keep the left mouse button pressed, you can first set the Control Points, and then 



Datavideo Technologies Co., Ltd.                                                          47 

create the Anchor Point. 

3) Join the last Anchor Point to the Start Point to complete the shape, or double click/press 

ESC to finish editing. 

4) Double click on the Bezier Curve to resume editing. 

5) In edit mode, right click to see the following context menu 

 

Smooth: smoothen lines between points 

Sharp: sharpen lines between points 

Delete: delete point 

Lock/Unlock: prevents point from being edited 

Set Start: set as start point 

Enable: you can disable the point 

Combine Move: move Control Points together or 

seperately 

Close: close/open curve 

Paintstroke 

 Operation flow 

1) Click “PaintStroke” in the Object tab. 

 

2) In the Editor Screen (still), left click, and drag. 

 
3) Release left mouse button, press ESC to exit. 
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Example: 

 

Image 

The operation flow for images and objects is similar, the only difference is that an image file 

needs to be chosen in the Properties Window. 

1) In the Object Menu Bar choose “Image” 

 

2) Set position and size in Still Mode. Release mouse cursor. 

3) In the Properties Window select an image file (and Mask if needed). 
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Enable “3D Stereoscopic Image” and 

select “Single/Dual” 

Browse and select file and show file 

name  

Show image height and width and 

enable/disable “Origin” 

Clip image 

Set mask parameters and blur 

parameters 

Whole Transpatency Control: Set whole 

transpatency (disable when enabling “3D 

Stereoscopic Image”) 

The options are used when image object 

have shader style property(Face, Outline, 

Shadow) 

Specific Properties of 3D Stereoscopic Image 

 

 

4) Example. 
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5) Double click to Crop  

  

 
6) The selected area will expand to the original image size 
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7) Press ESC to exit 

Animation 

Create Animation and Create Image operation flows are similar. 

1) In the Object Menu Bar click “Movie Video”. 

 

2) In Still Mode, adjust size and position. 

3) Release mouse cursor 

4) In Properties Window select animation file and set parameters. 

 

 

Present: set start frame 

Time In: set start time point 

Time Out: set end time point 

Repeat: set repetitions 

Origin: go to animated object 

original position 

5) Create complete 

Using animation templates 

A large number of preset animated objects are provided. Go to the templates library and 

double click on them to use them. 
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Note: If you double click on an animation in the templates library when an animation has 

been selected in the Edit Screen, it will be replaced.  

Horizontal/Vertical Text 

Normal-frame and Set-frame Text options are possible. 

 Create Normal Text 

1) In Object Menu Bar choose “Horizontal Text”, 

 

Note: hold cursor to choose “Vertical Text” 

2) In Still Mode, adjust text size and position, 

 
3) Enter text, 

Method 1: enter text 

 
Method 2: copy and paste 
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Right click in text editing state and choose “Character Map” from the context menu. 

 
4) Press ESC or double click to exit 

5) Double click on text to continue editing 

 Create Set-Frame Text 

1) In Object Menu Bar choose “Horizontal Text” 

 

2) In Still Mode drag cursor to desired frame size 

   

3) Enter text. If text exceeds frame it will automatically move to the next line. 
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Text will automatically adjust when frame is shifted. 

 

 
4) Press ESC or double click to exit 

5) Double click on the text to continue editing. 

 Properties 

Text Titles have many properties. Simply double click on the desired text to start editing. 
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Morph Text 

 Creating Morph Text uses the same operation flow as Normal Text. 

1) In the Object Menu Bar select “Morph Text” 

 

2) In Still Mode adjust text position, then enter text 

   
3) Edit Morph Text curves (see also Bezier curve editor) 

   

4) You can choose a morph text template from the Properties Window 
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5) Press ESC to exit. Example: 

   

6) Double click on text to resume editing. 

 Morph Text control curves have three settings: 

Separate - control curves independently 

Same - control curves together 

Inverse - curves do the inverse of each other 

Set in two ways 

1) Right click on the text and then choose from the context menu 

  

 



Datavideo Technologies Co., Ltd.                                                          57 

2) Select in the Properties Window 

   

Example: 
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Curve Text 

 Operation flow similar to Normal Text 

1) In Object Menu Bar select “Curve Text”, 

 

2) In Still mode use the Bezier curve method to create curves. 

   

3) Enter text 
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4) You can also choose preset Curve Text styles from the template library. 

   

5) Press ESC to exit. Example: 

   
6) To resume editing, double click on the text. 

Clock Object 

 To create: 

1) In the Object menu bar, click on the "Clock" button. 

 

Note: The "Clock" button offers various choices, from the drop-down menu you can select 
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"Number" or "Time Code". 

2) In the still editor window click on the starting position, then left click to drag the object 

to the appropriate size. 

3) Release the mouse button to complete operation. 

 

4) Setting clock time parameters: 

1. Using the system time, the default length can be adjusted freely, with the default set at 

4 seconds.  

  
2. Set countdown time as shown below. Default is set at 4 seconds. 

 
Enter start time values. The default time is set as 0:00 

 

Clock object parameters: 
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Start time: set the start time. Select system time to 

set the current system time as start time. 

Default length: Set playback time. After setting the 

countdown, the duration will be shown. 

Display Type: Select digital clock or dial clock.  

Cut-time: switch to cut-time mode 

Accumulate-time: switch to accumulate-time mode 

Display Format: Select the time display format 

Dial clock: use dial clock 

Straighten: square shaped dial clock 

Label front: enter text before the clock 

Label back: enter text after the clock 

Language: Select language 

Example: 

  

Number Object 

 To create: 

1) In the Object menu bar, click on the "Number" button. 

 

2) In the still editor window click on the starting position, then left click to drag the object 

to the appropriate size. 

3) Release the mouse button to complete operation. 
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Number object parameters 

 

Initial value: Set start numerical value  

End value: Set end value 

Keyframe interpolation: Enable/Close key frame 

interpolation functions 

Decimal: set decimal number values 

Minimun digit: set smallest whole number 

Display Format: Select the display format, 

including numerical values, spelling, percentage, 

etc. 

Three units: three separate digital units to be 

displayed 

Label front: text to the left 

Label back: text to the right 

Language: Select language 

Examples: 

  

Timecode 

 To create: 

1) In the Object menu bar, click on the "TimeCode" button. 
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2) In the still editor window click on the starting position, then left click to drag the object 

to the appropriate size. 

3) Release the mouse button to complete operation. 

 

Time code object parameters 

 

Start Time code and Current Time Code will be 

discussed later. 

 

 

View Format: select format. 

Discard Frame: discard format 

Frame Rate: select frame rate. 

Front Marker: enter time code left text. 

Back Marker: enter time code right text. 

Set start time code: 

1. Current Time Code mode: set Current Time Code mode, modulate deviance, but default 

length are unchangeable. 

 

2. Start Time Value mode: 
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When selecting Default Length, default length can be changed. 

 

3. When selecting Keyframe Interpolation, end time code can change. 

    

Examples: 

  

Date Object 

 To create: 

1） In the Object menu bar, click on the "Date" button. 

 

2） In the still editor window click on the starting position, then left click to drag the object 

to appropriate size. 
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3） Release the mouse button to complete operation. 

 
Date Object Parameters 

 

Select “System Time” to set the 

current system time as start time. 

Select “User Define” to set time as 

needed. 

Select the display format 

Display Format: select date format 

Language: Select language 

Set Date 

System time code: 

Set to system date, and default date is unchangeable.  

 

Define date code: 

When selecting “User Define”, date can change. 



Datavideo Technologies Co., Ltd.                                                          66 

 
Display Format 

Choose a date format from the drop down list. 

 

Examples: 

 

Flag 

 The create flag operation flow is similar to that of objects, and will not be presented 

here. 
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 Choose a flag from the Properties Window 

 

The flag name and abbreviation will be shown 

below. 

To find a flag, enter the full name or abbreviation 

into the "Find Name" field, then press “Search”. 

Press “Origin” to place the flag in its default position. 

To find a flag, enter the full name or abbreviation into the "Find Name" field, then press 

“Find”. 

   

  
Edit flag: 

In Flag Library left click, select desired flag, then click “Edit”. 
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In the pop-out Edit Frame, enter property parameters, click “OK”. 

Object Group 

Objects groups can be used to quickly manipulate multiple objects. Use groups to: 

1) Rescale, rotate, etc., whole groups simultaneously 

2) Use object groups' properties to produce different play effects. 

 Make Group:  

a. In the Edit Screen select multiple objects/text, then use the shortcut Ctrl+G 

b. In the Edit Menu Bar choose “Make Group” 

c. In the Edit Screen, right click, then choose “Make Group” from the context menu 

 

 Undo Group: 

a. In the Edit Screen select the group, then use the shortcut Ctrl+U 

b. In the Edit Menu Bar choose “Undo Group” 

c. In the Edit Screen, right click, then choose “Un Group” from the context menu 
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Path Group 

Path Groups use Boolean editing to create new, individualised object types. 

 Choose multiple objects, then right click, use shortcut key or Edit Menu Bar to 

apply Boolean 

  

     
Boolean Union (Ctrl +'+') - merges two objects 

Boolean Subtract (Ctrl +'-') - subtracts one object from the other 
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Boolean Intersect (Shift +'-') -intersect between objects remains 

Boolean Xor (Shift +'+') - intersect between objects is removed 

Example: 

  

 To apply artistic effects to normal text, you can turn it into a Path Group. 

1) Create normal text 

 

2) Transform normal text into Path Group by typing Ctrl+P or right click then choose 

"Text Block"- "Text Block to Path Group" 
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3) Double click on the Path Group to edit 
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Example 

 

 

Applying Shader 

Shader Properties 

Shader properties incluce: Color, Texture, Linear sheen, Bitmat sheen, Bump bitmap, 
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Concave, and Bevel. An object's Face, Edge, Shadow and Depth have similar properties, 

allowing for different combinations.  

Colors 

You can set Colors as: Color, Gradient, QuadGradient, BmpGradient. 

Color 

 

 Reset 

 Set single 

color. Click to see 

colors library. 

 RGB format 

 HSB format 

The "Color" section has 32 preset colors, and 8 RGB Alpha combinations. To set color: 

1. Choose one of the 32 preset colors 

2. Use the cursor to pick a color from the palette 

3. Set parameters in the RGB Alpha fields 

4. Use the scroll bar 

5. Use the pipette 

Gradient Color 

 

Gradient preview 

Under gradient preview, 

select gradient type, 

count and angle. 

Different parameters 

can be set depending on 

gradient type. 

Set gradient 
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Fisrt click on Color Marker, then 

pick color. 

Use the same method as with 

single color to set any color on 

each Marker. 

Adding, deleting and moving Color Markers: 

 

Click under the gradient color bar to add a 

Marker, drag to set position. Press Delete to 

remove Marker. 

 

Set the central position between colors 

using the blured block over the gradient 

color bar. 

 

Change Count, Angle, and XY parameters by 

imputing numbers directly or dragging the 

cursor left-right. 

 Gradient type 

 

Choose gradient type from the drop down 

list: linear, circle, clock, rose line or 

rectangle. 

 Linear gradient 

 

In Linear you can only set color, count and 

angle. Use angle to set the direction of 

colors. 

  Example 
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Circle gradient 

 

In Circle you can only set the X, Y parameters 

for effect. 

 Example 

  

Clock gradient 

 

Divisions between colors are like clock needles. 

All parameters can be changed. 

 Example: 



Datavideo Technologies Co., Ltd.                                                          76 

  

Rose Line gradient 

 
 Example: 

  

As with Clock and Rose Line, all parameters 

can be changed 

 

 

 Example: 
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QuadGradient 

 

QuadGradient: four colors are chosen at four 

points 

Setting QuadGradient: as with single colors, 

choose color for each point. 

 Example: 

  

BumpGradient 

 

Choose a Bitmap Gradient from the System 

Templates Library, double-click to apply. Then 

set colors. 
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Texture 

 

 Library: choose a template from the 

library 

 Reset: resete parameters 

XY Scale: set block size 

XY Offset: set block position 

Strenght: set texture strength/visibility 
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Linear Sheen 

 

 Colors: set linear sheen colors 

 Reset: reset parameters 

Position: set linear sheen position 

Angle: set linear sheen angle 

Width: set linear sheen width 

Strength: set linear sheen strength/visibility 

  

Bitmap Sheen 

Addlight Type 

 

 Colors: choose bitmap sheen color 

 Library: choose a style from the 

template library 

 Reset: reset parameters 

Blur: blur bitmat sheen 

Strength: set bitmap sheen strength 

You can pick between Addlight Type and Mixlight Type 
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Bump Bitmap 

 

Set Colors, Angle, Height, Strength and 

Type (Tile/Stretch) 

You can pick a preset template from the 

library. 

Press Reset to delete set parameters. 
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Concave 

 

Set Colors, Style 

(Raise/Convave/Lightborder), 

Brightness, Blur, Angle and Height. 

Press Reset to delete set parameters. 

 

  

Bevel 

 

Set Colors, Size, Depth, Angle and Light 

Depth. 

Press Reset to delete set parameters. 
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Face 

In Face you can set the following properties: Color, Texture, Linear Sheen, Bitmap Sheen, 

Bump Sheen, Concave and Bevel 

 

Reset: resets all parameters to their 

original values. 

Delete:  deletes Face 

Fold/Expand: Folds/Expands all 

Face properties 

Fold/Expand: Folds/Expands Face, 

Edge, Shadow, Depth properties 

Edge 

In Edge you can set the following properties: Color, Texture, Linear Sheen, Bitmap Sheen, 

Bump Sheen, Convave, Bevel 
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As with Face you have Reset, Delete and 

Fold/Expand properties. 

Unique to Edge: Width and Blur 

Edge has different effect types. 

  

  

Shadow 

In Shadow you can set the following properties: Color, Texture, Linear Sheen and Bitmap 

Sheen 
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As with Face you have Reset, Delete and 

Fold/Expand properties. 

Unique to Shadow: Width, Angle and Blur 

properties. 

 

Depth 

In Depth you can set the following properties: Color, Texture, Linear Sheen and Bitmap 

Sheen. 

 

As with Face you have Reset, Delete and 

Fold/Expand properties. 

As with Shadow you have Width and 

Angle properties. 

You can set Shadow type by clicking on 

the drop down list. 

  

Example 
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Frame 

In Frame you can set the following properties: Color, Texture, Linear Sheen and Bitmap 

Sheen, Bump Sheen, Convave, Bevel. 

 

As with Face you have Reset, Delete 

and Fold/Expand properties. 

As with Shadow you have Width 

and Angle properties. 

Unique to Shadow: Height, Offset 

and Space properties. 

You can set Frame type by clicking 

on the drop down list. 

  

Example 
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Advanced properties 

 

 

You can apply Mask effects by going to the bottom of 

the Shader Tab. Here you can apply a Mask from the 

template library, set the blur level and 

activate/deactivate the Inverse option. 

Setting Mask 

1) Enter a text in the Edit Screen, then choose  from the Shader Tab. 
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2) Click on the  button to choose a template. Double-click or press  to 

apply. 

 

Set Mask Blur parameters 

Example 

 

 
Use Inverse option to inverse effect. 
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Editing properties 

Combinations 

Enter text/object on the Edit Screen, open Shader, and then pick Face, Edge and Shadow. 

You can also pick Shader properties first and then input text/object. 

By default, when you first enter text only Face is opened. Add other properties. 

 

Click the “Insert” button to add Outline over Face. 
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Note: you can click the “Insert” button to insert a shader property over the selected 

property. 

The text add a Outline property: 

 

To delete a property, choose the unwanted property and then click on either of the “Delete” 

buttons shown in the screen below. 

Example 

Step 1 

 

Step 2 
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Move between properties by using the mouse cursor or the /  buttons, 

 

Example 

 

Using different properties combinations you can produce all sorts of Title effects. Example: 
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Preset Styles 

You can choose a Preset Style by clicking on the drop-down list shown below. 

 

Below: neon style. 

 

Shader Template Library 

At the bottom of the Shader tab you can open the Templates Library by clicking the  

button. 

 

Use the “Add/Delete” buttons to 

add/delete templates to/from the library. 

Hide the library by clicking on the “Hide 

Library” button. 

Right-click on a template to see the context menu: 
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Apply All: applies shader and format properties to 

current text 

Apply Shader: applies shader properties to current 

text 

Delete 

Apply all except font height 

Export template 

Locate file in explorer 

Move previous 

Move next 

 Right-click on an empty space in the library to see the context menu: 

 

Add 

Import 

Empty  

Choose all 

Invert selection 

Clear selection 

Refresh 

To add a template you can: 

1. Press the  button in the library 

2. Choose Add from the options context menu. 
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To delete a template either: 

1. Press the  button in the library 

2. Choose Delete from the context menu 

After creating text in the Edit Screen, the easiest way to apply template properties is to 

double-click on the desired template. 

 

To apply Shader properties only, press Ctrl and Double-click on the template. Example 
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Render Text 

 As part of the shader properties, you can choose to render the text as a whole or letter by 

letter. 

Render All: applies Shading effects to the text as a whole. 

Individual Render: applies Shading effects letter by letter. 

Set the Render format by clicking on the  button in the Text Editing Bar 

 

Example 
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Render Image  

Specific properties of render image are shown below.  

 
Note: the options are used when image object has shader style property (Face, Outline, 

Shadow). 

Example: 
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Graphics (Still) Editing Mode 

Position, Scale, Rotate 

To move an object: 

1. In the Edit Screen drag the object to the desired position. 

2. Click on an object and use the arrow keys on the keyboard. Press Ctrl to increase 

speed. 

3. Enter co-ordinates in the properties tab. 

Step 1:Click on the object in the Edit 

Screen 
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Step 2:Enter XY coordinates 

 

Zoom Object: 

Method 1: 

Drag the markers surrounding the 

object. Hold Shift to keep XY scale 

constant. 

 

Method 2: 

Enter XY scale in the Properties tab. 

Press on the lock to keep XY scale 

constant. 

 

Rotate object: 

Method 1: On the keyboard, hold Shift, then use the Up/Down arrow keys to rotate 45 

degrees. Use Right/Left arrow keys to rotate 1 degree. 

Method 2: 
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Enter numbers in the Properties tab 

Rotation field. 

 

Method 3: 

Move the cursor to the marker in the 

centre of the object 

 

A circle will appear 

 
Drag the marker around the circle to 

perform rotation 

 

Make Group, Ungroup 

Make Group will turn many objects into one. To make a group: 

1. Hold Ctrl and choose objects, or press Ctrl+A to choose all objects in Edit Screen. 

 
2. Press Ctrl+G or right-click and choose “Make Group” from the context menu. You 

can also press on “Make Group” in the Edit Menu Bar. 
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Example 

 

To Ungroup press Ctrl+U, right-click and choose “Ungroup”, or press “Ungroup” in the Edit 

Menu Bar. 

 

 

Example 
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Boolean 

Boolean is a special form of grouping and includes: Union, Subtract, Intersect and Xor. 

To perform Boolean grouping, choose objects then: 

  

1. Use the keyboard shortcuts (Shift+'+', Shift+'-', Ctrl+'+' or Ctrl+'-') 

2. Right-click and choose from the context menu. 

 

3. Press “Boolean” in the Edit Menu Bar 
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Example: 

Boolean Union 

  

Boolean Subtract 

 

Boolean Intersect 

 

Boolean Xor 

   

 

Object level 

When you have several objects in the Edit Screen, you can set level by: 
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1. Using the keyboard shortcuts: Ctrl+PageUp, Ctrl+PageDown, Ctrl+Home, Ctrl+End 

2. Right-click and choose from the context menu. 

 

3. Press “Level” button in the Edit Menu Bar 

  

Mix Option 

There are two Mix options: Mix Normal and Mix Penetrate. Two ways to apply: 

1. Use keyboard shortcuts Ctrl+T, Shift+T 

   

2. Right-click then choose from the context menu 
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Example 

Mix Normal 

 

Mix Penetrate applied to text 

 
Mix Penetrate applied to 

object  

 

3. Choose from the Properties Tab 
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Align 

To align objects you can: 

 Press “Align Objects” in the Edit Menu Bar, 

 

Right-click and choose “Align Objects” from the context menu 
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Example 

Choose Objects: 
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Align Right, Top, Bottom all use the same steps. 

  

  

  
Align Horizontal, Vertical and Centre 
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When you have more than three objects, you can align range using the “Align Space” button in 

the Edit Menu Bar or right-clicking and choosing from the context menu. 
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Vertically centre multiple objects 
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Horizontally centre multiple objects 

  
Centre multiple objects 

 

Multiple objects full-screen 
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Smart Borders 

Smart Borders help you align objects. The border lines will illuminate whenever an object 

touches them. 

1. Create an object 

2. Drag the object to one of the Smart Borders 

3. Border line is activated 
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Smart Borders along the edges will turn red, whilst the centre lines will turn yellow. 

In Roll/Crawl settings lines will appear red. 

Applying effects 

Object effects have two sources: those preset in 3D Transform, and those that have been added 

from effect files. 

3D Transform 

1) The effect's play time and Timeline track duration are always equal. 

2) An object's 3D Transform effects include Displacement, Scale, Rotate, Pivot and 

Transparency. 

3) Timeline display 
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In the picture above we can see Displacement Keyframes 

4) Parameters in the Effects Tab: 

  

Displacement 

Displacement refers to the position of an object at a specific time in space. Where the object 

moves depends on the set route and starting position. Example: 
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Object starting point and trajectory 

Scale 

Scale refers to the size of the object at a specific time in space.  

Example: 

 

Rotate 

Rotate refers to an object's rotation movements at a specific time in space. The object centre is 

the centre of rotation. Example:  

  

Pivot 

Pivot refers to the size of the object pivot at a specific time in space. 
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Transparency 

Transparency refers to how transparent or opaque and object is at a certain point in time. 

Example: 

 

Transparency at 100% and 47% 

Applying 3D Transform 

To apply 3D Transform: 

1. Press F10 to open Effect Edit Mode 
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2. Click on the Effect Menu Bar 

 

3. To apply parameters use the Edit Screen or the Effect Tab. 
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4. If Keyframe animation is needed: 

a. Activate Keyframe animation parameters as shown below 

 

 

b. Move the Timeline Marker to the desired location 

c. Click on Keyframe Marker to add keyframe (see below) 



Datavideo Technologies Co., Ltd.                                                          118 

 

d. Use the Effect Tab or the Edit Screen to adjust parameters  

Creating Keyframes 

Add keyframe: after moving the timeline click on the add keyframe button, 

 

Delete keyframe: move the timeline onto the keyframe, click on the delete keyframe button. 
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Copy keyframe: right-click and choose "Copy" on selected keyframe(s). You can also use the 

shortcut Ctrl+C to copy. 

 
Right-click context menu 
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Cut 

Copy 

Paste Value 

Delete 

Reset 

Constant 

Linear 

Speed Up 

Speed Down 

Ease in out 

Custom 

Copying keframes to other clips: right-click on the 3D Transform track of another clip to see the 

context menu 

  

Perform paste 

 
When clicking on a single track all keyframes on that track will be selected, as shown 

below: 
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 Right-clicking on the rectangle shown above gives the following context menu: (This 

operation only affects the current track) 

 

Copy keyframe linked list 

Paste keyframe linked list 

Reset keyframe lined list 

Invert keyframe linked list 

Keyframe interval list 

Effect composition 

There are many template effects that can be added to an object preset effects, including: 2D Pan, 

2D Stretch, Linear Dither, Region Dither, Shine, Star Glow, Lens Flare, Stripe, Sparkle, Linear Light, 

Radical Light, Image Light, Lens, Wormhole, Swirl, Riple, Circle Lens, Page Curl, Page Turn, Gaus 

Blur, Radical Blur, Motion Blur, Box Blur, Spin Blur, Wipe, Mosaic, Flick. 

1) The duration of added effects can be freely modified 

2) All keyframe effect parameters can be edited 

Track example 

  

Effect Tab example 
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Effect Templates Library 

The software supplies many preset templates for every effect. Double-click on a template to 

apply it to the object. Exampe: 

   

Before applying the template you can set other parameters such as duration and appearance. 

  

“In” Button - set when an effect should appear 

“Stay” Button - set how long an effect should appear 

“Out” Button - set when an effect should disappear 

Effect Template Library operation buttons: Add Effect, Delete all effects, Refresh library, Show 

Text List 

  

Click on a category to see the full list of effects 
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Text effect 

Text is the most commonly seen title format on television. CG-500 adds a new scope to how text 

can be played, including Whole Text, Line by Line, Letter by Letter, enter progressively exit 

instantly, and much more. The user can add play areas and styles according to need. 

Setting play area 

Right-click on the text bar in the Timeline (shown before) to see the context menu: 

 

 

Enable/Disable 

Add area in Timeline 

Delete area in Timline 

Text enters letter by letter 

Text exits letter by letter 

Text enters line by line 

Text exits line by line 

Whole text instantly visible 

Sets play frequency 

Sets uniform play areas 

Resets play area 

Text will be play according to set style and effects. 
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In the picture above you can see three play areas, each with its own style: 

 

The first play area is set to play by letter, 0.2 frequency, with effects shown in the red field. 

 

The second play area is set to play whole text, with effects in the red field. 

 

The third play area is set to play by letter, 0.2 frequency, with effects in the red field. 

Example  

Curl in by letter 

   

Flash whole text 

   

Fade out by letter 

   

Play Frequency and Duration 

Frequency (q) must be between -1.0 and 1.0, used to determine letter/line in time, play time etc.  

1） Frequency only has effect when play by letter/line is set 

2） Frequency can be set in three ways: 

i) Right-click, set frequency from context menu 



Datavideo Technologies Co., Ltd.                                                          125 

 

Enable/disable area 

Add area in current timeline  

Delete selected area 

Play by char (in) 

Play by char(out) 

Play by line(in) 

Play by line (out) 

Play by text 

Frequency value 

Uniform area 

Reset area 

 

ii) Click on the button shown below, choose frequency from drop-down list 

 

iii) Double-click on frequency field, enter number. 

 

After setting frequency, In/Out points and time will be set automatically using this method: 

Play time = T, N. of Items = n, other effect time = t, item = i, then: 

Play item In/Out intervals = t*q 

Play item In/Out = i*t*q 

Play item effect = T/((n-1)*q+1) 

Example: five items in 100 frames 

a. At frequency 1.0 every effect execution time will be 100/((5-1)*1.0+1)=20 frames, 

intervals at 20*1.0=20 frames, as in the example to the right. 

   

At frequency 0.2, every effect execution time will be 100/((5-1)*0.2+1=55 frames, intervals at 
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55*0.2=11 frames, as in the example to the right. 

  
Frequency +/- determines play order. Example: 

Timeline of every item at frequency 0.2 

  

Timeline of every item at frequency -0.2 

  

Play Whole Text 

If set to play as whole text, the entire object will appear instantly. 

Play In/Out by Letter 

In play in/out by letter, every letter will appear according to frequency and effect settings 

 

Scale In By Letter, frequency 0.1 

 

Fade Out By Letter, frequency 0.2 

 



Datavideo Technologies Co., Ltd.                                                          127 

Play In/Out by Line 

In play in/out by line, every line will appear according to frequency and effect settings 

 

Scale In By Line, frequency 0.1 

 

Fade Out By Line, frequency 0.2 

 

Random In/Out Text 

Random Text is a subtitle with special effects, with text entering/exiting the screen randomly line 

by line or word by word. Select as shown below: 
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The arrows show how to select Random mode. 

 

The same method broadcasts different texts randomly into the region. 

 

Set A to play randomly line by line and set B to play randomly word by word, as shown below: 

Play to 1.5 seconds: 

 
Play to 5.0 seconds: 
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Play to 7.0 seconds: 

  

  

Object Group Effect 

Object Groups are special types of objects which can be used to edit multiple shapes (movement, 

scale, rotation, etc.), and can be played independently with many effects. 
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Setting Play Area 

Object Group play areas are similar to Text play areas. The Object Group will play set effects 

within the allotted time in the Timeline. These setting can be changed by right-clicking and using 

the context menu. 

  

In the picture above you can see an example of an Object Group, composed of four objects and 

two texts. 

 

Right-click on the play area to choose play options 

 

Enables play area 

Add area to the current timeline position 

Delete area 

Play as child (individually) 

Play as group 

Make spaces uniform 

Resets play area 

Object Group will be played according to set style and effects.  

In the example above the Object Group is split in two 

Part 1.  Set to play as child, each object will use its own effects. 

Part 2. Set to play as group, all objects will be played using group effects (in this 
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case Curl effects) 

Example: Text moving in from the left, object moving in from the right (play as child) 

Frame 10 

 

Frame 14 

 

Play as child finish 

 
Example: both text and object play out using Curl effect (play as group) 

Frame 30 

 

Frame 40 
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Play as Group 

If set to Play as Group, effects will be played equally to all objects. 

Play as Child 

If set to Play as Child, objects will play their own effects and group effects will be ignored. 

Setting Stay Area 

Setting Stay Area for Title 

If you want to change duration of dynamic title, when setting stay areas, animation effect will not 

be changed. 

Add/Delete Stay Area 

Right click on the space above timeline, and choose “Set Stay Area In” to add a stay area in. You 

can add a stay area out using the same way. 

 

Note: choose options from the context menu to clear stay area, scale stay area and so on. 

Drag in point and out point to change the stay area duration. 
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Sacle Stay Area 

Method 1: right click the stay area and select “Scale Stay Area” from the context menu. 

 

Type in desired timecodes in the popup Scale Stay Area window and then press Enter. 

 

Method 2: hold Ctrl and drag out point to scale. 

 
Example:  
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Object duration changes, when scaling the stay area, but animation effect does not change. 

Create Subtitle 

1) Open CG-500. 

In Text properties tab, enter text or click on “Open” button and choose existing text file. Then 

press Ctrl+A, open the drop-down list of button  and choose “Create Subtitle”. 

 

2) Set the text object bold, font size and set text color.  
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3) Add effect 

In Effect tab, add keyframe and adjust parameters. 

 

You can also double click effect template to apply. 

 

4) Preset subtitle properties 

In Property tab set Effect Mode (Cut, Fade and FX), Align Mode, Play Mode (Interlace and 
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Sequence) and so on. 

 

If you set play properties in Property tab, subtitle will show the properties in CG-500 Player. 

5) Save the subtitle to Template Library when done. 

6) Drag subtitle template to Subtitle List in CG-500 Player. 

Create Roll/Crawl 

The roll screen is often seen at the end of a movie (in the form of credits). In CG-500 you will 

find many powerful roll functions, including 3D roll and Mask roll screens. 

Operation flow 

Most rolls are aligned, and with CG-500 this can be done quickly and conveniently. 

1) In CG-500 choose roll, set roll type (up, right, left), and the software will automatically 

change the current layout into a roll screen. 
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2) Import preset roll screen text onto the Edit Screen. 

 

 

Set Headings: to set multiple headings, hold Ctrl, 

choose headings then press on.  

Heading will turn red. All text under a heading 

will automatically become its content. 

3) Press Ctrl+A to select all text, then press  button. The text will appear in the Edit 

Screen. Press H to centre. Example: 
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4) Set line intervals using parameters in the image below, then click on . 

   

Example: 

   

5) Press  to choose all headings, then apply Shader using the Shader Tab. Example: 

   

The same method can be applied to Contents. 

6) Open the Roll/Crawl Tab to set roll parameters. 
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Here you can set In/Out format, roll area, Liner, Mask and play area. 

7) Save to Template Library when done, and use in CG-500 Player. 

Create 3D roll\crawl 

1) Use the operation flow above to create a roll/crawl screen. 

2) Press F10 to activate Effect Edit Mode, and activate 3D Transform in the Effect Tab. 

3) Click on the Timeline 3D Transform track, and use 3D rotate modulator tools to set roll 

screen rotation angle. 
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Other parameters 

Fade In/Out 

 

Mask 
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Slow-Motion 

 

Dynamic Texture 

When using Shader, other than normal Face, Edge and Shadow bitmap you can also use Dynamic 

Texure properties. When played, the object will display dynamic change effects. More than 100 

preset templates are available. 

Examples: 

 

Applying Dynamic Texture 

1) Create an object or text 

2) In the Shader Tab area, activate Dynamic Texture and set Strength level (0-100). At 0 

Dynamic Texture is not applied, at 100 it completely replaces the current object Shader. 



Datavideo Technologies Co., Ltd.                                                          142 

   

3) Right-click the Dynamic Texture track in the Timeline and a context menu will appear. 
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Modify file 

Adjust duration automatically 

Add a dynamic texture file 

Insert file in current position 

Cut 

Copy 

Paste 

Mask 

Delete file 

Set file play speed 

Delete all files 

Select all files 

4) Choose “Add”, then select from the Dynamic Texture Library. You can make further 

modifications in this screen, including color and play speed. To apply, double-click on the 

template or select first and then click on OK. 

 

5) A bar will appear on the track, 

 

6) Set the file In/Out points to mirror object In/Out points, 

7) Example: 
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Rendering 

1) At any point in time, an object's dynamic texture is unique and can't have more than one. 

The dynamic texture will automatically choose the first Shader property (be it Face, Edge or 

Shadow) 

2) For each layout there can only be one Dynamic Texture track, so all objects will make use of 

this file. 

3) When rendering in real time, if the Dynamic Texture effects cannot be found, the object will 

apply the first Shader property (for example Face or Edge) 

Examples 

Dynamic Texture background 1 

  

Dynamic Texture background 2 

  

Text Face using Dynamic Texture 
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Text and Rectangle Face jointly using Dynamic Texture effects 

  

  

Applying Settings 

Activate system settings 

1) Press shortkey Ctrl+Shift+O. 

2) Click on “System Option” button at bottom right-hand corner. 

   



Datavideo Technologies Co., Ltd.                                                          146 

 

Background Setting 

  

You can set Edit Screen's background as Solid, Grid, Image and save as a background template 
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Solid Color 

Sets one color as Edit Screen background 

Grid Color 

Sets two colors as Edit Screen background 

 

Image Background 

Sets a picture file as Edit Screen background 

  

Background Template 

To save as Background Template 

1) Choose a background style 

2) Choose color or picture file 

3) Click on the “Options” button, from drop-down list choose: 

  

Add: adds background as template 

Import: import a background 

Delete: deletes background template 

Delete All: deletes all templates 
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Keyboard Shortcut 

 
There are four major keyboard shortcut groups that apply to different areas: 

1) Global 

2) Layout 

3) Timeline 

4) Edit Screen 

Note: keyboard shortcuts may be edited in future editions of this software 

User Interface 

 

Edit View Dynamic Zooming - double-click to adjust screen zoom 

Edit View Prompt Message - prompt messages such as "Save File" or "Apply Effect" 
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Timeline View Dynamic Zooming - double-click on the timeline to adjust window zoom 

Auto Load Recent Text File - automatically load last used file at start up 

Font Combo Box Standard Style - set font Standard list or Use Current Font list 

  

Default Imput String - press F2 and preset text will appear in Edit Screen  
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Default Setting 

 

Default Fade In/Out Percent - applies default Fade In/Out settings for effects in the 3D Transform 

timeline track 
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Default Object Length - set default object play duration in the timeline 

Text Setting 

 

Set default input string. 

Special Language Hotkey Process: switch font setting with current font setting 
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File Path Settings 

 
Project Path: sets project path 

Text Path: sets text path 

Image Path: sets image path 

AutoSave Path: sets auto save path 

Subtitle Path: sets subtitle path 

Auto Save 

 

Automatically Save Project: whether save project automatically 

Save every step operation: save every step operation in project 

Automatically save every *** minutes: automatically save project every the specified time 

Max Directory Capacity: set max capacity of auto save path 
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3D View Edit Settings 

 
X Grid Interval: set parameter of X grid interval 

Z Grid Interval: set parameter of Z grid interval 

Axis Line Thickness: set parameter of axis line thickness 

X Axis Line Color: set color of X axis line 

Z Axis Line Color: set color of Z axis line 

Grid Color: set color of grid 

Whether real-time updates Settings: enable/disable real-time update settings 

Export 

Click the marked button to select options. 
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Export Current Layout as Picture 

Method 1: press Ctrl+I or click on “File” in menu bar and “Export Layout” in tool bar, then select 

“Export Current Layout as Picture” from the drop-down list. 

Method 2: right click in Edit Screen and then select “Save Layout as Picture” from the context 

menu. 

 

Then the Save as window will appear. 

 

In the Save as window set path, enter file name and select file save type then click the “Save” 
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button. 

Export Current Frame as Picture 

Click on “File” in menu bar and “Export Layout” in tool bar, then select “Export Current Frame as 

Picture” from the drop-down list. The Save as window will appear. 

 

In the Save as window set path, enter file name and select file save type then click the “Save” 

button. 

Export Current Layout as Movie 

Press Ctrl+E or click on “File” in menu bar and “Export Layout” in tool bar, then select “Export 

Current Layout as Movie” from the drop-down list. The Export Movie window will appear. 
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Setting properties: 

Field Order: select option from the drop-down list. 

 

Clip: set parameters of Top, Bottom, Left and Right after enabling “Clip”.  

 
Set parameters by: 

1. Clicking on the field and typing in the numbers 

2. Dragging the cursor over the field 

3. Moving cursor over the field then clicking on “<, >“ 

Resolution: set parameters of Width and Height.  
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You can also click the marked button shown above then select option from the drop-down list. 

 

Codec: click on the dropdownbutton and then select option from the drop-down list. 

 
File Path: click the “Browse” button, the Save as window will appear. 

 
Select path, enter file name then click on the “Save” button in the Save as window. 

 

Render and Preview: click the “Render” button to render. After rendering, click on the “Preview” 
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button to preview the movie file. 

 

The left button is “Render” and the right is “Preview”. 

Preview: 

 

Export Current Layout as Image Sequence 

Click on “File” in menu bar and “Export Layout” in tool bar, then select “Export Current Layout as 

Image Sequence” from the drop-down list. The Export Movie window will appear. 
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Click on the marked dropdownbutton shown above and then select option from the drop-down 

list. 

 

Please refer to Export Current Layout as Movie about operation. 

Export Current Layout as QuickTime Movie 

Click on “File” in menu bar and “Export Layout” in tool bar, then select “Export Current Layout as 

Quicktime Movie” from the drop-down list. The Export Movie window will appear. 
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Click on the marked dropdownbutton shown above and then select option from the drop-down 

list. 

 

Please refer to Export Current Layout as Movie about operation. 

Export all Layouts as Pictures 

Click on “File” in menu bar and “Export Layout” in tool bar, then select “Export All Layouts as 

Pictures” from the drop-down list. The Save as window will appear. 
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In the Save as window set path, enter file name and select file save type then click the “Save” 

button. 

Export Project include reference files 

Export project include reference files to specified directory. 

Click on “File” in menu bar and “Export Layout” in tool bar, then select “Export Project include 

reference files” from the drop-down list. The Save as window will appear. 

 



Datavideo Technologies Co., Ltd.                                                          162 

In the Save as window set path, enter file name and select file save type then click the “Save” 

button to see the following dialog. 

 

Click the “OK” button, you can open the path and the following will appear. 

Example 

Create Title 

  

1. Text 

1) Enter the text "Heading" font size 32, and "SubHeading" font size 29. 

Method 1: In the Object Menu Bar press , click on the Edit Screen, then enter text. 

 

Method 2: in the Text properties tab, click on  button 
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Method 3: in the Text properties tab, click  button 

 

 Open saved file 
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After text appears in the tab, click on  button 

 

Method 4: use System paste 
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Copy text from desired location 

 

In Object Menu Bar click “Text” button, right-click and paste, or type Ctrl+V to paste. 

 

2) Color 

Method 1: edit color in the Shader tab 

Select "HEADING", click Shader tab, set Gradient as Linear, 90 degrees angle. 
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Add a Gradient point, choose RGB style, and set gradient points to (255, 215, 0, 255), (255, 

128, 0, 255), (130, 0, 0, 255), 
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Choose "SubHeading", enter Shader tab, set RGBA to (232, 232, 232, 255), 

   

Click on  , add Edge, set width to 2, set blur to 0, RGB style, RGBA to (0, 0, 0, 255), 

   

Add Shadow, set width to 5, angle to 45, blur to 3, RGB style, RGBA to (0, 0, 0, 128), 
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Method 2: Double-click on the text and select shader from library. 
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Method 3: Open Shader Template Library, open Single Color catalogue, choose shader 020. 

 

2. Liner 

1) Create liner 

Use Object Menu Bar to create a rectangle on the Edit Screen 
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2) Set shader 

Select object, in  tab choose Gradient-Linear, angle 90, add a Gradient Point, RGB 

style, RGBA parameters at (255,215,0,255), (255,128, 0,255), (130,0,0, 255), 

  

 

Use the same method to create another rectangle 

 

3) Set text and object level 

As the text was created before the object, the object will cover the text. 
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Method 1: Select text, in Edit Menu Bar choose Move Top  from “Level”  

button, or type Ctrl+Home. 

 

Method 2: in the Edit Screen right-click text, from context menu choose “Move Top”,  

 
Method 3: click “Move Top” in Timeline Window, 

 
Method 4: drag text to desired level using the cursor. 
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3. Make Group 

Method 1: select all objects in Edit Scree, then click on   in Edit Menu Bar, or type 

Ctrl+G. 

 

Method 2: Select all objects, right-click then choose “Make Group” from context menu 

 

4. Fade In/Out Animation 

1) Click “Effect Edit Mode” to activate 3D editor. 

 

2) Click  to open Effect tab, activate Transparency Keyframe, set transparency to 

0, open group in Timeline. 
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Double-click expand 3DTransform track and choose "Transparency". 



Datavideo Technologies Co., Ltd.                                                          174 

 

 

3) Move Timeline marker to 1 second,set Transparency to 100. 
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4) Move Timeline marker to 3 seconds, then click “Add/Delet Keyframe” . 
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5) Move Timeline marker to Choice “End” . 

 

 

Set Transparency value to 0. 

 

 

6) Press  button to see Fade In/Out effects. 

 



Datavideo Technologies Co., Ltd.                                                          177 

5. Preview 

   

Create Effect Title 

 

1. Text 

1) Enter Text 

Click , enter "HEADING" font size 20, and "Subheading"font size 37. 

 

2) Shader 

In Shader tab set to RGB style, RGBA parameters at (230,230,230,255) 
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2. Liner 

1) Create liner and shader 

1. Green Rectangle: in Edit Screen create rectangle, open Shader tab, set to RGB, RGBA 

parameters to (23,87,91,255) 

 

   

2. Orange Rectangle: create rectangle, open Shader tab, set to RGB, RGBA parameters to 

(255,123,0,255) 
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3. Red Gradient Rectangle: copy-paste orange rectangle, extend length, open shader tab, 

set Gradient to Linear, add a Gradient Point, set to RGB, RGBA parameters to (41,0, 0, 

255),(160,22,1,255) (85,0,0,255) 

   

4. Adjust objects' position and size 

 

2) Adjust text-object levels so all text is placed on top of the objects. 
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3. Make Group 

1) Select both texts using the Ctrl key, right-click and choose "Make Group" from context 

menu. 

 

2) Use same method to Group all rectangles.The Timeline now has two groups. 
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3) Double-click to edit group names 

 

4) Set names as "Liner" and "Text Group" 

 

4. Create Effect Animation 

1) Add Effect 
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Click on object group, open Effect tab, choose 2D Pan, then click on  

 

2) Set Keyframe 

1. Set 2D Pan direction as Left to Right 

 

2. Activate effect in Timeline . Set percent to 0 at In point 
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3. Set percent to 100 at 1 second 
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4. Set text group animation 2D Pan, Right to Left 

 

5. Activate animation, in Effect tab set percentage to 0 at In point 
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6. Set percentage to 100 at 1 second 

 

 

 

7. In the Edit Screen choose both groups, right-click and choose “Make Group” from 

context menu 



Datavideo Technologies Co., Ltd.                                                          186 

 

8. Hold Shift, drag Group End to 5 seconds on the Timeline 

 

 

9. Set Timeline marker at 4 seconds, right-click on the track shown below, from 

context menu choose "Add Area"  

 

10. Right-click on the track shown, then choose "Play as Child" 

 
11. Add 2D Stretch effect, from Left to Right. 
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12. Adjust effect position and duration 

 

13. At 4 seconds set percentage to 100 
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14. At 5 seconds set percentage to 0 
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5. Preview 

   

                  

Create Button 
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1. Draw Circle 

 

1) From the “Object” Menu Bar, create a circle by holding Ctrl. 

 

 

2) Set Shader: Gradient to Linear, 90 degrees, add Gradient Point, RGB, RGBA parameters 

to (218,83,20,255),(243,181,100,255),(224,182,74,255) 
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3) Add Edge: Width 9, Gradient to Linear, 90 degrees, both Gradient Point RGBA 

parameters set to (255,255,255,255),(55,54,54,255) 
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2. Draw Reflection 

 

1) Using the “Object” Menu Bar, create a large oval-shaped circle, 

 

2) Set Shader: Gradient to Linear, 90 degrees, both Gradient Point RGBA parameters to 

(255,255,255,205),(255,255,255,0), 
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3) Using the “Object” Menu Bar, create a small oval-shaped circle, 

 

4) Set Shader: Gradient to Linear, 90 degrees, both Gradient Point RGBA parameters to 

(255,255,155,182),(255,255,255,19), 
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Create Custom Shape 

 

1. Draw Leaf 

Under the “Objcet” Menu Bar, use the Bezier Curve tools  to draw the following 

lines, 
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2. Draw Apple 
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3. Shader 

1) Make Group 
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2) Set Shader: Gradient to Linear, 90 degrees, RGB, both Gradient Point RGBA parameters 

set to (96,201,21,255),(0,23,0,255) 

 

3) Set Concave effect: Raise mode, Brightness 100, Blur level 2, 45 degree angle, Height 4. 
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Create Play by Character 

 

1. Enter Text and Shader 

1) Using the “Object” Menu Bar “Text” button, enter "Play By Letter", font size 64, and 

press C to centre. 
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2) Shader: from the shader template library double-click on style 039. 

 

 

2. Add Area 

1) Expand text track, drag timeline marker to 1 second, right-click on the Text track, 

choose “Add Area”. In first area, right-click and choose “Play by Character (In)”. 
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2) Drag timeline marker to 2 seconds, right-click and choose “Add Area”. In last area 

right-click and choose “Play by Character (Out)” 
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3) Set play area Frequency: press  to set 0.2 In/Out frequency values. 

 

 

3. Set Keyframe in 3D Transform 

1) Drag timeline marker to start position, open Effect tab, set Translate XYZ positions to 64, 

-74, 0. 
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2) Place timeline marker at Play by Character (In) Out-Point, set Translate to 0, 0, 0 

 

 

3) Set timeline marker at Play by Character (Out) In-Point, click Add Keyframe 
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4) Set timeline marker at Play by Character (Out) Out-Point, set Translate to -64, 74, 0 
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4. Preview 

 

 

Create Play by Line 
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1. Enter Text and Shader 

1) Write "Videostar" three times on three different lines, size 40, press C to centre. 

 

 

 

2) Shader: apply shader 020 from the templates library 
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2. Add area 

1) Extend duration to 6 seconds 

 

 

 

2) Expand tracks, drag timeline marker to 2 seconds, right-click to add area, right-click 

again to set as Play by Line (In) 
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3) Set timeline marker at 4 seconds, right-click to add area, right-click again to set as Play 

by Line (Out) 
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4) Set play area Frequency: press  to set 0.5 In/Out frequency values Set 0.5 

frequency 

 

Set 0.5 frequency 

 

3. Set Keyframe in 3D Transform 

1) Drag timeline marker to start position, open Effect tab, set translate XYZ positions to 0, 

-80, 0 
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2) Place timeline marker at Play by Line (In) Out-Point, set Translate to 0, 0, 0 

 

 

3) Set timeline marker at Play by Line (Out) In-Point, click “Add Keyframe” 
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4) Set timeline marker at Play by Line (Out) Out-Point, set Translate to 0, 80, 0 

 

 

4. Preview 
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Create Mixed Play by Character/Line 

 

1. Enter Text and Shader 

1) Using the “Object” Menu Bar “Text” button, enter "Videostar", font size 48, and press C 

to centre. 
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2) Shader: apply shader 013 from the templates library 

 

 

2. Add area 

1) Extend duration to 6 seconds 
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2) From 0 to 2 seconds, add Play by Character area, frequency value 0.5 

 
3) From 4 to 6 seconds, add Play by Line area, frequency value 0.5 

 

3. Set Keyframe in 3D Transform 

1) Open Effect tab, at 0 seconds toggle XY scale keyframe to 100 each. 
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2) At 1 second set XY scale keyframe to 200 each. 

 

 

3) At 2 seconds, frame 10, set XY scale at 100 each 
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4) At 4 seconds, frame 20, set XY scale to current keyframe 

 

 

5) At 5 seconds, frame 10, set XY scale to 200 each 
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6) At 6 seconds, set XY scale to 0 each 
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4. Preview 

     

               

Create Advanced Animation Keyframe 

Raindrops Animation 

       

1. Create Cloud 

1) Use “Object” Menu Bar to create circles and a round rectangle  
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2) Create Boolean Union      

  

 

3) Set Shader: Gradient to Linear, RGB, RGBA parameters at (210,210,210,255), 

(152,152,152,255), 90 degrees.  
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Add Edge, set to Outer Edge, Width 3, RGB, RGBA parameters at (230,230,230,255). 

 



Datavideo Technologies Co., Ltd.                                                          223 

4) Use “Bezier Curves”  to add cloud reflection. Set reflection: Single color, RGB, 

RGBA parameters at (210,210,210,120) 
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2. Create Raindrop 

1) Use Bezier Curve to draw raindrop 

  
2) Set Shader: Gradient to Linear, 90 degrees, XY axis to (62, 89), RGB, RGBA parameters at 

(110,181,227,255), (12,105,175,255). 

Add Edge, set to Outer Edge, Width 3, Blur 0, RGBA parameters at (220,220,220,255) 
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3. Set Raindrop Animation Keyframe 

1) Reduce raindrop play time, from 4 seconds to 1 second 
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2) At 0 seconds, activate 3D Transfrom Translate (0,5,0), XY scale (0,0), and Transparency 

(100) keyframes.  

 

  

3) Drag timeline marker to frame 15, then set Translate (0,0,0), XY scale (100,100), and 

Transparency (add current) keyframes. 
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4) Drag timeline marker to 1 second, set Transparency to 0 

 

  

5) Make three more copies to create rainfall effect 
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4. Preview 
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Create Progress Bar 

   

1. Liner 

   

2. Color 

1) Select the progress bar high-light, select gradient, 90 degrees, with the RGBA values at 

(188,188,188,200), (255,255,255,0). 
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2) Select the progress bar, select gradient, set RGBA values at (125,34,0,255), 

(208,181,172,255), and adjust gradient position to 17. 

    

3. Merge progress bar and high-light 

1) Click on create group, then name group 
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2) Create Animation: select the group, choose template Wipe001. Click to add special 

effects such as equal length, feather level 2. 

  
Select this template, then click on, 
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4. Percentage Animation 

 

1) Select the numbers tool, set size to17, RGBA to (232,232,232,255) 

 

2) Set digital animation: Check the key frame interpolation, start value 0, end value 100, 

the display format to percentages. 
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5. Preview Animation 

     

                 

Create Roll Up 

Please consult the chapter "Create Roll" for instructions. 

Create Crawl 

1. Crawl Left 

 

2. Create Text 

Enter text in Text tab 
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Click on “One Line Text” to create in Edit Screen 

 

3. Set Parameters 

1) Use the ruler (Tab key) to set roll area 
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2) Set background area 

 

1) Example 
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Render Image 

1. Create Image  

In the Object menu bar press the button . 

 

Drag cursor then release. 

 

Select image file in Property tab. 
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2. Set Parameters 

Check “Use Shaderstyle to Render” and use “Bright Channel” as Alpha channel. Enable 

“Always Use Iamge Color as Face Color” and “Binarization” and set Threshold value. 

 

3. Add Face, Outline, Shadow  

Add Outline 

Click the “Add” button to add an outline in Shader tab. 
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Set color and width, Blur value as 4, 0. 

 
Example: 

 

Add Depth 
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Click the “Add” button to add a depth. 

 

Select Gradient and set width, angle as 24, 59. 

 

Example:  
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Add Shadow 

Click the “Add” button to add a shadow. 

 

Set width, angle and Blur value as 0, 45 and 8. 

 
Example: 
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4. Preview  

 

Create Crawl with Liner 

Crawl 

1. Create text 

Click on the “Object” toolbar and select “Text” button. Then left click in Edit Screen, enter “Crawl 

text”  

 

Then left click in Edit Screen, enter “Crawl text”. Set font size as 68 
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2. Set shader 

In Shader tab, choose color and set shader parameters 

 

 
3. Set CG properties 

Select the text then in CG property tab set Object Type as Text Crawler Object and ID Class as 

Crawl Text. 
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Set other parameters shown above. 

Liner 

1. Create rectangle 

Click on the “Object” toolbar and select “Rect” button. Then create a rectangle as the liner of 

crawl text in Edit Screen. 

 

 
2. Shader  

In Shader tab, set shader parameters 
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3. Set CG properties 

Select the rectangle then in CG property tab set Object Type as Universal Flip Object and ID Class 

as Play Position 
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Edit Crawl Group 

1. Make group 

Select text object and rectangle object and press C to centre. Make text object up. 

Press Ctrl+G or right-click and choose “Make Group” from context menu.  

 

2. Set CG properties 

Click group object. In CG Tab set Object Type as Text Crawler Object and ID Class as Crawl Text. 
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3. Import text 

Select Single Line Text File data source. 

 

Click the “Browse” button to import text file and set loop parameters. 
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4. Preview 

Press F5 to preview 
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Create Flip Stock 

Stock Price Goup Group 

1. Create Text 

Click on the “Object” toolbar and select “Text” button 

 

Then left click in Edit Screen and enter “name” and set font size as 77. 

 

Use the same method to create two text objects stock price and stock change. 

 

2. Crete Liner 

Click on the “Object” toolbar and select “Rect” button. Then create a rectangle as the liner in Edit 

Screen. 

 

 

Shader 

In Shader tab set parameters 
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Create a rectangle again and set shader parameters 

 

In Edit Screen select all objects, set align mode and objects level. Then press Ctrl+G to make 

group. 
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3. Set CG properties 

Hold Ctrl and select “name” and set CG properties in CG property tab. 

 

Use the same method to set CG property foe stock price object and stock change object. 

 

Select the group object and set Object Type as Replaceable Object and ID Class as Stock Price 

Goup Group in CG property tab. 

 

Stock Price Drop Group  

Use same method to make the stock price drop group. Or copy stock price goup group then 
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change properties parameters. 

Set CG parameters for stock price drop group object 

 

 

Stock Price Stop Group 

Use same method to make the stock price stop group. Or copy stock price goup group then 

change properties parameters. 

Set CG parameters for stock price stop group object, 
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Edit Stock Flip Group 

1. Make Group 

Select three groups then press C. Press Ctrl+G to make group. 

 

2. Set CG property 

In CG Tab set Object Type as “Stock Flip Object” 

 

3. Import stock data  

Set data source file as “CSV File”. Click “Browse” button to choose file. 
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Preview 

Press F5 to preview 

 

 

 

Create Crawl Stock 

1. Create Stock Price Goup Group 

1) Create triangle 

Click on the “Object” toolbar and select “Trianglet” button. Then create a triangle in Edit Screen. 
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Shader 

In Shader tab set parameters 
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2) Create text 

Click on the “Object” toolbar and select “Text” button 

 

Then left click in Edit Screen and enter “name” and set font size as 29. 

 

Use the same method to create two text objects stock price and stock change. 

 

Shader 

In Shader tab set stock object color and stock change color same with the triangle color 

 

3) Set CG property 

Select stock name text. In CG property tab set Object Type and ID Class as “Replaceable Object” 

and “Stock Name”.  
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Set CG parameters for stock price text and stock change text, 

 

In Edit Screen select all objects, set align mode and objects level. Then press Ctrl+G to make 

group. 

 

Select group object, set Object Type and ID Class as “Replaceable Object” and “Stock Price Goup 

Group” 

 

2. Create Stock Price Drop Group 

Use same method to make the stock price drop group. Or copy stock price goup group then 

change properties parameters. 
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Set CG parameters for stock price drop group object 

 

 

3. Create Stock Price Stop Group 

Use same method to make the stock price stop group. Or copy stock price goup group then 

change properties parameters. 

Set CG parameters for stock price stop group object 

 

 

Select three groups then press C to centre. 
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4. Create Crawl Position 

Click on the “Object” toolbar and select “Rect” button. Then create a rectangle.  

 

 

Shader  

In Shader Tab double-click on shader style Color0023 
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Select all objects, set align mode and objects level. Then press Ctrl+G to make group. 

 

Select group object. In CG Tab set Object Type as “Stock Crawler Object”, 

 
Set data source file as “CSV File”. Click “Browse” button to choose file 
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Press F5 to preview 

 

 

 

 

Using 3ds max animation in CG-500 

1. Set Frame Rate and Time 

1) Click “Time Configuration”  
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2) In "Frame Rate" select PAL, and in "Animation" enter End Time (25 frames equals 1 

second).Click on “OK”. 

  

2. Choose Field Order 

1) From the Menu Bar click Customize, Preferences 
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2) Open Rendering tab, in Field Order choose Even, click “OK”. 

  

3. Render Setting 

1) Click “Render Scene”  
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2) Open Common tab, set Range, Output Size, and activate Render to Fields. 
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4. Save Setting 

1) In the Render Scene dialog window, click “Files” under Render Output. 

 
2) In Save As, enter Render Output File name, save as Targa Image File. (Here, .tga files 

are used, but .jpg, .png files can also be used). 
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3) In following dialog window set Image Attributes to 32 Bits-Per-Pixel, and activate 

Compress. Click “OK”. 

 

5. Render Animation 

In the Render dialog window, click on “Render” button. 
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6. Change Format 

1) Open MV program, click , then select 3ds max Render Output File. 

 

2) Type Ctrl+A to select all, then click “Open”. 
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3) Set save location 
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4) Click “Render” button 

 

7. Using in CG-500 

1) Open CG-500 in the Object Menu Bar click . A frame will appear in the Edit 

Screen 
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2) In the Properties Tab, click  and open the MV Render Output File. 

      

After Effect Animation in CG-500 

1. New Composition and Composition Setting 

1) Open After Effects, then choose “Composition”, “New Composition” 
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2) In Composition Settings dialogue window, choose size from Preset drop-down list or set 

custom size in Height/Width fields. Set project Duration, then click on “OK”. 

  

2. Render Area 

Drag timeline to set render area 
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3. Render Setting 

1) In Menu Bar choose “Composition”, “Make Movie”. 

  
2) Open Render Queue tab, click “Best Settings”. Choose Upper Field First from Field 

Render drop-down list, then click on “OK”. 
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3) Output Module Settings: in Render Queue tab click “Lossless”, then choose Targa 

Sequence from Format drop-down list. 

  

4) Click “Format Options” button, set Resolution to 32 bits/pixel. Click on OK. 
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5) Under Video Output, choose Straight (Unmatted) color to make object edge look 

smoother. Click on “OK”. 

 

6) Name file: click “comp1[####].tga” button, set save location and enter file name. Click 

on “Save”. 
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7) Click on “Render” to start rendering. 

  

4. Change Format 

Open MV program, import .tga file created in After Effects 
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5. Using in CG-500 

Open CG-500, click  , a frame will appear on the Edit Screen. In Properties Tab open 

MV render output file. 
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Combine Animation with CG-500 Animated Header 

1. Set Keyframe positions 

1) In the Animation Template Library, choose Movie2, "Effects1". Double-click to place in 

Edit Screen. 

Activate the 3D Edit Mode, and set Effect1 Y-axis to 180 (this animation is a flame that 

moves from left to right, but here we invert the direction) 
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2) From the Animation Template Library, choose Movie1, "Redearth". Adjust size and 

position. 

  

3) Set Redearth keyframes: extend duration to 7 seconds 9 frames, then drag timeline 

marker to 0 seconds. In 3D Transform set animation displacement keyframes.  

0 seconds: XYZ (95,0,0), 15 frames: XYZ (0,0,0),6 seconds: XYZ (0,0,0),End point: XYZ 

(95,0,0) 
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2. Background and Text 

1) Use Bezier Curves to draw backgrounds, then insert text. 

  

2) Set upper background color: set to gradient, 99 degree, RGBA (185,125,12,255) and 

(152,19,0,255); concave effect RGBA (255,255,255,255). 
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3) Set lower background color: set to gradient, 85 degree, RGBA (218,168,44,255) and 

(142,23,6,255); concave effect, RGBA (255,255,255,255). 

   
4) Text color: set "HEADING" RGBA to (210,210,210,255), and "Subheading" RGBA to 

(0,0,0,255) 

    

5) Choose "HEADING" and background to make group, then set keyframes and duration as 

shown below 
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6) Choose "Subheading" and background to make group, then set keyframes and duration 

as shown below 
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3. Set position 

 

4. Animation Preview 

     

     

Operation Flow of Plugins 

Operation Flow of Magic Composite 

1. Run Magic Composite Plugin 

Click on “Object” button in tool bar, then choose “Magic Composite” button from the 

drop-down list of “Title Plugin”. 
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2. Create Push Back 

Click the “Push back object” button , press and drag mouse in the Edit Screen. 

 

Release mouse, create a push back object. New pushback object appears in the object layer list. 
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3. Adjust Push Layer Counts 

 

First click to select push in Edit Screen, or in the object layer list click to select. Then click the 

“Down” button under object layer list to change object layer order. 
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4. Bezier Editor 

First select a push object, click the “Bezier Editor” button or double click left mouse button, 

push, and edit Bezier curve. 

 

5. Preview  
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Operation Flow of Text Kerning/Leading Animation 

Click the “Horizontal Text” button to create a text object in Edit Screen of CG-500. After creating 

object, select “Text Kerning/Leading Animation” from the drop-down list of “Title Plugin” in tool 

bar. 

 

Kerning Animation 

1. Set Kerning Animation Mode 

Click the “Align Center” button in menu bar to set kerning animation mode. 

  
2. Keyframe Setting 

Move timeline to 2 seconds, click the “Add/remove keyframe” button in the timeline 

window. 
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Change keyfarme parameter to 100 in Property screen. 

 

Move timeline to 4 seconds in the timeline window then in Property screen set 

parameter as 0. 

 

3. Preview  
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Leading Animation 

1. Set Leading Animation Mode 

Click the “Align Middle” button in menu bar to set leading animation mode. 

 
2. Keyframe Setting 

Move timeline to 0 second, click the “Toggle Animation” button in the timeline window. 
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Move timeline to 2 seconds in the timeline window then in Property screen set parameter as 

100. 

 

 

Move timeline to 4 seconds in the timeline window then in Property screen set parameter as 0. 

 

 

3. Preview  
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Operation Flow of Image Slide Show 

Click on “Object” button in tool bar, then choose “Image Slide Show” button from the drop-down 

list of “Title Plugin”. 

 

1. Import Images 

Click the marked area in the following picture to import images. 

Or click “Import”  to import. 
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After choosing images, click the “Open” button. 

 

2. Set Image Convert Type 

Click “Image Convert Type”, select “Pan & Scan” in the context menu. 

 
Set Size 
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1） Clicking the following buttons can quickly alter size, supported common sizes are full 

screen, 1/4 and 1/8. 

 
2） Move cursor to the control points, press left mouse button and drag. 

 

3. Adjust Image Order 

Left click chosen image, for example Image004, in the image list. Then click the “Delete” 

button to delete the image.  

The buttons on the right side of the list from top to bottom: “Add”, “Delete”, “Empty”, “Up”, 

“Down”, “Move to Home” and “Move to End”. 

 

4. Set Special Effect 

Choose “Custom” in the Effect Option screen. Click “Effect Class”, select “Others” in the 

context menu. 
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Click “Effect Preset”, select “Random” in the context menu. 

 

Click the “Seed” button behind Random Seed.  

Set Picture duration and Effect duration numerical values as 75 and 25. 

 
5. Preview  

 



Datavideo Technologies Co., Ltd.                                                          294 

 

Operation Flow of 2D Stroke Animation 

Click on “Object” button in tool bar, then choose “2D Stroke Animation” button from the 

drop-down list of “Title Plugin”. 

 

1、 Create Stroke Lines 

1. Click “PaintStroke” in the tool bar. 

 

2. Left-click in the Edit Screen, drag mouse to create StrokeLine01. 

 

3. Use the same way to create StrokeLine02 and StrokeLine03. 
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2、 Edit Bezier 

Left-click to select a stroke line in the Edit Screen, then double-click, or click “Bezier” in tool 

bar. 

 
Drag control points to adjust. 

 

3、 Set Properties 
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Set Start Position and End Position 

Left click to select a stroke line (for example StrokeLine 01) in the Stroke Lines List panel. 

Set Start Position, End Position and Stay Time Ratio value as 0, 100 and 0. 

 

Use the same way to set properties parameters for StrokeLine 02 and StrokeLine 03. 

Shader 

Click the Color button behind Solid Color. 

 
Select color in the Color Select window then click the “OK” button. 
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Note: this operation will change color of all stroke lines. 

Set Thickness, Fineness, Feather and Opacity value as 15, 1, 50 and 100. 

 
4、 Logo  

1. Click on the “Logo” button  to open Logo tab. Enable “Insert Tracing Logo”. 
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2. Click the “Browse” button then select a logo, click the “Open” button. 
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3. Left click and drag the hot point to set logo hot point position. 

   

4. Set X Scale value, Y Scale value and Rotate value as 70, 70 and 0. 

 

5、 Preview  
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Operation Flow of Image Four-point Deformation 

Create an image object in Edit Screen, choose “Image Four-point Deformation” button from the 

drop-down list of “Object” in tool bar. 

 

1.  Click on Point1 in Edit Screen, “Add/Remove Keyframe” button after Point1x in timeline 

window, you can apply and add a keyframe at 0 second position. 
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Add a keyframe at 1 second position. 

 

When time is 1 second, set the keyframe value as 20. 

 

2. Click on Point2 in Edit Screen, move timeline to 1 second position, then click on 

“Add/Remove Keyframe” button after Point2x in timeline window, thus, you can apply and 

add a keyframe. 

 

Move timeline to 2 second position, then click on “Add/Remove Keyframe” button to add a 

keyframe. 
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Set the keyframe value as 120. 

 

3.  Click on Point3 in Edit Screen, move timeline to 2 second position, then click on 

“Add/Remove Keyframe” button after Point3x in timeline window. Thus, you can apply and 

add a keyframe. 

 

Move timeline to 3 second position, then click on “Add/Remove Keyframe” button to add a 

keyframe. 

 
Set the keyframe value as 20. 
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4.  Click on Point4 in Edit Screen, move timeline to 3 second position, then click on 

“Add/Remove Keyframe” button after Point4x in timeline window. Thus, you can apply and 

add a keyframe. 

 

Move timeline to 4 second position, then click on “Add/Remove Keyframe” button to add a 

keyframe. 

 

Set the keyframe value as 120. 

 

5.  Preview 
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Operation Flow of Text Path Animation 

1、 Create a curve text in Edit Screen of CG-500. 

 

2、 After creating, select “Text Path Animation” from the drop-down list of “Title Plugin” in tool 

bar. 

 

3、 Move timeline to 0 second position, click the “Toggle Animation” button in the timeline 

window. 

 

In Property tab set parameter as 100. 

  

4、 Move timeline to the tail frame position then click “Add/Remove keyframe” in the timeline 
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window. 

 

Set parameter as -20 in Property tab. 

  

5、 Preview  
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Operation Flow of Shadow 

Create an object in Edit Screen, choose “Shadow” button from the drop-down list of “Object” in 

tool bar. 

 

Back Shadow 

Click on “Back Shadow” button in Property panel. 

 

Click on the Color button, select a color, then press the “OK” button. 

 



Datavideo Technologies Co., Ltd.                                                          308 

Still Shadow 

Step-1 Setting parameters in back shadow properties panel. 

 

Click on “Translation” button in tool bar. 

 
You can also drag control point in editor area to adjust positions in the X and Y axis.  

 

Step-2 Preview 
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Dynamic Shadow 

Step-1 Adjust timeline to 0 second position, click on the “All Parameters Animating” button. 

 

 

Set parameters shown below. 

 

Step-2 Move timeline, then click on the “All Parameters Animating” button. 

 

 

Set parameters shown below. 
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Step-3 Move timeline to the tail frame position, click on “All Parameters Animating” button. 

 

 
Set parameters shown below. 

 

Step-4 Preview 
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Mirror shadow 

Click on the “Mirror Shadow” button in the Property panel. 

 

Still Shadow 

Step-1 Setting parameters in mirror shadow properties window. 
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Click on “Translation” in tool bar. 

 
You can also drag control point in editor area to adjust positions in the X and Y axis. 

 

Step-2 Preview 
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Dynamic Shadow 

Step-1 Adjust timeline to 0 second position, click on the “All Parameters Animating” button. 

 

 

Set parameters shown below. 

 

Step-2 Move timeline, then click on the “All Parameters animating” button. 
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Set parameters shown below. 

 

Step-3 Move timeline, then click on “All Parameters Animating”. 

 

 

Set parameters shown below. 
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Step-4 Preview 
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Slant Shadow 

Click on the “Slant Shadow” button in the Property panel. 

 

Click Color button, select a color, then press “OK” button. 

 

Still Shadow 
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Step-1 Setting parameters in slant shadow properties window. 

 

Click on “Translation” in tool bar. 

 
You can also drag control point in editor area to adjust positions in the X and Y axis. 

 

Click on “Slant” in tool bar. 

 
You can also drag control point in editor area to adjust slant shadow positions in the X and Y axis. 



Datavideo Technologies Co., Ltd.                                                          318 

 

Step-2 Preview 

 
Dynamic Shadow 

Step-1 Adjust timeline to 0 second position, click on “All Parameters Animating”. 

 

 

Set parameters shown below. 



Datavideo Technologies Co., Ltd.                                                          319 

 
Step-2 Move timeline, then click on the “All Parameters Animating” button. 

 

 

Set parameters shown below. 
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Step-3 Move timeline, then click on “All Parameters Animating”. 

 

 

Set parameters shown below. 
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Step-4 Preview. 
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Keyboard Shortcuts 

Common Shortcuts 

F1    -Online Help 

Ctrl+Z   -Cancel Operation 

Ctrl+Shift+Z  -Restore Operation 

CG-500 Shortcut Keys 

File Command Keyboard Shortcut Remarks 

Global 

New Document Ctrl +N  

Save Document Ctrl + S  

Open Document Ctrl + O  

Start Project Ctrl+Shift+N  

Auto Save As Document Ctrl + Shift + S  

CG Preview Play  F5  

3D Stereo Adjust Ctrl+F4  

CG Capture One Frame as EditView 

Background 

Ctrl+F7  

CG Capture Frame F7  

Preview in External Monitor Alt+M  

CG Clear Output F6  

Save Document Animation Alt+S  

Edit Alt+E  

Export Movie Ctrl+E  

Document Settings Ctrl + Shift + P  

Hardware Option Ctrl+Shift+H  

System Option Ctrl + Shift + O  

Tab To Libraray Ctrl + Tab  

Reset Shader Style Ctrl + F10  

Reset text Props Ctrl + F9  

Reset UI Ctrl + F8  

Scroll Edit Mode F11  

template Edit Mode F12  

Effect Edit Mode F10  

Graphics Edit Mode F9  

Edit Only UI F8  

Library F3  

Help F1  
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About Ctrl+F1  

Layout 

Delete Delete  

Paste Ctrl + V  

Cut Ctrl + X  

Copy Ctrl + C  

Bottom End  

Top Home  

Down PageDown  

Up PageUp  

Timeline 

Delete Delete  

Ungroup Ctrl + U  

Make Group Ctrl + G  

Set Objects Duration Ctrl + D  

Play/Stop Space  

Play/Stop In Out Shift+Space  

Objects Trim Out Align End Pos Shift + ]  

Objects Trim In Align End Pos Shift + [  

Objects Move Align Out Point ]  

Objects Move Align In Point [  

Objects Trim In Align Cur Pos Shift+I  

Objects Trim Out Align Cur Pos Shift+O  

Objects Trim out Inc.One K  

Objects Trim out Dec.One J 

Effects Trim out Inc.One Ctrl + K  

 Effects Trim out Dec.One Ctrl + J  

Keyframe Shift Inc.One Shift +.  

Keyframe Shift Dec.One Shift +, 

Effects Shift Inc.One Ctrl +. 

Effects Shift Dec.One Ctrl +, 

Objects Shift Inc.One .  

Objects Shift Dec.One ,  

Expand E  

Zoom Out Ctrl+Num+  

Zoom In Ctrl+Num-  

Fit =  

Move Bottom Ctrl + Home  

Move Top Ctrl + End 

Move Down Ctrl + PageUp 

Move Up Ctrl + pageDown 
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Selection Out Shift + End  

Selection In Shift + Home  

Next Key Frame Down  

Prev. Key Frame Up 

End End  

Home Home 

Next Frame Right  

Prev. Frame Left  

Goto Next Mark Point Shift+Page down  

Goto Prev. Mark Point Shift+Page up  

Goto Out Point W  

Goto In Point Q  

Clear All Mark Point Alt+Shift+M  

Clear In/Out Point X  

Clear In Point Alt+I  

Clear Out Point Alt+O  

Set Mark Point M  

Set In Point I  

Set Out Point O  

Set Pause Point P  

Goto Prev. Pause Point Alt+PageUp  

Goto Next Pause Point Alt+PageDown  

Clear All Pause Point Alt+Shift+P  

Select None Esc  

Select All Ctrl + A  

Edit Alt+E  

Visible V  

Lock L  

Pause To Shift + V  

Paste New Ctrl + V 

Paste All Ctrl + Shift + V  

Copy All Shift + C  

Cut Ctrl + X  

Copy Ctrl + C  

EditView 

Delete Delete  

Play/Stop Space  

Center Pivot Ctrl + M  

Quick Text F2  

Character Map Alt+T  

Guideline G  

Ruler Tab  
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Origin Media Object O  

Alpha A  

Rotate R 

Scale S 

Translate T 

Motion M 

Mix Penetrate Shift + T  

Mix Normal Ctrl + T  

Boolean Intersect Shift + -  

Boolean Xor Shift + =  

Boolean Subtract Ctrl + -  

Boolean Union Ctrl + =  

Same Ver. Space .  

Same Hor. Space , 

Align Ver. Shift + \  

Align Hor. \  

Align Bottom Shift + ]  

Align Top Shift +[  

Align Right ]  

Align Left [  

Hor. Screen Center H  

Ver. Screen Center V  

Screen Center C  

Full Screen F  

Move Bottom Ctrl + End  

Move Top Ctrl + Home  

Move Down Ctrl +Pagedown  

Move Up Ctrl + PageUp  

Zoom Out Ctrl + Num+  

Zoom In Ctrl + Num-  

Actual Size Ctrl + 0  

Fit =  

Select None Esc  

Select All Ctrl + A  

Cut Ctrl + X  

Paste Ctrl + V  

Copy Ctrl + C  

Make Path Group Ctrl + P  

Next CG Subtitle Line PageDown  

Previous CG Subtitle Line PageUp  

Ungroup Ctrl + U  

Make Group Ctrl + G  

Visible Shift + V  
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Lock L  

Some Questions and the Answers 

How to Change Parameter Value 

Parameter Type 1 

 
To set parameters: 

Method 1: move cursor over the field and left click then enter numbers. 

Method 2: move cursor over the field then press the left mouse button and drag right or left. 

Parameter Type 2 

 

To set parameters: 

Method 1: move cursor over the field and left click then enter numbers. 

 

Method 2: move cursor over the field then press the left mouse button and drag right or left. 

Method 3: move cursor over the field then click on “<, >“. 
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Parameter Type 3 

 

Set parameters by: 

Method 1: Dragging the slide marked in green in the image above 

Method 2: please refer to Parameter Type 2 about other methods.  

Parameter Type 4 

 

Set parameters by: 

Method 1: moving cursor over the field then click on “<, >“. 

Method 2: Dragging the cursor over the field. 

Method 3: moving cursor over the field and left click then enter numbers. 

How to Enter Special Characters 

You can enter special charaters for text object, curve object and morph object.  

To enter special characters: 

1. After creating a text object, right click in text and choose"Character Map” from the context 

menu or press Alt+T.  

 

2. Each font type has the corresponding characters in Chracter Map window. Select a font then 

click the desired character in the Chracter Map window.  
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How to Convert Character Case  

You can convert lower case to upper case by using the Small Caps. 

1. Click to select text. 

 

2. Click the “Hide/Show Font AdvProps” button in tool bar then set Small Caps value as 60. 
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How to Scale Shader Style Parameter 

By using the Scale ShaderStyle Parameter, you can scale all shader parameters of Face, Outline, 

Shadow, etc simultaneously.  

1. Click the selected object including face, outline and so on. 
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2. Right click the object then select “Scale ShaderStyle Parameter” from the context menu. 

 

Set Scale Factor parameter in the Scale ShaderStyle Parameter window. The maximum is 200 and 

minimum is -200. You must convert the value to percentage, thus the shader parameter value will 

triple or reduce twice at most. 

 

Set Scale Factor parameter as 200 then click the “OK” button. 
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Example: 

 

Scale Object Data When Video Resolution Is Changed 

1. Click the “System Option” button in state bar, the System Option window will appear. Then 

select “Default Setting” to open the Default Setting panel. 
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2. Check “Scale Object Data when video resolution is changed” and change the Scale Object 

Data Control Factor parameter value. 

3. Click the “Apply” button and then restart CG-500 to apply the change. 

How to Hotkey Process Special Language 

After launching CG-500, you can press F4 to switch current font settings with the special language 

font settings. 

 

To set special language font settings: 

1. Click the “System Option” button in state bar, the System Option window will appear. 

2. Then select “Text Setting” to open the Text Setting panel. 

3. Select font settings in the panel. 



Datavideo Technologies Co., Ltd.                                                          333 
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