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What's new in ThinOS 2402

Citrix Workspace app updates

e Citrix Workspace App (CWA) package version is updated to 23.11.0.82.6, and the package can install the Citrix Workspace
App version 2311 on ThinOS.

e Fixed the issue with video images being stretched in an optimized Microsoft Teams video call. For more information on
enabling this fix, see the Dell ThinOS 2402 Release Notes at www.dell.com/support.

e You can configure the Android smartphone device redirection using Citrix USB File Settings in Citrix Configuration
Editor.

e (Citrix log can be enabled through the Log Level setting in Session Settings > Citrix Session Settings in Wyse
Management Suite.

e Citrix log path is changed from /var/log/citrix to /compat/linux/var/log/citrix.

e You do not need the Citrix VDI Configuration Editor to configure the Citrix keyboard Server default mode and Dynamic
Sync mode.

Authentication using FIDO2 when connecting to on-premises stores is supported with ThinOS 2402.
For Citrix Workspace App limitations, see the Dell ThinOS 2402 Release Notes at www.dell.com/support.

Microsoft RDP and AVD updates

e Microsoft AVD package is updated to version 2.4.2282 in ThinOS 2402.

e For more Microsoft RDP and AVD updates, known issues, and limitations, see the Dell ThinOS 2402 Release Notes at
www.dell.com/support.

Teradici PColP updates

e Teradici version is updated to 23.06.2.18 in ThinOS 2402.
e The Teradici PColP package version 23.06.2.18 cannot be installed on the previous ThinOS release.
e The latest PColP package version 23.06.2.18 must be installed for PColP sessions on ThinOS 2402.

VMware Horizon updates

The Horizon Session SDK package is updated to VMware Horizon 2309.8.11.0.22660930.37.pkg.

The Horizon Client SDK package is updated to VMware Horizon ClientSDK 2309.8.11.0.22660930.46.pkg.
RDP sessions can be displayed and launched in Horizon Broker.

Horizon HTTPs Secure Tunnel can be configured in Horizon Connection Server.

Device certificate authentication is supported in ThinOS Horizon Client SDK 2309.

Horizon Cloud Next Gen is the latest generation of Horizon Cloud and is supported in ThinOS Horizon Client SDK.

Amazon WorkSpaces Client with WSP updates

ThinOS supports Amazon WorkSpaces Client Mode with this ThinOS release.
The supported Amazon WorkSpaces client version is 23.1.4633.

The ThinOS Amazon WorkSpaces Client package version is 23.1.4633.7.

New settings for Amazon WorkSpaces Client with WSP

o Enable Amazon WorkSpaces client mode—The setting enables the Amazon WorkSpaces client to log in to Amazon
WorkSpaces and launch a WSP session.
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o Enable smart card login—The setting must be enabled to use the smart card authentication.
e For limitations and known issues, see the Dell ThinOS 2402 Release Notes at www.dell.com/support

ldentity Automation updates

e Identity Automation Package version is updated to 2.1.0.6.
e Supports Self-Service Password Reset (SSPR).

Imprivata OneSign Authentication updates

The display setting window can be opened in Imprivata PIE mode by using the Windows key and the letter P combination (Win +
P) .

/oom updates

e Zoom package is updated to the Zoom universal package version 5.16.10.24420.5.
o New features

o Sign-in and switch between accounts.

o Quickly create Zoom meetings in Teams chat.

o Disable Zoom notes for meetings.

Lakeside agent updates

e The Lakeside package version 99.0.0.173.3 is supported with ThinOS 2402.
e (o to www.lakesidesoftware.com and follow the steps to install the Lakeside agent.

ThinOS updates

e Improved the ThinOS graphical Ul experience
o Changed the OK button to Save button on most of the windows.
o Switched the position of Save button and Cancel button.
o Updated the Save and WiFi icons.
o You can resize the System Information window to check more event logs.
Updated the shutdown window to display the defer update status.
Improved the operating system, BIOS, and application update process with select group—From ThinOS 2402, if
there is a policy change with a new operating system, BIOS, and applications in the parent select group or registered child
select group, the device downloads the new operating system, BIOS, and applications and installs immediately.

e From ThinOS 2402, a new BIOS boot option DellThinOS Recovery is added in devices from the factory or installed through
an ISO image.
Updated the Enable Schedule Update policy process in Wyse Management Suite and Admin Policy Tool.
A new Save & Reboot button is added that can apply resolution, rotation, and other display changes. Then, the device
restarts automatically.

e Enable Rollback to Last Known Good Status is added in the Troubleshooting section in the General tab in Wyse
Management Suite and Admin Policy Tool.
Improved Wyse 5070 and Wyse 5470 BIOS update process.
Supports new WiFi 6E regions—Mexico and Thailand.
For detailed ThinOS updates, see the Dell ThinOS 2402 Release Notes at www.dell.com/support.
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Wyse Management Suite and Admin Policy Tool updates

@ NOTE: Wyse Management Suite 4.3 server is required for the updates to Admin Policy Tool and Wyse Management Suite
policy settings.

Added Log Level setting in Session Settings > Citrix Session Settings.

Added Show Admin and Shutdown Button in Lock Terminal in Login Experience > Login Settings > Login
Experience.

e Added Enable eMMC Disk Lifetime in Services > WDA Settings.

Added Screen Refresh Rate(Hz) in Peripheral Management > Monitor.
Added the following application package categories:

o Zoom Universal

o ThinOS Telemetry Dashboard

o Lakeside Virtual Agent

o Amazon WorkSpaces Client

Added Telemetry Dashboard in System Settings > Device Monitoring.
Added new BIOS pages for Dell Latitude 5450.

Added Enable Webcam Audio in Peripheral Management > Audio.

Added the ThinOS customized downloads feeds option in Broker Settings > Azure Virtual Desktop Settings, which is
enabled by default.

e Added the Enable Rollback to Last Known Good Status option in Services > Troubleshooting Settings >
Troubleshooting Settings, which is disabled by default.

e Added the Enable Logs Preserved at Reboot option in Services > Troubleshooting Settings > Log Settings, which is
disabled by default.

e Added the Enable Logs Store on Disk option in Services > Troubleshooting Settings > Log Settings, which is disabled
by default.

e Added the Auto Disable Logs Store on Disk option in Services > Troubleshooting Settings > Log Settings, which is
enabled by default .

Added some options in Personalization > Shortcut Keys > Audio Shortcut key.
Added some options in Personalization > Shortcut Keys > Display Shortcut key.
Added some options in Personalization > Desktop > Background Info Settings.
FIDO2 enrollment and authentication are supported in Horizon Workspace One mode.

Added Enable Remote Shadow Watermark and Specify Watermark Message in Services > Remote Shadow
Settings.

Added Device Driver in Peripheral Management.
The Terminal name field does not allow * ' ' characters for security reasons.
The Remote Shadow Password field supports a minimum of eight characters in Services > Remote Shadow Settings.

For detailed Wyse Management Suite and Admin Policy Tool updates, see the Dell ThinOS 2402 Release Notes at
www.dell.com/support
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Introduction

Thin clients running Dell Wyse ThinOS firmware are designed solely for optimal thin client security and performance. These
efficient purpose-built thin clients offer ultrafast access to applications, files, and network resources within Virtual Desktop
Infrastructure (VDI) environments. With zero attack surface, unpublished API, and encrypted data Wyse ThinOS is virus and
malware resistant.

Wyse ThinOS requires a management software to configure, operate, and update thereby eliminating the need for IT support

to visit or touch the physical devices. Dell Wyse Management Suite is the next generation management solution that enables
you to centrally configure, monitor, manage, and optimize your ThinOS-based thin clients. As the number of devices grows, the
Wyse Management Suite offers process automation and helps lower costs for large deployments of thin clients. With secure
HTTPS-based communications and active directory authentication for role-based administration, Wyse Management Suite keeps
your thin clients always up-to-date. The mobile application enables IT to view critical alerts, notifications on the dashboard, and
send real-time commands.

This guide is intended for administrators of thin clients running Wyse ThinOS and using Wyse Management Suite to manage thin
clients. It provides information and detailed system configurations to help you design and manage a ThinOS environment using
Wyse Management Suite.

Supported platforms

The Dell Wyse ThinOS firmware is supported on the following Dell Wyse thin clients:

Wyse 3040 Thin Client

Wyse 5070 Thin Client

Wyse 5470 Thin Client

Wyse 5470 All-in-One Thin Client

OptiPlex 3000 Thin Client

Latitude 3420

OptiPlex 5400 All-in-One

Latitude 3440

Latitude 5440

Latitude 5450

OptiPlex All-in-One 7410

OptiPlex All-in-One 7420

@ NOTE: Wyse 3040 Thin Client is for users who work mostly on tasks with limited multimedia requirements. It is not
applicable for using multimedia such as BCR, HTML 5 video redirection, Window multimedia redirection, RTOP video
call, JVDI video call, enable video or share screen with Microsoft Teams, Webex Meetings, Webex Teams or Zoom. It is
recommended to use other platforms for high multimedia requirements.
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Upgrading the ThinOS firmware

It is recommended to use the Wyse Management Suite version 4.0 or later to upgrade your ThinOS firmware to the latest 9.x
version. You can also use the USB Imaging Tool version 3.4.0 or later to install the ThinOS Merlin image on your thin client.

The overall upgrade process using Wyse Management Suite includes the following tasks:

1. Register your thin client to Wyse Management Suite.

e Register ThinOS devices using Central Configuration. See Register ThinOS devices using Wyse Device Agent.
e Register ThinOS devices using DHCP option tags. See Register devices by using DHCP option tags.
Download the ThinOS operating system image. See Download the ThinOS firmware.

Upgrade the BIOS on your device to the current version mentioned in the BIOS details table below.

Upgrade the ThinOS firmware from 9.x to later versions. See Upgrade ThinOS 9.x to later versions.

Deploy the application packages. See Upload and push ThinOS 9.x application packages.

SLIE I N

The following firmware upgrade scenarios are supported for upgrading to the latest ThinOS version:
e ThinOS 9.1.3129 or later versions > ThinOS YYMM

From ThinOS 2303, Servicing mode has been added to the installation process. The following changes can be observed as part
of this addition:

e Updated the installation order from OS > BIOS > Application to BIOS > OS > Application. After a BIOS update, ThinOS
reboots and then continues to update the operating system. After an operating system update, ThinOS reboots and then
continues to update the application.

e The operating system, BIOS, and applications are downloaded in the background and installed in servicing mode. Click the
download icon on the taskbar to check the download status.

e When ThinOS enters servicing mode, ThinOS automatically logs off when you are logged in. You cannot log in until the
update process is finished.

e |f the update fails, ThinOS automatically exits servicing mode after a countdown. After exiting the servicing mode, you can
log in to continue your work.

The applications that fail to update are displayed in the failed application list.

If you update an invalid application package, like trying to install an application that is released prior or as part of ThinOS
2205, the update fails. Reboot your device and the device does not download and install the invalid application package
again.

e From ThinOS 2308, if the battery charge is lower than 50%, the update process does not start even when the power
adapter is connected. Once the device is charged to 50%, the update process starts.

If you change the WMS server or group in the Central Configuration window when there is a notification window with a new
available firmware or application package upgrade, a dialog box is displayed to notify that the upgrade is going to be terminated.

For detailed information about the upgrade process, see the latest Migration Guide at www.dell.com/support.

Table 1. Firmware images

Platform ThinOS firmware image for upgrading from 9.x to later versions

Wyse 3040 Thin Client ThinOS_YYMM _version.pkg

Wyse 5070 Thin Client

Wyse 5470 Thin Client
Wyse 5470 All-in-One Thin Client
OptiPlex 3000 Thin Client

OptiPlex 5400 All-in-One

Latitude 3420

Latitude 3440

Latitude 5440
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Table 1. Firmware images (continued)

Platform

ThinOS firmware image for upgrading from 9.x to later versions

Latitude 5450

OptiPlex All-in-One 7410

OptiPlex All-in-One 7420

Table 2. Ubuntu to ThinOS conversion image

Platform

ThinOS firmware image for converting from Ubuntu

Latitude 3420

OptiPlex 5400 All-in-One

Latitude 3440

Latitude 5440

Latitude 5450

OptiPlex All-in-One 7410

OptiPlex All-in-One 7420

ThinOS_YYMM_version_Ubuntu_Conversion.zip

Table 3. Package information

Name

Description

Package installation

Citrix_Workspace_App

The package supports the Citrix Workspace app
with RTME client integrated.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Teradici_PColP

The package supports the Teradici PColP
connection.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

VMware_Horizon

The package supports VMware Blast.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

VMware_Horizon_Client
SDK (The package
cannot be installed with
VMware_Horizon
simultaneously)

The package supports VMware Blast.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Imprivata_PIE

The package supports Imprivata with ProvelD
Embedded feature.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Cisco_Jabber

The package supports Cisco Jabber.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Cisco_Webex_Meetings_
VDI

The package supports Cisco Webex Meetings
VDI.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Cisco_Webex_VDI

The package supports Cisco Webex VDI.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Microsoft_AVD

The package supports Azure Virtual Desktop.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Jabra

The package supports Jabra headsets.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

EPOS_Connect

The package supports EPOS Connect.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

HID_Fingerprint_Reader

The package supports HID Fingerprint Reader.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

|dentity_Automation_Qwi
ckAccess

The package supports ldentity Automation.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.
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Table 3. Package information (continued)

Name

Description

Package installation

ControlUp_VDI_Agent

The package supports ControlUp.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

RingCentral_App_VMwar
e_Plugin

The package supports RingCentral.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Common_Printing

The package supports Common Printing.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Liquidware_Stratusphere
_UX_Connector_ID_Age
nt

The package supports Liquidware Stratusphere
UX Connector ID Agent.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Amazon_WorkSpaces_Cli
ent

The package supports Amazon WorkSpaces
Client.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Lakeside_Virtual_Agent

The package supports Lakeside Virtual Agent.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

ThinOS_Telemetry_Dash
board

The package supports the ThinOS Telemetry
Dashboard.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

Zoom_Universal

The package supports the Zoom Universal
package.

Upload the new package using Wyse
Management Suite or Admin Policy Tool.

@ NOTE: If the package fails to update, or if the thin client does not work after upgrading to the new firmware, remove all
packages and reboot the thin client. Reinstall the package after the reboot.

@ NOTE: After upgrading to ThinOS 2402, all application packages that are released before 2205, Microsoft AVD package
that is released before 2311, Zoom AVD, Zoom Citrix, and Zoom Horizon packages are removed automatically and cannot be
installed again. You must install the latest application packages.

Table 4. Tested BIOS versions for ThinOS 2402

Supported platform BIOS version
Wyse 3040 Thin Client 1.2.5
Wyse 5070 Thin Client 1.26.0
Wyse 5470 All-in-One Thin Client 1.22.0
Wyse 5470 Mobile Thin Client 1.21.0
OptiPlex 3000 Thin Client 1.15.0
Latitude 3420 1.33.0
OptiPlex 5400 All-in-One 1.1.36
Latitude 3440 1.9.1
Latitude 5440 1.10.0
Latitude 5450 1.0.2
OptiPlex All-in-One 7410 1.11.0
OptiPlex All-in-One 7420 1.0.0

If you convert a device from another operating system to ThinOS 2303 or later versions or install the ThinOS 2303 or later
recovery image, ThinOS changes BIOS settings when booting for the first time:

BIOS password: Set to Fireport

SATA/NVMe Operation: Set to AHCI/NVMe

Integrated NIC: Set to Enabled (set to disable PXE boot support)
Wake-on-LAN: Set to LAN only
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For OptiPlex 3000 Thin Client with SFP module, the option is set to LAN or SFP NIC.

Enable Secure Boot: Set to ON

Enable USB Boot Support: Set to OFF

Enable USB Wake Support: Set to ON

Deep Sleep Control: Set to Disabled

@ NOTE: Only the devices with BIOS password Fireport or an empty password field applies these changes in BIOS
settings.

Before you upgrade

e If you are using earlier versions of ThinOS 9.x, you must upgrade to ThinOS 9.1.3129 or later versions before upgrading to the
latest version of ThinOS 9.x.

e If you are using ThinOS 8.x, you must upgrade to ThinOS 9.1.3129 or later versions before upgrading to the latest version of
ThinOS 9.x.

@ NOTE: From ThinOS 2205, there's no image to upgrade to the latest ThinOS version from ThinOS version 8.x directly
due to image file size limitation.

e Your system must be powered on and the sleep mode must be disabled on the system. If the system has entered the sleep
mode, you must send the WOL command using Wyse Management Suite before using any real-time commands. To use the
WOL command, ensure that the Wake-On-LAN (WOL) option is enabled in BIOS.

Important notes

e You cannot boot into ThinOS when you perform any of the following operations in BIOS setup:
o Disable the on-board Network Interface Card (NIC), Trusted Platform Module (TPM), or Platform Trust Technology
(PTT).
o Clear TPM or PTT.
o Reset BIOS to factory default settings

e If you power off the ThinOS client by force, a counter in the TPM starts from one. When the counter reaches 32, the client
encounters a Fatal Error. If the error is displayed, do the following:

o For ThinOS 2205 and older versions, you must reimage the device.

o For ThinOS 2208 and later versions, each time the TPM counter reaches 32 and encounters the issue, manually reboot to
recover the client.

Register ThinOS devices to Wyse Management Suite

®| NOTE: DHCP and DNS configurations for Wyse Management Suite work when the ThinOS client is not registered yet..

Register ThinOS devices using Wyse Device Agent

Steps

1. From the desktop menu of the thin client, go to System Setup > Central Configuration.
The Central Configuration window is displayed.

Enter the Group Registration Key as configured by your administrator for the wanted group.
Select the Enable WMS Advanced Settings check box.

In the WMS server field, enter the Wyse Management Server URL.

o b on

To verify the setup, click Validate Key. If the key is not validated, verify the group key and Wyse Management Suite server
URL which you have provided. Ensure that ports mentioned are not blocked by the network. The default ports are 443 and
1883.

®| NOTE: If the Group Token parameter is not specified, the device is moved to the unmanaged group or quarantine group.
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6. Enable or disable CA validation based on your license type. For public cloud, select the Enable CA Validation check box, and
for private cloud, select the Enable CA Validation check box if you have imported certificates from a well-known certificate
authority into your Wyse Management Suite server.

To enable the CA validation option in the private cloud, you must install the same self-signed certificate on the ThinOS
device as well. If you have not installed the self-signed certificate in the ThinOS device, do not select the Enable CA
Validation check box. You can install the certificate to the device by using Wyse Management Suite after registration, and
then enable the CA validation option.

7. Click OK.
The device is registered to Wyse Management Suite.

Register ThinOS devices by using secure DHCP option tags

About this task

You can register the devices by using the following secure DHCP option tags:

®| NOTE: Do not set secure DHCP option tags if your current ThinOS version is earlier than 9.1.6108.

Table 5. Registering device by using secure DHCP option tags

Option Tag Description

Name—WMS The tag specifies the secure Wyse Management Suite server.
Data Type—String
Code—201

Description—Secure WMS Server

Name—Group Registration Key The tag directs the device to fetch the secure Group Registration Key for
Data Type—String Wyse Management Suite.
Code—202

Description—Secure Group Token

Name—CA Validation You can enable or disable CA validation option if you are registering your
devices with Wyse Management Suite on private cloud.

Data Type—String

Enter True, if you have imported the SSL certificates from a well-known
Code—167 authority for https communication between the client and the Wyse
Description—Certificate Authority Validation | Management Suite server.
Enter False, if you have not imported the SSL certificates from a well-known

authority for https com@Wedding2020munication between the client and the
Wyse Management Suite server.

@ NOTE: CA Validation is optional for Wyse Management Suite 2.0 and later
versions. However, Dell Technologies recommends to configure this option
tag.

@ NOTE: If you use both secure DHCP option tags and legacy DHCP option tags to register devices, secure DHCP option
tags take priority over legacy.

To get secure Wyse Management Suite server and secure Group Registration Key, do the following:

Steps

Go to WMS Server > Portal Administration > Console Settings > WMS Discovery.
Enter the group token.

Select DHCP from the Discovery Type drop-down list.

Click Generate Details.

N
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@ NOTE: Do not set predefined string values for DHCP option tag 201 and 202 as the predefined values are limited to 255
characters while the secure Wyse Management Suite server and secure Group Registration Key can accommodate more
than 255 characters. Copy the secure Wyse Management Suite server and secure Group Registration Key and set the
DHCP option tag 201 and 202 string values manually.

Register ThinOS devices by using legacy DHCP option tags

About this task

You can register the devices by using the following legacy DHCP option tags:

Table 6. Registering device by using legacy DHCP option tags

Option Tag

Description

Name—WMS

Data Type—String

Code—165

Description—WMS Server FQDN

This tag points to the Wyse Management Suite server URL. For example,
wmsserver.acme.com, where wmsserver.acme.com is fully qualified domain
name of the server where Wyse Management Suite is installed.

®| NOTE: HTTPS:// is not required in the Wyse Management Suite URL.

Name—MQTT

Data Type—String
Code—166
Description—MQTT Server

This tag directs the device to the Wyse Management Suite Push Notification

server (PNS). For a private cloud installation, the device gets directed to

the MQTT service on the Wyse Management Suite server. For example,

wmsservername.domain.com:1883. WDA automatically fetches the

MQTT details when devices check in for the first time.

@ NOTE: MQTT is optional for Wyse Management Suite 2.0 and later
versions.

Name—CA Validation

Data Type—String

Code—167

Description—Certificate Authority Validation

You can enable or disable CA validation option if you are registering your
devices with Wyse Management Suite on private cloud.

Enter True, if you have imported the SSL certificates from a well-known
authority for https communication between the client and the Wyse
Management Suite server.

Enter False, if you have not imported the SSL certificates from a well-known
authority for https com@Wedding2020munication between the client and the
Wyse Management Suite server.

@ NOTE: CA Validation is optional for Wyse Management Suite 2.0 and later
versions. However, Dell Technologies recommends to configure this option
tag.

Name—Group Registration Key
Data Type—String
Code—199

Description—Group Registration Key

This tag directs to the Group Registration Key for the Wyse Management Suite
agent. For example, in SCDA-DTos91SalesGroup, for the second part of the
Group registration key, you must use 8-31 characters, with at least 1 upper,
1lower, 1 number, 1 special character. However, special characters such as
\(backslash), "(double quotes), '(single quote) are not allowed.

@ NOTE: Group Token is optional for Wyse Management Suite 2.0 and later
versions on private cloud. However, there is a known issue that if you do
not provide the group token, the device is not moved to unmanaged group.
Therefore, It is recommended to configure the Group Token key.

Register devices using secure DNS records

Steps

1. On the Wyse Management Suite server, go to Portal Administration > WMS Discovery.
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Specify the Wyse Management Suite URL, Group Token, select DNS as the Discovery Type and click Generate Details to
get the Wyse Management Suite URL and Group Token encrypt strings.
In the DNS server, go to DNS > DNS Server Host Name > Forward Lookup Zones > Domain and right-click the domain.
Click Other New Records.
Select Text (TXT), click Create Record, and do the following:
e To create the Wyse Management Suite Server record, enter the following values, and click OK.
o Record name—_WMS_MGMTV2.
o Text—Wyse Management Suite URL encrypt strings from Step 2.
e To create the Wyse Management Suite Group Token record, enter the following values, and click OK.
o Record name—_WMS_GROUPTOKENV2.
o Text—Group token encrypt strings from Step 2.
e To create the Wyse Management Suite CA validation record, enter the following values, and then click OK.
o Record name—_WMS_CAVALIDATION
o Text—TRUE/FALSE

If you have not registered your ThinOS client to Wyse Management Suite and if you have set the DNS server with records,
the device will automatically register to Wyse Management Suite.

@ NOTE: If both secure DNS records and legacy DNS records are set in the DNS server, the secure DNS records take
priority.

Register devices using legacy DNS records

Steps

1

In the DNS server, go to DNS > DNS Server Host Name > Forward Lookup Zones > Domain > _tcp, and right-click the
_tcp option.
Click Other New Records.
The Resource Record Type window is displayed.
Select the Service Location (SRV), click Create Record, and do the following:
To create Wyse Management Suite server record, enter the following details and click OK:
e Service—_ WMS_MGMT
e Protocol—_tcp
e Port number—443
e Host offering this service—FQDN of WMS server
Go to DNS > DNS Server Host Name > Forward Lookup Zones > Domain, and right-click the domain.
Click Other New Records.
Select Text (TXT), click Create Record, and do the following:
e To create Wyse Management Suite Group Token record, enter the following values, and click OK:
o Record name—_WMS_GROUPTOKEN
o Text—WMS Group token
e To create Wyse Management Suite CA validation record, enter the following values, and then click OK:
o Record name—_WMS_CAVALIDATION
o Text—TRUE/FALSE

Enable Live Update

Steps

N
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Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
Click the Advanced tab.

Expand Services, and click WDA Settings.

Enable or disable Enable Live Update.

If enabled, the thin client starts downloading the firmware and package immediately. If the Live Update option is disabled,

the thin client cannot download and install any firmware or package until the next reboot. However, the firmware or

packages are downloaded in the following scenarios even when the Live Update option is disabled:
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e When you register the thin client to Wyse Management Suite manually.

e \When you power on the thin client from a power off state.
e When you change the Wyse Management Suite group.

5. Click Save & Publish.

@ NOTE: In ThinOS 2303, the operating system firmware and BIOS firmware downloads in the background. If the Live
Update option is disabled, the thin client downloads the operating system firmware and BIOS firmware but cannot

complete installation until the next reboot.

Download the ThinOS firmware, BIOS, and application

packages

About this task

This section describes the steps to download the ThinOS firmware, BIOS, and application packages from the Dell support site.

Steps

1. Go to www.dell.com/support.

2. In the Enter a Service Tag, Serial Number, Service Request, Model, or Keyword field, type the model number of your

device.

. Select the product from the search results to load the product page.

. On the product support page, click Drivers & downloads.

3
4
B. Select the operating system as ThinOS <version>.
6

. Locate the ThinOS image entry and download the image.

Table 7. ThinOS 2402 image

Scenario

ThinOS image title

Upgrade your ThinOS 9.1.3129 or later versions to 2402
(9.5.1079)

ThinOS 9.1.3129 or later to ThinOS 2402 (9.5.1079) Image
file for Dell Wyse 3040, 5070, 5470 and 5470 All-in-One
Thin Clients, Dell OptiPlex 3000 Thin Client, Dell Latitude
3420, 3440, 5440 and 5450, Dell OptiPlex 5400 All-in-One,
Dell OptiPlex All-in-One 7410, and Dell OptiPlex All-in-One
7420

Ubuntu to ThinOS 2402 conversion image

ThinOS 2402 Ubuntu conversion image for Dell Latitude
3420, 3440, 5440, and 5450, Dell OptiPlex 5400 All-in-One,
Dell OptiPlex All-in-One 7410, and Dell OptiPlex All-in-One
7420

7. If you want to use ThinOS packages, locate a package and download the package to your device.

NOTE: For a given ThinOS release, you can install only the supported packages that are mentioned in the corresponding

ThinOS Release Notes available at www.dell.com/support.

Table 8. ThinOS packages

ThinOS packages ThinOS image title

All-in-One 7420

Citrix_Workspace_App ThinOS YYMM <version> Citrix package <version> for Dell Wyse 3040, 5070, 5470 and
5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One, Latitude
3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and OptiPlex

OptiPlex All-in-One 7420

VMware_Horizon ThinOS YYMM <version> VMware Horizon package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
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Table 8. ThinOS packages (continued)

ThinOS packages

ThinOS image title

VMware_Horizon_Client
SDK (The package
cannot be installed

with VMware_Horizon
simultaneously)

ThinOS YYMM <version> VMware Horizon package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Teradici_PColP

ThinOS YYMM «<version> Teradici PColP package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Microsoft_AVD

ThinOS YYMM <version> Microsoft AVD package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Imprivata_PIE

ThinOS YYMM <version> Imprivata package <version> for Dell Wyse 3040, 5070, 5470 and
5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One, Latitude
3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and OptiPlex
All-in-One 7420

Zoom_Universal

ThinOS YYMM <version> Zoom Universal package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Jabra

ThinOS YYMM <version> Jabra headsets package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

EPOS_Connect

ThinOS YYMM <version> EPOS Connect package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Cisco_WebEx_VDI

ThinOS YYMM «<version> Cisco Webex VDI package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Cisco_WebEx_Meetings_V
DI

ThinOS YYMM <version> Cisco Webex Meetings package <version> for Dell Wyse 3040,
5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

Cisco_Jabber

ThinOS YYMM <version> Cisco Jabber package <version> for Dell Wyse 3040, 5070, 5470
and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

HID_Fingerprint_Reader

ThinOS YYMM <version> HID Fingerprint Reader package <version> for Dell Wyse 3040,
5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

|dentity_Automation_Qwic
kAccess

ThinOS YYMM <version> Identity Automation QwickAccess package <version> for Dell Wyse
3040, 5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

ControlUp_VDI_Agent

ThinOS YYMM <version> ControlUp VDI Agent package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420
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8.

Table 8. ThinOS packages (continued)

ThinOS packages

ThinOS image title

RingCentral_App_VMware
_Plugin

ThinOS YYMM «<version> RingCentral App VMware Plugin package <version> for Dell Wyse
3040, 5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

Common_Printing

ThinOS YYMM <version> Common printing package <version> for Dell Wyse 3040, 5070,
5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One,
Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and
OptiPlex All-in-One 7420

Liquidware_Stratusphere_
UX_Connector_ID_Agent

ThinOS YYMM «<version> Liquidware package <version> for Dell Wyse 3040, 5070, 5470 and
5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400 All-in-One, Latitude
3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One 7410, and OptiPlex
All-in-One 7420

Amazon_WorkSpaces_Clie
nt

ThinOS YYMM <version> Amazon WorkSpaces Client package <version> for Dell Wyse 3040,
5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

Lakeside_Virtual _Agent

ThinOS YYMM <version> Lakeside Virtual Agent package <version> for Dell Wyse 3040,
5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

ThinOS_Telemetry_Dashbo
ard

ThinOS YYMM <version> ThinOS Telemetry Dashboard package <version> for Dell Wyse
3040, 5070, 5470 and 5470 All-in-One Thin Clients, OptiPlex 3000 Thin Client, OptiPlex 5400
All-in-One, Latitude 3420, Latitude 3440, Latitude 5440, Latitude 5450, OptiPlex All-in-One
7410, and OptiPlex All-in-One 7420

®

NOTE: After you upgrade the client, install the Citrix Workspace app package first, and then reinstall the Citrix-related
application packages such as Cisco WebEx Meeting or HID.

If you want to install the latest BIOS package, locate the package entry—ThinOS <version> BIOS package <version>—
for your thin client model and click the download icon.

®

NOTE: For more information about BIOS installation, see BIOS Installation.

File naming convention

ThinOS application packages, ThinOS firmware, BIOS packages, and other files can be published from the Wyse Management
Suite server and support the following characters in their file names:

Uppercase letter
Lowercase letter
Numeric character

Special characters—period (.), hyphen-minus (-), and underscores (_)

If you use other characters in file names, the file installation fails.

Upgrade ThinOS 9.x to later versions using Wyse
Management Suite

Prerequisites

Ensure that you are running 9.1.3129 or later versions on your thin client.
Create a group in Wyse Management Suite with a valid group token. Use this group token to register the ThinOS 9.x devices.
Register your thin client to Wyse Management Suite.
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Steps

1. Go to the Groups & Configs page, and select a group.

2. From the Edit Policies drop-down menu, click ThinOS 9.x.
The Configuration Control | ThinOS window is displayed.

3. Click Advanced.
4. In the Firmware field, select OS Firmware Updates.

5. Click Browse to browse and upload the firmware.
The EULA details of the package and the name of the vendors are displayed.

6. Click the vendor names to read the license agreement of each vendor and then click Accept to upload the package.

You can select the Do not show this again if you do not want to see the EULA details of the same vendor again.
@ NOTE: If you upload multiple packages, the EULA details of each package are displayed. You must accept the license
agreement of the packages individually. The firmware is not uploaded if you click Decline.

7. From the Select the ThinOS Firmware to deploy drop-down menu, select the uploaded firmware.

8. Click Save & Publish.
The thin client downloads the firmware and restarts. The firmware version is upgraded.

Upgrade ThinOS 9.x to later versions using Admin
Policy Tool

The firmware upgrade using Admin Policy Tool is supported on ThinOS 9.x.

Prerequisites

Ensure that you are running ThinOS 9.1.3129 or later versions on your thin client.

Steps

Go to the Admin Policy Tool on the ThinOS client.

In the Configuration Control | ThinOS window is displayed. Click Advanced.

In the Firmware field, select OS Firmware Updates.

Click Browse to browse and upload the firmware from USB drive.

From the Select the ThinOS Firmware to deploy drop-down menu, select the uploaded firmware.

Click Save & Publish.
The thin client downloads the firmware and restarts. The firmware version is upgraded.

Convert Ubuntu with DCA to ThinOS

Prerequisites

N N NS

Table 9. Supported conversion scenarios

Platform Ubuntu version DCA-Enabler version
Latitude 3420 20.04 1.7.1-61 or later
OptiPlex 5400 All-in-One 20.04 1.7.1-61 or later
Latitude 3440 22.04 1.7.1-61 or later
Latitude 5440 22.04 1.7.1-61 or later
Latitude 5450 22.04 1.7.1-61 or later
OptiPlex All-in-One 7410 22.04 1.7.1-61 or later
OptiPlex All-in-One 7420 22.04 1.7.1-61 or later
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Ensure that DCA-Enabler is installed on your Ubuntu devices according to the above table. For details on how to install
DCA-Enabler in the Ubuntu operating system and upgrade it, see the latest Dell ThinOS Migration Guide at www.dell.com/
support. For detailed DCA-Enabler version and ThinOS version conversion scenarios, see the latest Dell ThinOS Release Notes at
www.dell.com/support.

@ NOTE: The Ubuntu device must have a factory-installed Ubuntu operating system. If you have custom installed the
Ubuntu operating system, you cannot convert it to ThinOS.

Wyse Management Suite version 4.0 or later versions must be used to convert to ThinOS.

Ensure that you have connected the device to the external power source using the power adapter.

Ensure you have enough ThinOS Activation devices licenses on Wyse Management Suite.

Create a group in Wyse Management Suite with a group token.

The ThinOS Activation devices license number of Wyse Management Suite must be larger than the Ubuntu device number. If
it is not, you cannot create the Advanced Policy for conversion.

The Ubuntu devices must be registered to Wyse Management Suite as generic clients. For details on how to register generic
clients to Wyse Management Suite, see the latest Dell ThinOS Migration Guide at www.dell.com/support.

Ensure you have downloaded the Ubuntu to ThinOS conversion image.
Extract the Ubuntu to ThinOS conversion image to get the Conversion Installer file DTOS_Ubuntu_Installer_x.x-dtosx-
amd64_signed.tar.gz and ThinOS image ThinOS_YYMM_9.x.pkg.

®| NOTE: The ThinOS image ThinOS_YYMM_9.x.pkg can be used for downgrading in the future.

Steps

N NN

® N

10.

1.

12.
13.

Go to Apps & Data > App Inventory > Generic Client, and click Add Package file.

Upload the Conversion Installer file DTOS_Ubuntu_Installer_x.x-dtosx-amd64_signed.tar.gz

Go to Apps & Data > OS Image Repository > ThinOS 9.x, and click Add Firmware file.

Upload the ThinOS image ThinOS_YYMM_9.x.pkg.

Go to Apps & Data > App Policies > Generic Client, and click Add Advanced Policy.

Enter the policy name, select the group in which the Ubuntu device has been registered, and select Generic Client as OS
type.

Click Add app, and select the Conversion Installer file that was uploaded before from the drop-down menu.
Click Add app again, and select the ThinOS image file that was uploaded before from the drop-down menu.
Select all the platforms that you want to convert in the Platform Filter drop-down menu.

Click Save.

®| NOTE: Ensure that the Apply Policy Automatically option is set to Do not apply automatically.

In the dialog window, click Yes to schedule a job.
Select Immediately in the Run drop-down menu on the App Policy Job window, and click Preview.

Click Schedule.

The Conversion Installer file downloads and installs first followed by the ThinOS image on Ubuntu device. After installation,
the device restarts automatically.

@ NOTE: After you register the converted ThinOS device to Wyse Management Suite, the ThinOS activation devices

license is consumed automatically.

@ NOTE: After conversion, ThinOS is in the factory default status. ThinOS must be registered to Wyse Management Suite
manually or using DHCP/DNS discovery.

@ NOTE: If the conversion has failed, you can see the error log table below and reschedule the job. Go to Jobs >
Schedule APP Policy to reschedule the job.

®| NOTE: If the conversion has failed, it is recommended to install the ThinOS ISO image.

If there is a /usr/dtos folder in the Ubuntu device, then you can use command “cat /var/log/
dtos_dca_ installer.log” to getan error log. If there is no /usr/dtos folder present in the device that runs Ubuntu,
go to Jobs in Wyse Management Suite server to check the error messages.

Table 10. Error log

Error Log Resolution

No AC plugged in Plug in power adapter, reschedule job

Upgrading the ThinOS firmware 27


HTTPS://WWW.DELL.COM/SUPPORT/HOME/EN-US
HTTPS://WWW.DELL.COM/SUPPORT/HOME/EN-US
https://www.dell.com/support/home/en-us

Table 10. Error log (continued)

Error Log

Resolution

Platform Not Supported

This hardware platform is not supported.

Error mounting recovery partition

The Ubuntu image is not a factory image. Reinstall the
factory image.

No DHC/ThinOS package in recovery partition

Cannot find the ThinOS image, reschedule job.

Error in extracting DHC/ThinOS Future packages

Failed to extract the ThinOS image, reschedule job

Error copying the DHC/ThinOS Future packages to recovery
partition

Failed to copy the ThinOS image, reschedule job

ThinOS package verification failed

ThinOS image is not correct, reschedule job with the correct
ThinOS image.

Not enough space in Recovery Partition

Clear the recovery partition.

The free space of Recovery Partition is not enough.

Clear the recovery partition.

Add ThinOS application packages to the repository

Steps

1

2.
3.

Log in to Wyse Management Suite using your tenant credentials.
In the Apps & Data tab, under OS Image Repository, click ThinOS 9.x.

Click Add Package file.
The Add Package screen is displayed.

To select a file, click Browse and go to the location where your file is located.

e |f the EULA is embedded in the package, the EULA details of the package and the name of the vendors are displayed.
You can click the vendor names to read the license agreement of each vendor. Click Accept to upload the package. You
can select the Do not show this again if you do not want to see the EULA details of the same vendor again. You must
accept the license agreement of the packages individually. The package is not uploaded if you click Decline.

e |f the EULA is not embedded in the package, go to step b.
Click Upload.

NOTE: The operator can upload the package from operator account and is visible to all the tenants. Tenants cannot

delete or modify these files.

Convert Windows 10 loT to ThinOS 2306

Prerequisites

28

Supported scenarios

Table 11. Supported conversion scenarios

Platform

Windows 10 loT version

WDA version

Wyse 5070 Thin Client

Wyse 5470 All-in-One Thin Client

Wyse 5470 Mobile Thin Client

Windows 10 Enterprise 2019 LTSC-MR2

14.6.9.x

OptiPlex 3000 Thin Client

Windows 10 loT Enterprise LTSC 2021

Ensure that you are running Windows 10 IoT version and WDA version according to above table.

You must use Wyse Management Suite 4.1 or later versions.

Ensure that there are enough ThinOS Activation device licenses on Wyse Management Suite 4.1 or later versions.

Create a group in Wyse Management Suite with a group token.
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The Windows loT devices must be registered to Wyse Management Suite.
Ensure that the power adapter is connected to the device.
Ensure that you have downloaded the Windows IoT to ThinOS 2306 conversion image.

Extract the Windows IoT to ThinOS 2306 conversion image to get the Conversion Installer file
ThinOS Conversion Tool.exe and the ThinOS image ThinOS_ 2306 _9.4.2103.pkg.

Steps

1
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Copy the conversion Installer file ThinOS Conversion Tool.exe to the Wyse Management Suite 4.1 or later version
server repository. The server can be located by going to Repository Location > repository > thinClientApps.

On the Wyse Management Suite page, go to Portal Administration > File Repository.
Select the repository and click Sync Files. Wait for the synchronization to complete.
Go to Apps & Data > OS Image Repository > ThinOS 9.x.

Click Add Firmware file.

Upload the ThinOS image ThinOS_ 2306 _9.4.2103.pkg.

Go to Apps & Data > App Policies > Thin Client.

Click Add Advanced Policy.

Enter the policy name, and select the Windows 10 loT devices registered group.

. Select WinloT as OS type.

. Check the Show conversion packages checkbox.

. Click Add app, and select the conversion Installer file from the drop-down list.

. Click Add app, and select the ThinOS image file from the drop-down list.

. Ensure that the Apply Policy Automatically option is set to Do not apply automatically.
. Click Save.

. When prompted, click Yes to schedule a job.

. For the Run option in App Policy Job window, select Immediately.

. Click Preview.

. Click Schedule in the next window.

The Windows loT devices download the Conversion Installer file and the ThinOS image after which, installation begins. After
rebooting four times, the conversion is complete, and the device auto boots to ThinOS.

Important Notes

e |f device is not connected to a power adapter, conversion fails.
The ThinOS Activation devices license number of Wyse Management Suite must be larger than Windows loT device
number, or you cannot create Advanced Policy for conversion.

e After conversion, ThinOS is in factory default status. You must register ThinOS to Wyse Management Suite manually or
by DHCP/DNS discovery.

e After you register the converted ThinOS devices to Wyse Management Suite, the ThinOS Activation devices license is
consumed. After consuming the license, the conversion job is completed.

e |f conversion fails, resolve the issue according to error log at C: \Wyse\Dtos\TRT\DtosConversion.log and
reschedule the job from Jobs > Schedule APP Policy. If conversion fails, It is recommended that you install the ThinOS
ISO image.

Limitations

e If the Trusted Platform module (TPM) is locked, conversion fails. If you see the message Error : Clear the TPM
Manually from BIOS Settings and retrigger Conversion from WMS in DtosConversion.log, clear the TPM
manually in BIOS setup. Go to BIOS Setup > Security > TPM and check the Clear checkbox.

e |f the message A configuration change was requested to clear this computer's TPM (Trusted Platform Module)
is displayed, press the F12 key to clear the TPM and continue conversion process.

Convert ThinLinux to ThinOS 2306

Prerequisites

Supported scenarios
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Table 12. Supported conversion scenarios

Platform ThinLinux version WDA version

Wyse 3040 Thin Client 2.2.1.04 3.5.2-05
Wyse 5070 Thin Client

Wyse 5470 Mobile Thin Client

e Ensure that you are running ThinLinux version and WDA version according to above table.
e You must use Wyse Management Suite 4.1 or later versions.
e Ensure that there are enough ThinOS Activation device licenses on Wyse Management Suite 4.1 or later versions.
e Create a group in Wyse Management Suite with a group token.
e The ThinLinux devices must be registered to Wyse Management Suite.
e Ensure that the power adapter is connected to the device.
e Ensure that you have downloaded the ThinLinux to ThinOS 2306 conversion image.
e Extract the ThinLinux to ThinOS 2306 conversion image to get the Conversion Installer file merlin-
nonpxe 4.1.1-01 amdé64.deb and the ThinOS image ThinOS 2306 _9.4.2103 TL Conversion.exe.
Steps

1. Copy the conversion Installer file merlin-nonpxe 4.1.1-01 amd64.deb to the Wyse Management Suite 4.1 or later
version server repository. The server can be located by going to Repository Location > repository > thinClientApps.

2. Copy the conversion image ThinOS 2306 _9.4.2103 TL Conversion.exe to the Wyse Management Suite 4.1 or later
version server repository. The server can be located by going to Repository Location > repository > osimages > zipped.

3. On Wyse Management Suite page, go to Portal Administration > File Repository.
4. Select the repository and click Sync Files. Wait for the synchronization to complete.
5. Go to Apps & Data > App Policies > Thin Client

6. Click Add Advanced Policy.

7. Enter the policy name and select the group with registered ThinLinux devices.

8. Select ThinLinux as OS type

9. Click Add app, and select the conversion Installer file from the drop-down list.

10. Ensure that the Apply Policy Automatically option is set to Do not apply automatically.
11. Click Save.

12. When prompted, click Yes to schedule a job.

13. For the Run option in App Policy Job window, select Immediately.

14. Click Preview.

15. Click Schedule in the next window.
The ThinLinux device downloads the conversion Installer file after which, installation begins.

16. Ensure that the conversion image is in the repository by going to Apps & Data > OS Image Repository > WinloT/
ThinLinux

17. Go to Apps & Data > OS Image Policies > WinloT/ ThinLinux and click Add Policy.
18. Enter the policy name, and select the ThinLinux devices registered group.

19. Select ThinLinux as OS type

20. Select ThinLinux 2.x as OS Subtype Filter.

21. Select OS Image as the conversion image.

22.Select Force this version as Rule.

23. Ensure that the Apply Policy Automatically option is set to Do not apply automatically.
24.Click Save.

25. When prompted, click Yes to schedule a job.

26.For the Run option in App Policy Job window, select Immediately.

27. Click Preview.

28.Click Schedule in the next window.
The ThinLinux device downloads the conversion image after which, installation begins. After installation, the devices
automatically reboot to ThinOS.

Important Notes
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Enhancements to the Application Package Updates

e |f device is not connected to a power adapter, conversion fails.

The ThinOS Activation devices license number of Wyse Management Suite must be larger than ThinLinux device number,

or you cannot create Advanced Policy for conversion.

e After conversion, ThinOS is in factory default status. You must register ThinOS to Wyse Management Suite manually or

by DHCP/DNS discovery.

e After you register the converted ThinOS devices to Wyse Management Suite, the ThinOS Activation devices license is
consumed. After consuming the license, the conversion job is completed.

category

When you click Browse to upload the application packages, all the application packages are available in the same drop-down

list before. From ThinOS 2208, categories are added to improve the visibility of the application packages. The following are the
defined categories:

1

Citrix

e Citrix Workspace App

VMware

e VMware Horizon

Microsoft

e Microsoft AVD

Zoom

e Zoom Universal

e Zoom Citrix (not supported from ThinOS 2402)
e Zoom Horizon (not supported from ThinOS 2402)
e Zoom AVD (not supported from ThinOS 2402)

Cisco

e Cisco Jabber

e Cisco Webex Meetings VDI

e Cisco Webex VDI

Dell

e Security Addon

e Hotfix

e ThinOS Telemetry Dashboard
Third Party

Teradici PColP

Imprivata PIE

Jabra

EPOS Connect

HID Fingerprint Reader

I[dentity Automation QwickAccess
ControlUp VDI Agent
RingCentral App VMware Plugin
Avaya Agent for Desktop
Liquidware Stratusphere UX Connector ID Agent
Lakeside Virtual Agent

Amazon WorkSpaces Client
Other

e Common Printing

e Application packages are not predefined yet.

For each category, there is one switch option INSTALL/UNINSTALL on the left and one drop-down list Not Selected by
default on the right. Click the drop-down list, and the uploaded versions of the application package is displayed. You can

select only one version in the list and the drop-down list title changes to the package name and repository.
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@ NOTE: For Other category, you can select multiple application packages and versions, as the application packages are
not predefined yet. However, you cannot set UNINSTALL for this category. Once you have the application packages
in Other category, it is recommended you upgrade the Wyse Management Suite configUl. The new Wyse Management
Suite configUl sets the application packages in the new category.

If the switch option is set to INSTALL, the selected application package version in the drop-down list is published to the
ThinOS client to install.

If the switch option is set to Uninstall, the application package drop-down list is disabled, and the application package is
uninstalled from the ThinOS client.

Upload and push ThinOS 9.x application packages
using Groups and Configs on Wyse Management Suite

Prerequisites

Create a group in Wyse Management Suite with a group token. Use this group token to register the ThinOS 9.x devices.
Register the thin client to Wyse Management Suite.

Steps

1

2.

Go to the Groups & Configs page, and select a group.

From the Edit Policies drop-down menu, click ThinOS 9.x.

The Configuration Control | ThinOS window is displayed.

Click Advanced.

In the Firmware field, click Application Package Updates.

To select a file, click Browse and go to the location where your file is located.

e |f the EULA is embedded in the package, the EULA details of the package and the name of the vendors are displayed.
You can click the vendor names to read the license agreement of each vendor. Click Accept to upload the package. You
can select the Do not show this again if you do not want to see the EULA details of the same vendor again. If you
upload multiple packages, the EULA details of each package is displayed. You must accept the license agreement of the
packages individually. The package is not uploaded if you click Decline.

e |f the EULA is not embedded in the package, go to step 6.

@ NOTE: You can upload and deploy multiple firmware packages from the remote repository, tenant cloud repository or
operator cloud repository.

6. Expand the category of the package and select it.

Verify and ensure that the switch option of the category is INSTALL.

Click Save & Publish.
The application package is installed and the thin client restarts.

Upload and install ThinOS 9.x application packages
using Admin Policy Tool

Steps

1

N o o sk o
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Go to the Admin Policy Tool on the ThinOS client.
The Configuration Control | ThinOS window is displayed.

Click Advanced.

In the Firmware field, click Application Package Updates.

Browse and upload the packages from USB drive.

Expand the category of the package and select it.

Verify and ensure that the switch option of the category is INSTALL.
Click Save & Publish.
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The application packages are installed and the thin client restarts.

Firmware installation using ThinOS ISO image

You can install ThinOS from a USB drive using the Dell OS Recovery Tool on the following platforms:

OptiPlex 3000 Thin Client
Latitude 3420

OptiPlex 5400 All-in-One
Latitude 3440

Latitude 5440

Latitude 5450

OptiPlex All-in-One 7410
OptiPlex All-in-One 7420

From ThinOS 2402, DellThinOS Recovery BIOS boot option is added in devices from the factory or you can install the option
using the ISO image. If you boot using this option, the devices are recovered to factory installed or ISO image-installed status.

®

NOTE: If you update older devices to ThinOS 2402 using Wyse Management Suite, you cannot see the DellThinOS
Recovery BIOS boot option.

®| NOTE: If the device size is less than 32 GB, DellThinOS Recovery BIOS boot option is not created.

For information about installation instructions, see the Dell ThinOS Installation and ThinOS Activation License User Guide at
www.dell.com/support.

Firmware installation using Dell Wyse USB Imaging
Tool

Use the Dell Wyse USB Imaging Tool version 3.4.0 or later versions to install the latest version of ThinOS 9.x Merlin image on
your thin client. For information about installation instructions, see the Dell Wyse USB Imaging Tool version 3.4.0 or later User's
Guide.

If you install the merlin image on the following thin clients, the installation may stop at 100% and does not display the completion
status:

Wye 3040 Thin Client with hard disk size larger than 8 GB

Wyse 5070 Thin Client with hard disk size larger than 16 GB

Wyse 5470 Thin Client with hard disk size larger than 16 GB

Wyse 5470 All-in-One Thin Client with hard disk size larger than 16 GB

However, you can force reboot the thin client as the image is already installed.

Upgrade BIOS

Prerequisites

e Depending on your thin client model, download the relevant BIOS file from www.dell.com/support.
e |f you are upgrading BIOS using Wyse Management Suite, register your thin client to Wyse Management Suite.
@ NOTE: On thin clients that run ThinOS versions earlier than ThinOS 9.1.6108, you must upgrade the operating system
image first. Then, upgrade the BIOS after the operating system image is successfully upgraded. Do not upgrade the
BIOS and the operating system image together. If you upgrade the BIOS and the operating system image together,
the BIOS upgrade is ignored, and you cannot upgrade the BIOS to the ignored version. You must upgrade the BIOS to
another version.

Steps
1. Open the Admin Policy Tool on the thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
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On the Configuration Control | ThinOS window, click the Advanced tab.

Expand Firmware and click BIOS Firmware Updates.

Click Browse and select the BIOS file to upload.

From the Select the ThinOS BIOS to deploy drop-down list, select the BIOS file that you have uploaded.

Click Save & Publish.

The thin client restarts. BIOS is upgraded on your device.

@ NOTE: BIOS upgrade requires a display screen (integrated or external) without which the update fails. In this case, you
cannot install the BIOS package again. You must install another BIOS version.

e From ThinOS 2402, if a monitor is not connected to Wyse 5070, the BIOS update fails. After the monitor is connected,
the BIOS update is triggered immediately.

e |f a power adapter is not connected on the Wyse 5470, the BIOS update fails. After the power adapter is connected, you
must reboot to trigger the BIOS update again.

Edit BIOS settings

Prerequisites

If you are using Wyse Management Suite, ensure that you have registered the thin client and synchronize the BIOS

admin password. For more information about using the Sync BIOS Admin Password option, see the latest Dell Wyse

Management Suite Administrator's Guide at www.dell.com/support.
NOTE: If you have not synced the BIOS password in the Wyse Management Suite server, you can enter the current
BIOS password in the Current BIOS Admin Password field to publish the BIOS settings. If you have synced the BIOS
password in the Wyse Management Suite server, this field is ignored. Wyse Management Suite server uses the synced
BIOS password to publish BIOS settings.

If you are using the Admin Policy Tool, ensure that you enter the current BIOS admin password in the Advanced > BIOS
section.

Steps
1. Open the Admin Policy Tool on the thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. In the Configuration Control | ThinOS window, click the Advanced tab.
3. Expand BIOS and select your preferred platform.
4. In the System Configuration section, modify the USB ports and audio settings.
5. In the Security section, modify the administrator-related configurations.
6. In the Secure Boot section, enable the secure boot option. If enabled, you cannot disable it using Admin Policy Tool or Wyse
Management Suite. Secure Boot can be disabled only in the BIOS setup window.
7. In the Power Management section, modify the power-saving options.
8. In the POST Behavior section, modify the post behavior options.
9. Click Save & Publish
@ NOTE: If the thin client does not have a BIOS admin password, you can set the password using Admin Policy Tool or
Wyse Management Suite. In this scenario, the client reboots first to apply the BIOS admin password and other BIOS
settings take effect after the second reboot.
@ NOTE: Changing BIOS password using Select Group requires a reboot to take effect.
@ NOTE: If you enable Set Admin Password, set new BIOS password and then reboot, the new BIOS password is synced
to WMS server automatically. If you first enable Set Admin Password, set the new BIOS password, and then disable
Set Admin Password, the BIOS password is cleared to empty. On the thin client, the Current BIOS Admin Password
option is always blank, and Set Admin Password option is always disabled. These options do not have any impact on
the functionality.
34 Upgrading the ThinOS firmware


https://www.dell.com/support

Delete ThinOS application packages

You can use the ThinOS local Ul or the Wyse Management Suite to delete one or more ThinOS packages.

About this task

This section describes steps to delete ThinOS packages using the ThinOS local Ul.

Steps

1
2.

Log in to the ThinOS client.

From the system menu, go to System Tools > Packages.
All the installed ThinOS packages are listed.

Select a package that you want to delete and click Delete.

®| NOTE: To delete all the packages, click Delete all.

Click OK to save your settings.

For information about how to delete or uninstall application packages using Wyse Management Suite, follow all steps in
Upload and push ThinOS 9.x application packages using Groups and Configs on Wyse Management Suite, except Step 7,

where you must switch to UNINSTALL

Downgrading the ThinOS firmware

If you are downgrading to ThinOS 8.6, ThinOS 9.0, or ThinOS 9.1 versions that are older than 9.1.3129, you must use the Dell
Wyse USB Imaging Tool to install the ThinOS 8.x or 9.x Merlin image that is posted to www.dell.com/support. Before you

downgrade, ensure that you disable the secure boot option in the BIOS. If you want to downgrade to ThinOS 9.0, you must clear
Trusted Platform Module (TPM) or Platform Trust Technology (PTT) in BIOS too. Else, ThinOS resets to factory settings after

each reboot. If you are running the latest version of ThinOS, you can downgrade to ThinOS 9.1.3129 or later versions using Wyse
Management Suite.

Upgrading the ThinOS firmware
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Getting started with ThinOS

This chapter helps you to quickly learn the basics and get started with your ThinOS -based thin client. From ThinOS 2205,
ThinOS Activation devices license is added in Wyse Management Suite. Devices that are converted from other operating
systems must have the ThinOS Activation devices license to enable the VDI function. The license is automatically added when
registering to Wyse Management Suite. You cannot log in to any Broker agent from the client without ThinOS Activation devices
license. You can add the license to enable PColP function on non-PColP devices that are converted from ThinOS 8.6 by enabling
the Enable PColP Activation License option from Services > WDA Settings.

@ NOTE: Once ThinOS Activation devices licenses are consumed, you cannot restore them anymore. The licenses are
permanently applied on the ThinOS clients. ThinOS activation licenses are not cleared when you reset the ThinOS clients
to factory default. However, if you recover ThinOS clients using ISO images or merlin images, the licenses are cleared. You
must register the devices to the same Wyse Management Suite server that you applied licenses previously, to re-active
them. If you register the devices to the same Wyse Management Suite server, the clients can use the same licenses,

and they do not consume new licences. For Non-PColP ThinOS clients, you must also enable Enable PColP Activation
Licenseoption in ThinOS 9.x policy to re-active licenses.

End User License Agreement

End User License Agreement (EULA) is added to ThinOS. EULAs must be read and accepted to continue using ThinOS. By
default, Dell EULA and HID EULA are added to ThinOS. The third-party EULAs are displayed on the EULA screen depending on
the ThinOS application packages that you install on the thin client.

The EULA screen is displayed during the following instances:

e \When you boot the thin client for the first time.
e When you reset a thin client that runs ThinOS 9.x to factory settings.

Configure ThinOS using First Boot Wizard

A First Boot Wizard application runs the first time when you start a thin client with ThinOS. The thin client starts the First

Boot Wizard application before you enter the ThinOS desktop. Use this application to perform tasks, such as configuring
computer preferences, setting up the Internet connectivity, loading USB configurations, configuring management software, and
configuring broker connections.

Prerequisites

If you are an existing thin client user, and you have upgraded to the ThinOS version 9.x, reset your thin client to factory default
settings to enter the First Boot Wizard.

@ NOTE: If DHCP contains the Wyse Management Suite configurations, the ThinOS desktop is loaded without entering the
First Boot Wizard and you cannot view the End User License Agreement.

About this task

This section describes how to configure ThinOS using First Boot Wizard.

Steps
1. Connect your thin client to an Ethernet using a wired connection.

@ NOTE: If you want to use a wireless connection, you can connect to Wi-Fi on the How do You Connect? screen at a
later stage.

2. Turn on your thin client.
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The thin client checks for a wired network connection. If the network connection is successful, a welcome screen is
displayed followed by the EULA screen. For more information about the EULA screen, see End User License Agreement.
@ NOTE: When you reset the device to factory default settings without a network connection, a message Device is

waiting for WMS information from network auto discovery is displayed. Press O on the welcome
screen to go to next screen.

Click Dell EULA or HID EULA from the right pane to read the respective EULAs. If you have installed the ThinOS application
packages, ensure that you read the respective EULAs of the third-party applications.

®| NOTE: The EULA screen may be different depending on the client installed packages.

Congratulations on your new Dell purchase!

Your purchase and use of this product is subject to and governed by Dell’s applicable Terms of Sale and End User License Agreement, which are each presented below in the
following order:

- Terms of Sale Websites

- End User License Agreement

By the act of dlicking “1 accept,” you agree (or re-affirm your agreement to) the foregoing terms and conditions. For the avoidance of doubt, to the extent that Dell is deemed
under applicable law to have accepted an offer by you: () Dell hereby objects to and rejects all additional or inconsistent terms that may be contained in any purchase order or
other documentation submitted by you in connection with your order; and (b) Dell hereby conditions its acceptance on your assent that the foregoing terms and conditions
shall exclusively control

IF YOU DO NOT AGREE WITH THESE TERMS, DO NOT USE THIS PRODUCT AND CONTACT YOUR DELL REPRESENTATIVE WITHIN FIVE BUSINESS
DAYS TO ARRANGE A RETURN.

Citrix

DELL

1 you purchased directly from Dell for your intemal use, your purchase is governed by the applicable Terms of Sale, unless you have a separate written agreement with Dell el
that specifically applies to your order.

‘Terms of Sale Websites

AMERICAS

US www.dell.com/terms

Canada Dell.ca/terms

Canada (French) Dell.ca/conditions

Argentina www.dell.conylear/ar/es/arcorp1/terms-of-sale

Aruba www.dell.com/lear/aw/en/awcorpl/terms-of-sale TeamsvD
Bahamas wiww.dell.com/leam/bs/en/bscorp1terms-of-sale
Barbados wwwdell.com/leabb/en/bbcorp terms-of-sale webertieeings
Belize www.dell.com/leam/b/en/bzcorp terms-of-sale

Bolivia wyww.dell.com/learm/boes/bocorp /terms-of-sale

Brazil wwwdell.com/br/TermosCondicoe

Chile www.dell.com/learn/cl/es/clcorp1/terms-of-sale

Colombia www.dell.com/learn/co/es/cocorp1/terms-of-sale

Costa Rica www.dell.com/learn/cr/es/creorpl /terms-of-sale

Click here to accept all EULAS

Figure 1. EULA screen

Select the Click here to accept all EULAs check box and click Accept.
Scan your QR code.

You can scan your QR Code to import the Wyse Management Suite configuration, after which the device exits from First
Boot Wizard. If your device does not have an integrated camera or external camera, then you cannot see the QR code.

On the Select Your Language screen, select a language from the Language drop-down list to start ThinOS in the regional
language.
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Select Your Language

Language
1) Select Language Bz
Deutsch
2) Select Keyboard Francés
Italiano
3) Select Time Zone
Espaiiol
) Select Network e
kb
) Import Configuration BERY
@30f
) Set VDI Broker
7) Done C

Figure 2. Select Your Language

7. Click @

8. On the Select Your Keyboard screen, select a keyboard layout from the list.

Select Your Keyboard

keyboard layout
R
1) Select Language
Czech
(@ select Keyboard panish

Dutch

3) Select Time Zone English (3270 Australian)

English (Australian)

) Select Network
English (New Zealand)

5) Import Configuration English (United Kingdom)
English (United States)
) Set VDI Broker

7) Doe ©©

Figure 3. Select Your Keyboard

9. Click @

10. On the Select Your Time Zone screen, select a time zone from the list to set the time zone for your thin client.

The time server with IP addresses or host names is also displayed.
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Select Your Time Zone

pool.nip.org

(uTcsouTe
@ select Language
(UTCHAfrcalAlgiers

(@ select Keyboard (UTC+1)Africa/Bangui

(UTCs)AficalBrazzaville

@ select Time Zone
(UTCHAficalCeuta

(UTC+1)Africa/Douala
(@ Select Netiork

(UTC+1)AfricalEl_Aaiun
® Import Configuration (UTCHAfcalKinshasa

(UTC+1)AfrcalL agos

(© Set Vo Broker

b OO

Press Ctrl+Esc to Exit

Figure 4. Select Your Time Zone
I/—>
11. Click .

12. On the How do You Connect? screen, do either of the following:

e Local network (Ethernet)—Click this option if you have connected the thin client to an Ethernet using a wired
connection.

e Wi-Fi Network—Click this option if you want to select a wireless network. From the list, select a wireless network, and
click Connect.

®| NOTE: The option to define a wireless connection is not available on thin clients without a WLAN module.

e My computer does not connect to the Internet—Click this option if you do not want to establish a network
connection using the First Boot Wizard screen. You can connect to either wired or wireless connection after you boot to
the ThinOS desktop.

How do You Connect?

© Local network (Ethernet)
Wi-Fi Network

@ select Language My computer does not connect to the Internet

(@ select Keyboard
(@ select Time Zone

(@) select Network

(® Import Configuration
(© SetVDI Broker

(N
@ Done @

Press Ctrl+Esc to Exit

Figure 5. How do You Connect?

I/d_>
13. Click .
14. On the How would you like to import your ThinOS configurations? screen, do either of the following:
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From Wyse Management Suite—Click this option if you want to use Wyse Management Suite to manage your thin
clients.

To register your thin client to Wyse Management Suite, enter the group registration key and the Wyse Management Suite
server URL. Select the CA validation check box if you want to enable the CA validation feature. The CA validation is
required when you import certificates into your Wyse Management Suite server. By default, the CA Validation check box
is selected to improve the security when using the Wyse Management Suite cloud. While typing, you can click the eye
icon next to Prefix and Group Key to display the masked values. Click the icon again to hide the values.

From USB—Click this option if you want to import system settings from the USB drive.

Do not import a configuration—Click this option if you do not want to import any ThinOS configurations using the
First Boot Wizard screen.

How would you like to import your ThinOS
configuration?

Select Language
Select Keyboard
3) Select Time Zone

@) Select Network

© From Wyse Management Site
From USB

5) Import Configuration Do not import a configuration

Set VDI Broker

@ Done (é) @

Press Ctrl+Esc to Exit

Figure 6. How would you like to import your ThinOS configurations?

.f>

15. Click .
16. On the Connect to VDI broker screen, configure your preferred broker type from the following options:

40

Citrix Virtual Apps and Desktops
VMware Horizon

Azure Virtual Desktop

Microsoft Remote Desktop Services
Amazon WorkSpaces

Teradici Cloud Access
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Connect to VDI broker

1) Select Language
Gitrix Se

Address

Workspace Mod
Select Keyboard space Mode

3) Select Time Zone

© Citrix Virtual Apps and Desktops
@) Select Network VMware Horizon

Windows Virtual Deskiop

Microsoft Remote Desktop Services
5) Import Configuration Amazon WorkSpaces

Teradici Cloud Access

6) Set VDI Broker

b OO

Press Ctrl+Esc to Exit

Figure 7. Connect to VDI broker

17. Click @

The Done screen is displayed.

‘ Done!

Press Ctrl+Esc to Exit

Figure 8. Done

The device exists from the First Boot Wizard mode, and the ThinOS desktop is displayed.

Configure account privileges for ThinOS

Account privilege is used to control the user permission to access Admin Policy Tool and System Menu options. You can change
a user privilege to High, Customize, or None from the Admin Policy Tool or the Wyse Management Suite console. When you
set the user privilege to Customize, you can manually select and enable or disable the options in the ThinOS system menu.

The Administrator Mode menu in the Admin Policy Tool is disabled by default. You can enable the administrator mode in the
Admin Policy Tool or the Wyse Management Suite server, and configure an Administrator username and password.
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Configure account privileges using Admin Policy Tool

About this task

This section describes how to configure account privileges using Admin Policy Tool.

Steps

1. From the desktop menu, click System Setup > Admin Policy Tool.
The Configuration Control || ThinOS window is displayed.

Click the Standard tab or the Advanced tab.

Expand Privacy & Security.

Click Account Privileges.

SLE S

Click the Enable Admin Mode slider switch if you want to enable the Administrator mode. When enabled, you must specify
the Admin username and password.

6. From the Privilege Level drop-down list, select a privilege level—None, Customize, or High.

When you set the user privilege to Customize, you can manually select the options that you want to enable or disable in
the ThinOS system menu. The DHCP option is only available after you enable Network Setup and Granular Control of
Peripherals option is only available after you enable Peripherals. Granular Control of Troubleshooting option is only
available after you enable Troubleshooting.

7. Click Save & Publish.

Configure account privileges using Wyse Management Suite

About this task

This section describes how to configure account privileges using Wyse Management Suite.

Steps
1. Go to the Groups & Configs tab and select your desired group.
2. Click Edit Policies.

3. Select ThinOS 9.x from the drop down list.
The Configuration Control | ThinOS window is displayed.

4. Click the Standard tab or the Advanced tab .
5. Expand Privacy & Security.

6. Click Account Privileges.

7

Click the Enable Admin Mode slider switch if you want to enable the Administrator mode. When enabled, you must specify
the Admin username and password.

8. From the Privilege Level drop-down list, select a privilege level—None, Customize, or High.

When you set the user privilege to Customize, you can manually select the options that you want to enable or disable

in the ThinOS system menu. The DHCP option is only available after you enable Network Setup and Granular Control
of Peripherals option is only available after you enable Peripherals.Granular Control of Troubleshooting option is only
available after you enable Troubleshooting.

9. Click Save & Publish.

Enable PColP Activation License

About this task

You can enable PColP Activation License to enable the PColP function on Non-PColP Thin clients.

Steps

1. Open the ThinOS 9.x policy settings on Wyse Management Suite.
2. Click the Advanced tab
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Expand Services, and click WDA Settings.

Under WDA Settings, enable PColP Activation License.
By default this option is disabled.

Click Save & Publish.

Connect to a remote server

About this task

This section describes how to manually connect to a remote server.

Steps

1.

From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

Click the Broker Setup tab and configure the respective VDI broker.
Click OK and restart the thin client.

After the thin client restarts, the Login dialog box is displayed.

Enter the username, password, and domain.

After authentication is successful, your desktop is presented with your assigned connection that is defined by the broker
server.

Connecting a display

Depending on your thin client model, connections to displays can be made using VGA (analog) port, DisplayPort (digital), Mini
DisplayPort, USB Type-C port, HDMI, and the proper Dell monitor cables/splitters/adapters.

For more information about ports and connectors, see the hardware documentation of the respective thin clients.

Connecting a printer

To connect a local printer to your thin client, ensure that you obtain and use the correct adapter cables. Before use, you may
need to install the driver for the printer by following the printer driver installation instructions. For information about connecting
to a printer, see Configuring the printer setup.

Configure WMS settings on the client GUI

Steps
1. Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. Click the Advanced tab.
8. Expand Services, and click WMS Settings.
4. Click Enable WMS.
The option is enabled by default.
5. Enable Show Advanced Configuration to display the advanced configuration options.
6. Fill the following fields:
e Group prefix—This field is mandatory.
e Group token—This field is mandatory.
e Server—This field is mandatory.
@ NOTE: If you disable, and then enable Show Advanced Configuration, all the values that you enter in the mandatory
fields are cleared.
7. Enable or disable CA Validation.
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8. Click Save & Publish.

Desktop overview

ThinOS boots to the modern desktop screen. This screen is the default screen that is displayed after you log in to the thin
client—without autostart of any connections or applications.
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Figure 9. Modern desktop

The ThinOS modern desktop consists of the following screen elements:

e Floatbar or taskbar—Contains the system tray area that displays the system icons.
e Broker login window—Enables you to log in to the Broker agent session using your login credentials.

Modern interactive desktop features

The modern desktop mode (formerly zero desktop) has a Dell default background with the floating toolbar or floatbar on the
screen.

@l NOTE: Citrix Workspace mode is not supported on the modern desktop.

Table 13. Modern desktop shortcuts

Action Press

Open a selection box for toggling between the desktop and Ctrl+Alt+DownArrow

currently-active connections

Lock the thin client Ctrl+Alt+LeftArrow
or
Ctrl+Alt+RightArrow

Capture the full desktop to the clipboard Print Screen

Capture the active window to the clipboard Alt+PrintScreen
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Enable modern desktop mode

Steps

N NN S

® N

10.

M

Go to ThinOS 9.x policy settings on Wyse Management Suite or the Admin Policy Tool on ThinOS.
Click the Advanced tab and expand Personalization.

Click User Experience Settings.

From the System Mode drop-down list, select Modern.

From the Color scheme for Modern mode, select the color that you want.

If you do not want the floatbar to be displayed, enable Disable Floatbar. The floatbar can only be displayed by pressing
Windows key on the keyboard when focus is on ThinOS desktop.

From the Show Floatbar when mouse drop-down list, select the way that you want to show floatbar when it is hidden.
From the Floatbar Location on Screen drop-down list, select the location of floatbar on the screen.

In the Screen ID field, enter the Screen ID on which floatbar should be shown. You must enter a number O to 6. O specifies
the main screen.

Click Save & Publish.

odern toolbar or float bar

The modern toolbar or float bar appears at the left or right corner of the modern desktop. However, depending on administrator
configurations, the float bar can be removed or hidden. The toolbar is displayed when a user moves the mouse pointer over the

left

®
®

or right edge of the desktop screen.
NOTE: If you set the Show Floatbar option to Fly Over on either Admin Policy Tool or Wyse Management Suite, you must
quickly move the mouse pointer on the desktop.

NOTE: If you set the Show Floatbar when mouse option to Delay and the Delay Floatbar Activation in Milliseconds
to 0, the modern float bar is disabled in a full screen session. If you press Ctrl+Alt+down key combination to switch to the
ThinOS desktop, the floatbar is not displayed. You must press Windows key on the keyboard to show the floatbar. If you
change the mouse pointer size to a number greater than 3 in a Blast session, you must use Ctrl+Alt to exit the session and
view the floating bar on the ThinOS modern desktop.

Table 14. Toolbar icons

Icon Description

VDI menu Opens the list of available connections.

System Info Displays thin client system information.

Settings Opens the System Settings menu to configure thin client system settings and perform
diagnostics.

Shutdown Click the Shutdown Terminal icon to use the Shutdown options available on the thin client.

Wireless network Displays the wireless connection mode. Clicking the wireless icon displays the SSID scan

list. You can directly connect to your preferred WiFi. You can view the wireless IP address
information in the Wi-Fi icon tooltip.

Wired network Displays the wired connected mode.
Volume or Sound Click this icon to increase or decrease the speaker volume or mute the speaker.
PNA menu Displays the Citrix connection options such as Refresh, Disconnect, Reconnect, Logoff, and
Manage Security Question.
®| NOTE: The PNA menu button is displayed only after you log in to the Citrix Broker agent.
PColP Displays the active PColP sessions. This icon is applicable only for PColP-enabled clients. You

can select a session from the menu, and enable or disable the following PColP options in real
time:

e Relative Mouse

e Audio or Video synchronization
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Table 14. Toolbar icons (continued)

Icon

Description

Battery indicator

Hover over the battery indicator to view the remaining battery percentage. This option is
applicable only to the Wyse 5470 Thin Client.

Smart Card Self-Service

Click this icon to open the smart card self service window. You can use this window to view
the smart card details, change PIN, and unlock PIN. This icon is displayed when you connect a
smart card reader to the ThinOS client.

List of connections

On the modern toolbar, you can click the VDI menu icon to open your list of assigned connections and published applications.
Sometimes, the list contains only default connections.

®| NOTE: The connection options may be available for use, depending on the user privileges.

Table 15. Connection options

Option

Description

Name of the connection

Opens the connection you want to use.

Gear icon

Displays the sub menu.

Add Connection

Allows you to configure or add new connections.

Global Connection Settings

Use the Global Connection Settings dialog box to configure settings that affect
all the connection in the list.

Search bar

Enables you to search for a particular connection from the list.

Classic desktop features

This section includes information about desktop guidelines, shortcut menu, desktop menu, and Connection Manager.

Desktop guidelines

The classic desktop has a Dell Wyse default background with a horizontal taskbar at the bottom of the screen.
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Figure 10. Classic Desktop

Use the following guidelines:

Icons representing available server connections and published applications are displayed on the desktop. If you pause the
mouse pointer over an icon, the information about the connection is displayed. Right-click an icon to open the Properties
dialog box that displays additional information about the connection. The number of icons that can be displayed on the
desktop depends on the desktop resolution and administrator configuration.

A server connection and published application can be opened by double-clicking a desktop icon. You can also go to the
desktop icon by using the tab key and press Enter to initiate the connection.

Right-clicking on the desktop provides a shortcut menu.

Clicking the desktop menu button, or clicking anywhere on the desktop, opens the desktop menu.

Enable classic desktop mode

Steps

oo s aN

Go to ThinOS 9.x policy settings on Wyse Management Suite or the Admin Policy Tool on ThinOS.

Click the Advanced tab and expand Personalization.

Click User Experience Settings.

From the System Mode drop-down list, select Classic.

If you want to hide the taskbar when ThinOS is not logged in or if there is a maximized window, enable Hide Taskbar.

From the Show Taskbar when mouse drop-down list, select the way that you want the taskbar to be displayed when it is
hidden

Click Save & Publish.

Using the taskbar

Use the taskbar to view the date, time, system information, wireless information, volume icon, PNA menu button, and switch to
the desktop screen.
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The following table lists the taskbar elements:

Table 16. Taskbar - System tray elements

Element

Description

Date and time

Displays the date and time.

Battery

Displays the battery percentage. This option is applicable for Wyse 5470 Thin
Client.

Show desktop

Click this icon to hide or restore VDI sessions.

Volume or Sound

Click this icon to increase or decrease the speaker volume or mute the speaker.

System Information

Click this icon to view the system information such as general system details,

copyright, event logs, Wyse Management Suite status, network connections, and

SO on.

@ NOTE: From ThinOS version 9.1.6108, the Energy Star logo is added to the
System Information window of factory shipped OptiPlex 3000 Thin Clients.

Wireless icon

Displays the wireless connection mode. Clicking the wireless icon displays the
SSID scan list. You can directly connect to your preferred WiFi. You can view the
wireless |IP address information in the Wi-Fi icon tooltip.

With ThinOS 2306, a new option Manage Known Networks has been added

when you click the WiFi icon. Clicking this option displays all manually added

wireless SSIDs. You can select one SSID and click Forget to remove it or click

Properties to modify it.

@ NOTE: The wireless SSIDs published from Wyse Management Suite and Admin
Policy Tool are not displayed in Manage Known Networks.

Wired icon

Displays the wired connected mode.

Bluetooth icon

Displays the connection status of Bluetooth devices.

Citrix PNA menu

Click this icon to use the following options:
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Table 16. Taskbar - System tray elements (continued)

Element

Description

Refresh

Disconnect

Reconnect

Logoff

Manage Security Question—This option is available when you enable SSPR at
the server end.

@ NOTE: The PNA menu button is displayed only after you log in to the Citrix
broker.

Smart card self service

Click this icon to open the smart card self-service window. You can use this
window to view the smart card details, change the PIN, and unlock the PIN. This
icon is displayed when you connect a smart card reader to the ThinOS client.

PColP -

Click this icon to view the active PColP sessions. This icon is applicable only for
PColP-enabled clients. You can select a session from the menu, and enable or
disable the following PColP options in real-time:

e Relative Mouse

e Audio/Video synchronization

Taskbar icons are added for all ThinOS windows except the login window and the Admin Policy Tool window. You can use the
taskbar icons to minimize and restore the windows.

Table 17. Taskbar - ThinOS local windows icons

Element

Taskbar icon

Network Setup

]
150

Remote Connections

Central Configuration

VPN Manager

System Preferences

Display

Peripherals

Printer

System Information

System Tools

Troubleshooting

Connection Manager
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Using the shortcut menu

About this task

This section describes how to use the shortcut menu on your thin client.

Steps
1. Right-click on your desktop.
The shortcut menu is displayed.
2. On the shortcut menu, you can view and use the following options:
a. Administrator Mode—L ets you enter the administrator mode. This option is disabled by default. You must enable the
option from Wyse Management Suite server or Admin Policy Tool.
b. Hide all windows—Brings the full desktop to the foreground.
¢c. Copy to clipboard—Copies an image of the full screen, current window, or event log to the clipboard. The clipboard
contents can be pasted to an Independent Computing Architecture (ICA) session. You can copy the full screen or current
window to clipboard, and can export the screenshots using the Export Screenshot option in the Troubleshooting
dialog box.
d. Purge clipboard—Discards the contents of the clipboard to free up memory. If there are no contents in the clipboard,
the Purge clipboard option is disabled.
e. Lock Terminal—Puts the thin client in a locked state when the user has logged in to the system with a password. The
thin client can only be unlocked using the same password.
f. Performance Monitor—Opens the performance monitor.

Using the desktop menu

About this task

This section describes how to use the desktop menu on your thin client.

Steps

|
1. Click or click anywhere on your desktop.

The desktop menu is displayed.
2. On the desktop menu, use the following options to configure the thin client:
e System Setup—Provides access to the following local system setup dialog boxes:
Network Setup—Allows selection of DHCP or manual entry of network settings, and server locations.
Remote Connections—Allows you to configure the Broker agent connection.
Central Configuration—Allows you to configure the Wyse Management Suite server settings.
VPN Manager—Allows you to configure the VPN connection.
System Preferences—Allows you to configure general settings such as screensaver, locale, and time and date.
Display—Allows you to configure the monitor resolution and rotation.
Peripherals—Allows you to select the peripherals settings such as audio, keyboard, mouse, serial, camera, and
Bluetooth settings.
Printer Setup—Allows you to configure network printers and local printers that are connected to the thin client.
Admin Policy Tool—Allows you to configure all the ThinOS settings similar to configuring settings using Wyse
Management Suite.
System Information—Provides the device information.
System Tools—Provides information about devices, certificates, and packages.
Troubleshooting—Displays the performance monitor graphs, trace and event log settings, and other options that are
useful for troubleshooting your thin client.
e Shutdown—Allows you to shut down the system, or restart the operating system.

O O O O O O O

O
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Configure the Connection Manager

The Connection Manager has a list of connection entries and command buttons available for use with the connections.

About this task

This section describes how to configure the Connection Manager settings.

Steps

1. Go to System Setup > Remote Connections, and configure the Broker agent setup.
2. Log in to the Broker agent connection.

3. On the taskbar, click .

The Connection Manager dialog box is displayed.
®| NOTE: Nonprivileged users cannot view the Connection Manager.

4. In the Connection Manager dialog box, and use the following guidelines:
e Select a connection from the list, and click Connect to establish the VDI connection.
e C(lick Properties to open the Connection Settings dialog box for the selected connection.
All users can view and edit definitions for the selected connection. Edits are not permanently retained when the user
signs-off.
Click Sign-off to log off from the thin client.

If you want to reset a selected virtual connection, select a connection from the list, and click Reset VM.

Click the Global Connection Settings tab to open and configure settings that affect all the connections available in the
list.

Click Add to create an RDP or a PColP connection.
Click Delete to remove the created connection from the list.

Configuring thin client settings and connection broker
settings

You can either use the ThinOS local Ul or the Wyse Management Suite to do the following:

e Set up your thin client hardware, look and feel, and system settings

o For configuring these settings using ThinOS local Ul, see Configuring connectivity and Configure the thin client local
settings.

o For configuring these settings using Wyse Management Suite, see Edit the ThinOS 9.x policy settings.
e Configure the connection broker settings

o For configuring these settings using ThinOS local Ul, see Configuring the connection brokers.

o For configuring these settings using Wyse Management Suite, see Edit the ThinOS 9.x policy settings.

Configure ThinOS using Admin Policy Tool
ThinOS 9.x does not support FTP, HTTP, HTTPS file server, and INI parameter settings. You can configure these settings using

a local management tool called Admin Policy Tool.

NOTE: After you reset the thin client to factory default settings, the device starts the First Boot Wizard application by
default. You can use the Admin Policy Tool to change the default settings after First Boot Wizard.

Configure the Admin Policy Tool

Steps

1. From the desktop menu, click System Setup > Admin Policy Tool.
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The Configuration Control | ThinOS window is displayed.
2. Click the Standard tab or the Advanced tab.
The Standard tab lists all the common settings. The Advanced tab lists all the advanced settings.

3. Expand the options that you want to configure.

4. In the respective fields, click the option that you want to configure.

5. Click Save & Publish.

Feature list of Admin Policy Tool

The following table displays the list of features that are supported by the Admin Policy Tool in ThinOS.

Table 18. Admin Policy Tool

Feature Subfeature Restart required
Region & Language Region & Language | No

Settings

Privacy & Security Account Privileges No

Privacy & Security Certificates No

Privacy & Security

Security Policy

Yes, you must restart the client for all changes to take effect.

Privacy & Security

SCEP

No

Privacy & Security

Device Security

Yes, you must restart the client for all changes to take effect.

Session Settings

Broker Settings Global Broker No
Settings

Broker Settings Citrix Virtual Apps No
and Desktops
Settings

Broker Settings VMware Horizon No
Settings

Broker Settings Azure Virtual No
Desktop Settings

Broker Settings Microsoft Remote No
Desktop Settings

Broker Settings Amazon WorkSpaces | No
Settings

Broker Settings Teradici Cloud No
Access Settings

Session Settings Global Session No
Settings

Session Settings Citrix Session No
Settings

Session Settings Blast Session No
Settings

Session Settings PColP Session No
Settings

Session Settings RDP and AVD No

VDI Configuration Editor

Citrix Configuration
Editor

Yes, you must restart the client for all changes to take effect.
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Table 18. Admin Policy Tool (continued)

Feature

Subfeature

Restart required

VDI Configuration Editor

Horizon Blast
Configuration Editor

Yes, you must restart the client for all changes to take effect.

VDI Configuration Editor

Zoom Plugin
Configuration Editor

Yes, you must restart the client for all changes to take effect.

VDI Configuration Editor

Avaya Configuration
Editor

Yes, you must restart the client for all changes to take effect.

Login Experience

3rd Party
Authentication

No

Login Experience

Smart card Settings

Yes, you must restart the client for all changes to take effect.

Login Experience

Login Settings

No

Login Experience

Session Settings

No

Personalization

Shortcut Keys

Yes, you must restart the client for all changes to take effect.

Personalization Device Info No
Personalization Desktop Yes, you must restart the client for all changes to take effect.
Personalization Screen Saver No
Personalization User Experience No
Settings
Peripheral Management RFldeas Reader No
Peripheral Management Printers No
Peripheral Management Audio Yes, you must restart the client for all changes to take effect.
Peripheral Management Touch No
Peripheral Management Touchpad No
Peripheral Management Serial Port Yes, you must restart the client for all changes to take effect.
Peripheral Management USB Redirection No
Peripheral Management Monitor No
Peripheral Management Mouse No
Peripheral Management Camera No
Peripheral Management Keyboard No

Peripheral Management

Device Headset
Settings

Yes, you must restart the client for all changes to take effect.

Peripheral Management

CCID

Yes, you must restart the client for all changes to take effect.

Peripheral Management

Device Driver

Yes, you must restart the client for all changes to take effect.

Firmware OS Firmware No
Updates

Firmware Application Package | No
Updates

Firmware BIOS Firmware No
Updates

System Settings Power and Sleep No
Settings

System Settings Scheduled Reboot No

Settings
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Table 18. Admin Policy Tool (continued)

Feature Subfeature Restart required
System Settings Scheduled Shutdown | No
Settings
System Settings Device Settings No
System Settings Device Monitoring No
Network Configuration Ethernet Settings No
Network Configuration DHCP Settings No
Network Configuration DNS Settings No
Network Configuration VPN Settings No
Network Configuration Bluetooth Settings Yes, you must restart the client for all changes to take effect.
Network Configuration Proxy Settings No
Network Configuration Wireless Captive Portal requires a reboot to take effect.
Network Configuration Common Settings No

Network Configuration SNMPV3 Settings No

Services Remote Shadow No
Settings
Services WMS Settings No
Services Troubleshooting No
Settings
Services WDA Settings No
BIOS Dell Wyse 3040 Yes, you must restart the client for all changes to take effect.
BIOS Dell Wyse 5070 Yes, you must restart the client for all changes to take effect.
BIOS Dell Wyse 5470 Yes, you must restart the client for all changes to take effect.
BIOS Dell Wyse 5470 AIO | Yes, you must restart the client for all changes to take effect.
BIOS Dell OptiPlex 3000 Yes, you must restart the client for all changes to take effect.
BIOS Dell Latitude 3420 Yes, you must restart the client for all changes to take effect.
BIOS Dell OptiPlex 5400 Yes, you must restart the client for all changes to take effect.
AlO
BIOS Dell Latitude 3440 Yes, you must restart the client for all changes to take effect.
BIOS Dell Latitude 5440 Yes, you must restart the client for all changes to take effect.
BIOS Dell Latitude 5450 Yes, you must restart the client for all changes to take effect.
BIOS Dell OptiPlex All-in- | Yes, you must restart the client for all changes to take effect.
One 7410
BIOS Dell OptiPlex All-in- Yes, you must restart the client for all changes to take effect.
One 7420

Important information

e |f you are using the Device Security Allow List Policy setting, you must first specify Hub, HID in the Class field by adding
a row in Advanced > Device Security section in Admin Policy Tool. If you do not add Hub, HID to the Allow list, all USB
devices are inaccessible when connected to the thin client. You must restart the thin client for changes to take effect.

e |tis not recommended to set Vendor and Product ID and Class simultaneously in one row. However, if you configure both
options simultaneously, the device first checks the Vendor and Product ID followed by the Class list.
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e When you configure the Bluetooth, VNCD server, Bluetooth, VNC Server, NetID License, Serial Port, and Device Security
settings using the Admin Policy Tool, ensure that you restart the thin client for the settings to take effect.

Locking the thin client

ThinOS enables you to lock your thin client so that credentials are required to unlock and use the thin client again. This option is
enabled by default. To disable the option, go to Advanced > Login Experience > Login Settings from the Admin Polity Tool
or the Wyse Management Suite Policy Settings, and disable Lock Terminal.

From ThinOS 2306, Unlock Terminal Count is added in Advanced > Login Experience > Login Settings. The policy limits

the number of tries for unlocking the terminal. If the number of retries exceeds the set number, you can retry again after 15

minutes or sign off or restart the thin client.

@ NOTE: A lock terminal command from Wyse Management Suite takes priority over the settings and locks the thin client
even if the setting is disabled.

Shut down and restart

About this task

This section describes how to use the Shutdown dialog box to either shutdown the computer or restart the computer.

Steps
1. From the desktop menu, click Shutdown.
The shutdown dialog box is displayed.
2. Click any of the following options:
e Shutdown the system—Enables you to shut down the computer.
e Restart the system—Enables you to restart the operating system.
3. Click OK to save settings.
NOTE: A Notice dialog box is displayed with Update Now, Next Reboot, and Schedule Update options. If you have
clicked Next Reboot to defer the operating system, BIOS, or application installation, the shutdown window asks to
Update and shut down or Update and restart with a yellow dot on their respective icons. ThinOS updates first
before shutting down or restarting

Scheduled Shutdown

Using this option, you can specify a time and a day to shut down the device automatically.

Steps

Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
Click the Advanced tab.

Expand System Settings, and click Scheduled Shutdown Settings.

Click the Enable Auto Shutdown toggle switch to enable the feature.

SNV SR

You can use the following settings:

e Shutdown after Idle Time—The client shuts down only if it is left idle for the time that you specify here.

Scheduled Shutdown Time—Set a time window for the client to shut down. Specify the time in 24-hour format.
Shutdown Day—Specify the days when you want the shutdown to happen.

Shutdown Week No.—Use this option to select a minimum time period to trigger a shutdown from the last shutdown.

6. Click Save & Publish.

®| NOTE: If you change the time zone on the local client, Scheduled Shutdown Settings take effect only after a reboot.
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Scheduled Reboot

Using this option, you can specify a time and a day to reboot the device automatically.

Steps

1

o b onN

Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
Click the Advanced tab.

Expand System Settings, and click Scheduled Reboot Settings.

Click the Enable Auto Reboot toggle switch to enable the feature.

You can use the following settings:

e Reboot after Idle Time—The client reboots only if it is left idle for the time that you specify here.

e Scheduled Reboot Time—Set a time window for the client to reboot. Specify the time in 24-hour format.

e Reboot Day—Specify the days when you want the reboots to happen.

e Reboot Week No.—Use this option to select a minimum time period to trigger a reboot from the last reboot.

Click Save & Publish.

®| NOTE: If you change the time zone on the local client, Scheduled Reboot Settings take effect only after a reboot.

Enable or disable shutdown

This option disables the Shutdown option in the ThinOS Shutdown window, and also disables the physical shutdown button on
the thin client.

Steps

1. Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. Click the Advanced tab.

3. Expand Login Experience, and click Login Settings.

4. Click the Disable Shutdown toggle switch under Login Experience to enable or disable the shutdown.

5. Click Save & Publish.

Battery information

This section is only applicable to mobile thin clients. The battery indicator is displayed on the system tray.

The following table contains the battery indicators:

Table 19. Battery indicators

Battery status Icon

While charging with the AC adapter

Battery 90% - 100% without connecting the AC adapter

Battery 50% - 89% without connecting the AC adapter

Battery 25% - 49% without connecting the AC adapter

Lk

Battery 9% - 24% without connecting the AC adapter

(I
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Table 19. Battery indicators (continued)

Battery status Icon

Battery 0% - 8% without connecting the AC adapter Ij'

When the battery is lower than 12%, a notification is displayed at the right-bottom with the remaining percentage.

Plugging in the AC adapter to charge the device increases brightness by 10% and disconnecting the AC adapter decreases
brightness by 10%.

e By default, the critical battery level is 5%. When the battery reaches the critical level, ThinOS is turned off automatically.
You must plug in the AC power to power on the thin client.

Login dialog box features

The Login dialog box enables you to do the following tasks:

e |og in broker to the configured server connection.
e Change or reset your own password, and unlock your account.

View the system information

Use the System Information dialog box to view the system information. You can either click System Information from the
desktop menu or the System Information icon on the taskbar.

The System Information dialog box includes the following elements:

e General tab—Displays the following information:

System version

Terminal name

Serial number

System Up Time

Asset Tag— This element is displayed only when Asset Tag is set in BIOS Setup.
Memory size

Memory Usage

CPU Speed—From ThinOS 2306, the CPU speed changes dynamically

SSD size—the storage size of the SSD/eMMC on which ThinOS is installed.
CPU Utilization

Monitor

Main Resolution

Parallel ports

Serial ports

Battery—mobile thin clients only

Remaining time—mobile thin clients only

e Copyright tab—Displays the software copyright and patent notices.

O 0O 0O 0O o oo oo 0O o o o o o o

Click the Acknowledgments button to view the information that is related to third-party software.

e Event Log tab—Displays the thin client start-up steps beginning from system version to checking firmware or error
messages that are helpful for debugging issues. The number of displays and USB devices that are connected to the thin
client, and the Bluetooth initialization are also displayed.

ENET tab—Displays information about wired network connections.
WLAN tab—Displays information about wireless network connections.
About tab—Displays the following information:

o Platform name

Operating system

Build name

Build version

BIOS name

o O O ©
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BIOS version

Activation License

Citrix Workspace App version

Teradici PColP

VMware Horizon

AVD

WMS status

MQTT server

NOTE:

o Kernel mode—The components are implemented in Kernel according to the specification. The version is displayed
as [max].[min], which is the base version of protocol or server or client of the component.

O 0O 0O O O O O ©o

©

o User mode—The components are from the source, or binaries from third-party software that are compiled or
integrated into the ThinOS operating system. The version is displayed as [max].[min].[svn_revision]. The [max] and
[min] is the base version of the third component, and the [svn_revision] is the source control revision of ThinOS.
Using the ThinOS specified version, you can identify the changes between different revisions. For example, the Citrix
Workspace App version is 19.12.0.19. The components are matched to the installed packages. If the packages are
removed, the field remains empty in the About tab.

Sleep mode

The sleep mode enables the power-saving state and quickly resumes full power operations without loss of data.
The sleep mode feature is supported on the following platforms:

Wyse 5070 Thin Client

Wyse 5470 Thin Client

Wyse 5470 All-in-One Thin Client
OptiPlex 3000 Thin Client
Latitude 3440

Latitude 5440

Latitude 5450

OptiPlex All-in-One 7410
OptiPlex All-in-One 7420

The USB interface is closed in sleep mode. All USB devices such as USB drives, Bluetooth, audio devices, video devices, and
cameras are reinitialized after resuming from sleep mode.

The wired network, wireless network, and VPN are disconnected in sleep mode. However, the network configurations are saved.

All the ThinOS configurations— VDI configuration, network configuration, and so on—are saved automatically in sleep mode. If
you are signed in to a broker agent, all the windows are closed automatically and signed off when entering sleep mode. If you are
not signed on to a broker agent, the windows are not closed when entering sleep mode.

Enable sleep manually

To enable the Sleep option manually, use either of the following options:

e ThinOS lock window—To enter sleep mode using the ThinOS lock window, do the following:
1. Lock your thin client.
2. In the ThinOS lock window, click Sleep.
3. Click OK.
e Shutdown dialog box—To enter sleep mode using the Shutdown dialog box, do the following:
1. Open the Shutdown window.
2. Click Sleep, and then click OK.

You can wake the thin client from sleep mode by pressing the power button, any key on the keyboard, or by clicking the mouse
button. To use the USB keyboard or mouse to wake your thin client, you must enable wake on USB in BIOS.

Wyse 5470 Thin Client—The AC power must be connected to wake the Wyse 5470 Thin Client using the USB keyboard or
mouse. You can also wake the Wyse 5470 Thin Client by opening the lid.
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Import certificates to ThinOS from Admin Policy Tool

or Wyse Management Suite

Steps

1. Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.

SLE

@ NOTE: Admin Policy Tool supports the .cer, .crt, .pfx, .der, and .pemn certificate file types. Wyse Management

On the Configuration Control | ThinOS window, click the Advanced tab.

Expand Privacy & Security, and click Certificates.

Click the Auto Install Certificates slider switch to enable autoinstall of certificates on ThinOS.
Browse and select the certificate that you want to upload.

Suite supports .cer, .crt,.pfx, .der, and . pem certificate file types.

6. From the Select Certificates to Upload drop-down list, select the certificate that you have uploaded.

7. Click Save & Publish.

The certificate is installed on your thin client.

ThinOS system variables

ThinOS uses system variables or part of a system variable when defining command values. System variables are often

used to define unique values for fields such as terminal name or default user. For example, if the client has an IP address
123.123.123.022, ACC&RIight($FIP,3) results in a value of ACC022. Using system variables makes it easier to manage groups of
devices that require a unique terminal name or default user.

The following are the ThinOS system variables:

Table 20. ThinOS system variables

Variable Description

$IP IP address

$IPOCTA4 The fourth octet of the IP Address, for example: if the IP address is 10.151.120.15, then
the value is 15.

$MAC Mac address

$CMAC Mac address with colon.

SUMAC Mac address with uppercase letters is used.

$DHCP (extra_dhcp_option)

Extra DHCP options for Windows CE unit, including 169, 140, 141, 166, 167.

For example, set a string test169 for option tag 169 in DHCP server, and set
TerminalName=$DHCP(169) in wnos.ini. Check terminal name in GUI, and the terminal
name will be test169. 166 and 167 is default for CCM MQTT Server and CCM CA
validation in ThinOS. You must remap the options from GUI or INI if you want to use
$DHCP(166) or $DHCP(167).

$DN Sign on domain name

$TN Terminal name

$UN Sign on username

$SUBNET For subnet notation, the format is {network_address}_{network_mask_bits}. For
example, if the IP address is 10.151.120.15, the network mask is 255.255.255.0, and
10.151.120.0_24 is used.

SFIP

IP address is used in fixed format with 3 digits between separators. For example,
010.020.030.040.ini. Using it in conjunction with the left or right modifier helps to
define policy for subnet. For example, include=&Left($FIP,11).ini is specified to include
file 010.020.030.ini for subnet 010.020.030.xxx.
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Table 20. ThinOS system variables (continued)

Variable Description
$SN Serial number or Service tag
$VN Version number

Right($xx, i) or and Left($xx, i)

Specifies that the variable is to be read from left or right. The $xx is any of above
parameters and the parameter i specifies the digits for the offset of right or left.

&Right($xx, i) or &Left($xx, i)

Specifies whether the variable is read from left or right. The $xx refers to any of the
above System Variables. The option “i” specifies left or right offset digits. For example,
the parameter TerminalName=CLT-$SNSRIGHTS$07. If the Serial Number (or Service
Tag number) of the thin client is MAOO256, the terminal name of the thin client is
assigned as below:

e First four characters—CLT-

e The rest—The last right-most seven digits of the thin client serial number. The
resulting terminal name is displayed as CLT-MAQ00256.

$AT

Asset Tag must be enabled in the BIOS settings. $AT can be used as terminal name, and
the length is limited to 32 characters.

Manual override

The manual override feature enables users to prevent the Wyse Management Suite configured policies from applying to the
device after a particular action is performed on the local ThinOS device. When the manual override feature is enabled, and the
user performs the required action on the ThinOS local device, the configured policies from Wyse Management Suite for these
settings are not applied to the ThinOS device.

Table 21. Manual override support matrix

Settings Action to be performed on the ThinOS local |Default value
device

DHCP Settings Click the OK button in the Network Setup Disabled
window

DNS Settings Click the OK button in the Network Setup Disabled
window

Proxy Settings Click the OK button in the Network Setup Disabled
window

Ethernet Settings Click the OK button in the Network Setup Disabled
window

Wireless Settings Click the OK button in the Network Setup Disabled
window

VPN Settings

Add a new VPN, edit a VPN, or remove a VPN Disabled

Printers Click the OK button in the Printer Setup window | Disabled
Audio Change the audio configuration Disabled
Mouse Click the OK button in the Peripherals window Enabled
Keyboard Change the configuration under the Keyboard Enabled
tab in the Peripherals window, and click the OK
button
Touch pad Click the OK button in the Peripherals window Enabled
Monitor Click the Test button and then click OK in the Disabled

Display Setup window
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Table 21. Manual override support matrix (continued)

Settings Action to be performed on the ThinOS local |Default value
device

Region & Language - Region Change the region configuration and click the OK | Disabled

Settings button

Region & Language - Language | Change the language configuration and click the | Disabled

Settings OK button

Closing the Lid (Mobile Thin Change When | close the lid configuration Disabled

Clients only) and click OK

Login Settings Change the default credentials in the General Disabled

Options tab in Remote Connections
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Configuring the global connection settings

About this task

This section describes how to use the Global Connection Settings dialog box to configure the connection settings for ICA,
Horizon, RDP, and PColP.

Steps

1. Configure the Broker agent connection on ThinOS. See, Configure the Broker Setup.
2. On the desktop taskbar, click

86

(Connection Manager) and then click Global Connection Settings.
The Global Connection Settings dialog box is displayed.

3. Click the Session tab and configure the following options:

Settings common to all session—Select the check boxes to enable options that are applied to all sessions. The
available options are:

o Launch only once—Select the check box when you want the session to be launched only once simultaneously.

o Re-connect after disconnect—Select the check box when you want the session to launch again after the
connection is disconnected.

Mount disks as read-only—Select the check box when you want to disable write access for storage disks.

Enable Imprivata VC—Select the check box when you want the Imprivata VC to be redirected to the remote
session. If this option is not selected, RFIDEAS or Fingerprint reader can be redirected into the remote session.

Auto connect to local devices—Select the check boxes to automatically connect to local devices, such as printers,
serials, smart cards, audio devices, and disks at system startup.

If you want to use the Disks option to connect to sessions automatically, ensure that:

o More than one disk can be used simultaneously. However, the maximum number of USB drives including different
subareas is 12.

o You save all data and sign off from the session before removing the USB drive.

USB device redirection—Select this check box to allow USB devices to be redirected to the remote session. The

available options are:

o Exclude disk devices—Select the check box when you do not want disk devices to be redirected to the remote
session.

o Exclude printer devices—Select the check box when you do not want printer devices to be redirected to the
remote session.

o Exclude audio devices—Select the check box when you do not want audio devices to be redirected to the remote
session.

o Exclude video devices—Select the check box when you do not want video devices to be redirected to the remote
session.

4. Click the ICA tab, and do the following:

a.

b.

Select the check boxes to enable the options that are applied to all sessions. The available options are:

e Seamless window mode—Select this check box when you want to launch applications and desktops seamlessly.
e Desktop with fullscreen mode—Select this check box when you want to launch the desktop session in fullscreen.

e Enable HDX/MMR—Select the check box when you want to enable the Multimedia Redirection feature. When this
option is enabled, the audio and video is rendered on the endpoint device instead of the server.

e Enable session reliability—Select the check box when you want the session to remain active when the network
connection is unstable.

e Enable UDP audio—Select the check box when you want the Citrix connections to use audio over User Datagram
Protocol (UDP).

From the Audio Quality drop-down list, select an audio quality that is optimized for your connection.

5. Click the Horizon tab, and select the check boxes to enable the options that are applied to all sessions. The available options
are:
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e Allow H.264 decoding—Select the check box when you want to enable the H.264 decoding in Horizon Client. Enabling

this option improves the performance of high-end applications. H.264 is disabled by default.

Allow High Color Accuracy—Select the check box when you want to allow Horizon Client to use a superior color
fidelity when H.264 decoding is enabled.

Allow High Efficiency Video Decoding—Select the check box to enable High Efficiency Video Coding (HEVC). For
more information, see High Efficiency Video Coding

@ NOTE: HEVC in Blast Extreme requires both ESXi hosts that supports the virtual desktops, and RDSH servers
to have NVIDIA Tesla or newer graphics cards to offload its encoding. HEVC does not work with only ESXi CPU
encoding. If there are no supported graphics cards present, the H.264 or JPEG/PNG encoding is used.

6. Click the RDP tab, and do the following:

a.

b.

Select the check boxes to enable the options that are applied to all sessions. The available options are:

e Force Span—Select the check box when you want to span the session horizontally across two displays. This option
enables you to use two displays as one large display.

e Record from Local—Select the check box when you want to enable recording from a local microphone.
e Enable NLA—Select the checkbox when you want to verify users before connecting to an RDP direct connection.

In the Desktop Scale Factor box, enter the DPI value in percentage. This option enables you to define the desktop
DPI remotely. The Desktop Scale Factor is only applicable for the RDP connection. Setting this option does not impact
the display scale of the thin client locally. The DPI range is 100-500. If you enter a nonnumeric character, the value is
automatically set to 100. If you enter a value less than 100, the value is automatically set to 100. If you enter a value
higher than 500, the value is automatically set to 500.

Audio Playback option determines the audio playback mode and works for the sessions that are published through the
broker.

7. Click OK to save your settings.
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Configuring connectivity

This chapter helps you understand various configuration settings for a secure connection. To configure the settings on the
classic desktop, click System Setup from the desktop menu, and use the configuration tabs.

Configuring the network settings

Use the network options to configure the network connection based on your requirement.

You can enable or disable IPv6 from Advanced > Network Configuration > Common Settings > Enable IPv6 in Wyse
Management Suite policy settings or the Admin Policy Tool. IPv6 is enabled by default for both wired and wireless networks.

Configure the general settings

About this task

This section describes how to configure the general network settings on your thin client.

Steps

1. From the desktop menu, click System Setup > Network Setup.
The Network setup dialog box is displayed.

2. Click the General tab, and do the following:

Genetal e ENET WLAN

Select Network Interface as the Delaul Gateway

Uiie 5110 Name Serneis

30 Seconds

Figure 12. General tab

NOTE: If network interfaces are in the same subnet, connection to the same subnet is prioritized last by the interface to
fetch the IP address. Connections to the other subnets are prioritized in the order ENETO, ENET1, and WLAN.

a. To set a default gateway, select the type of network interface from the Select Network Interface as the Default
Gateway drop-down list.
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ThinOS supports the dual IPv6 network interface. The following network combinations are supported:

e Wired connection 1 + Wireless connection 1

e Wired connection 1+ Wired connection 2

@ NOTE: The limitation of the dual network is that the device cannot automatically determine which connection to use
among the two.

Use Static Name Servers—By default, this check box is not selected, and the thin client fetches the server |IP address
from DHCP. To manually assign the static IP addresses, select the Use Static Name Servers check box and do the
following:

@ NOTE: If name servers are changed, the details are displayed in event logs. In dynamic mode, the DNS can be
merged from Ethernet and wireless, or from Ethernet O and Ethernet 1.

@ NOTE: From ThinOS 9.1.3112 onwards, you can upload the host file using the Wyse Management Suite policy
settings or the Admin Policy Tool. To upload the file, go to Advanced > System Settings > Device Settings from
the Wyse Management Suite policy settings or the Admin Policy Tool, and click Browse... next to Select Host File.
ANSI or UTF-8 encoding is supported, and the maximum supported file size is 10 KB.

i. Enter the URL address of the DNS domain in the DNS Domain field.
®| NOTE: From ThinOS 9.1.5067 onwards, you can use multiple DNS domain suffixes. Use ; to separate values.

ii. Enter the IP address of the DNS server in the DNS Server field.

However, the use of DNS is optional. DNS enables you to specify remote systems by their host names rather than IP
addresses. If a specific IP address (instead of a name) is entered for a connection, it is used to make the connection.
Ensure that you use the DNS domain and the network address of an available DNS server. The function of the DNS
domain entry is to provide a default suffix that is used to resolve the name. The values for these two fields may be
supplied by a DHCP server. If the DHCP server supplies these values, they replace any locally configured values. If the
DHCP server does not supply these values, the locally configured values are used.

On ThinOS, error tips are displayed when you set an invalid DNS server. A window with the error message is displayed
when you click save the invalid DNS server.

NOTE: You can enter the server addresses, each separated by a semicolon. The character limit is 256. The first
address is for the primary DNS server, and the rest are secondary DNS servers or backup DNS servers.

Enter the IP address of the WINS server in the WINS Server field.

®| NOTE: Only one WINS server is supported.

However, the use of WINS is optional. You must specify the network address of an available WINS name server. WINS
enables you to specify remote systems by their host names rather than IP addresses. If a specific IP address (instead of
a name) is entered for a connection, it is used to make the connection. These entries can be supplied through DHCP, if
DHCP is used. DNS and WINS provide essentially the same name resolution. If both DNS and WINS are available, the thin
client attempts to resolve the name using DNS first and then WINS. You can enter a single WINS Server address.

Enter the digit multiplier of 30 s in the TCP Timeout box to set the time-out value of a TCP connection. The value must
be either 1 or 2 which means the connection time-out value is from 1 x 30 = 30 s to 2 x 30 = 60 s. Setting the time-out
period retransmits the sent data and tries to connect to the server again until the connection is established.

3. Click OK to save your settings.

Configure the DHCP options settings

About this task

This section describes how to configure the DHCP options settings on your thin client.

From the desktop menu, click System Setup > Network setup.
The Network setup dialog box is displayed.

2. Click the Options tab, and do the following:
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Figure 13. Options tab

a. Interpret DHCP Option IDs—Enter the supported DHCP options. Each value can only be used one time after you reset
your device to factory default settings.

Table 22. DHCP option tags

Option Description Additional information
165 Wyse Management Suite server | Optional string. Specifies the IP address of the Wyse Management Suite
server.
166 Wyse Management Suite MQTT | Optional string. Specifies the IP address of the MQTT server.
server
167 Wyse Management Suite CA Optional string. Specifies the CA validation.
Validation
181 PNAgent/ PNLite server list Optional string. The thin client uses the server to authenticate the

credentials of the user. The device obtains a list of ICA published
applications valid for the validated credentials. The user supplies those
credentials when logging in to the thin client.

182 NT domain list for PNAgent/ Optional string. The thin client creates a drop-down list of domains from
PNLite the information that is supplied in the option tag. The list is available
during thin client login in the order that is specified in the DHCP option.
For example, the first domain that is specified becomes the default
option. The selected domain is the one which must authenticate the user
ID and password. Only the selected domain is used in the authentication
process. If the domain list is incomplete and if the user credentials must
be verified against a domain not in the list, you can type a different
domain name during login. This is based on the assumption that the
server in option 181 can authenticate against a domain that is not
available in the list.

199 Wyse Management Suite group Optional string. Specifies a Wyse Management Suite group registration
registration key key for the Wyse Management Suite agent. When Wyse Management
Suite is disabled, and the group key of Wyse Management Suite is null,
this option takes effect. Wyse Management Suite uses the optional
string as the group registration key. If the Wyse Management Suite
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Table 22. DHCP option tags (continued)

Option Description

Additional information

server or the MQTT server is null, the Wyse Management Suite agent

sets the values to the default server values.

b. Interpret DHCP Vendor-Specific Info—Select this check box for automatic interpretation of the vendor information.

c. DHCP Vendor ID—Displays the DHCP vendor ID when the Dynamically allocated over DHCP/BOOTP option is

selected.

d. DHCP UserClass ID—Displays the DHCP user class ID when the Dynamically allocated over DHCP/BOOTP option is

selected.
3. Click OK to save your settings.

@l NOTE: The User Class option for DHCP standard is RFC 2132.

Configure the ENET settings

About this task

This section describes how to configure the Ethernet settings on your thin client.

Steps

1. From the desktop menu, click System Setup > Network setup.

The Network setup dialog box is displayed.
2. Click the ENET tab, and do the following:

Ettermet Sebect

T3 Metwork Sstup b4

T Enable EEER02 1x Authentication

ENET

Ethernet Speed

Figure 14. ENET tab

a. From the Ethernet Select drop-down list, select a wired network connection.
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d.

e.

NOTE: For Wyse 5070 Thin Client without SFP or RJ45 module, the ENETO option is selected by default. For
Wyse 5070 thin client with SFP or RJ45 module and Wyse 5470 Thin Client that is connected to Dell WD19 docking
station, select either ENETO or ENET1 based on your network preference.

From the Ethernet Speed drop-down list, select a value for the Ethernet speed. The default value is Auto-Detect. If
your network equipment does not support the automatic negotiation, select any of the following values:

10 MB Half-Duplex

10 MB Full-Duplex

100 MB Half-Duplex

100 MB Full-Duplex

1000 MB Full-Duplex

NOTE: The 10 MB Full-Duplex value can be selected locally. However, this mode can be negotiated through
Auto-Detect.

Click the IPv4 button, and then click Properties to configure the following options:

Dynamically allocated over DHCP/BOOTP—Select this option to enable your thin client to automatically receive
information from the DHCP server. The network administrator must configure the DHCP server by using DHCP
options to provide information. Any value that is entered locally in the Options tab is replaced by the DHCP value. If
the DHCP server fails to provide replacement values, the locally entered value is used.

Statically specified IP Address—Select this option to manually enter the IP address, subnet mask, and default

gateway.

o IP Address—Enter a valid network address in the server environment. The network administrator must provide
this information.

o Subnet Mask—Enter the value of the subnet mask. A subnet mask is used to gain access to machines on other
subnets. The subnet mask is used to differentiate the location of other IP addresses with two choices—same
subnet or other subnet. If the location is a different subnet, messages that are sent to that address must be
sent through the default gateway. This does not depend on the value that is specified through local configuration
or through DHCP. The network administrator must provide this value.

o Default Gateway—Use of gateways is optional. Gateways are used to interconnect multiple networks—routing
or delivering IP packets between them. The default gateway is used for accessing the Internet or an intranet with
multiple subnets. If no gateway is specified, the thin client can only address other systems on the same subnet.
Enter the address of the router that connects the thin client to the Internet. The address must exist on the same
subnet as the thin client as defined by the IP address and the subnet mask. If DHCP is used, the address can be
supplied through DHCP.

Click the IPv6 button, and on the Properties tab, configure the following options:

@ NOTE: The limitation of the dual IPv6 network is that the device cannot automatically determine which connection

to use among the two.

Select the Dynamically allocated over DHCP/BOOTP option to enable your thin client to automatically receive

information from the DHCP server. The network administrator must configure the DHCP server (using DHCP options)

to provide information. Any value that is entered locally in the Options tab is replaced by the DHCP value. If the

DHCP server fails to provide replacement values, the locally entered value is used.

Select the Statically specified IP Address option to manually enter the IP address, subnet mask, and default

gateway.

o IP Address—Enter a valid network address in the server environment. The network administrator must provide
this information.

Subnet Prefix Len—Enter the prefix length of the IPv6 subnet.

Default gateway—Use of gateways is optional. For more information, see various IPv4-supported options in this
section.

Select the Enable the IEEE 802.1x authentication check box, and from the EAP type drop-down list, select TLS,

LEAP, PEAP or FAST.

TLS—Select this option, and click Properties to configure the Authentication Properties dialog box.

o Select the Validate Server Certificate check box because it is mandatory to validate your server certificate.
@ NOTE: The CA certificate must be installed on the thin client. The server certificate text field supports a

maximum of approximately 255 characters, and supports multiple server names.

Select the Connect to these servers check box, and enter the FQDN of the server.

Click Browse to find and select the client certificate file and the private key file you want.

®| NOTE: Ensure that you select the PFX file only.

o Select either User Certificate or Machine Certificate, base on your choice.
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e LEAP—Select this option, and click Properties to configure the Authentication Properties dialog box. Be sure to
use the correct username and password for authentication. The maximum length for the username or the password is
31 characters.

e PEAP—Select this option, and click Properties to configure the Authentication Properties dialog box. Be sure to
select either EAP_GTC or EAP_MSCHAPvV2, and then use the correct username, password, and domain. Validate
Server Certificate is optional.

e FAST—Select this option, and click Properties to configure the Authentication Properties dialog box. Be sure to
select either EAP_GTC or EAP_MSCHAPvV2, and then use the correct username, password, and domain.

@ NOTE: During the initial connection with EAP-FAST, when there is a request for a Tunnel PAC from the
authenticator, the PAC is used to complete the authentication. The first-time connection always fails, and
the subsequent connections succeed. Only automatic PAC provisioning is supported. The user/machine PAC
provisioning that is generated with CISCO EAP-FAST utility is not supported.

When EAP-MSCHAPV2 or EAP-GTC is selected for PEAP or FAST authentication, an option to hide the domain

is available. Username and password boxes are available for use, but the domain text box is disabled. When EAP-

MSCHAPV2 or EAP-GTC is selected for PEAP or FAST authentication, a check box to enable the single sign-on

feature is available.

3. Click OK to save your settings.

Configure the WLAN settings

About this task
This section describes how to configure the wireless settings on your thin client.

@ NOTE: On the Wyse 5070 Thin Client with an optional SFP module or RJ45 module, you cannot configure the wireless
settings.

Steps

1. From the desktop menu, click System Setup > Network setup.
The Network Setup dialog box is displayed.

2. Click the WLAN tab, and configure the following options:

Figure 15. WLAN tab
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Add—Use this option to add and configure a new SSID connection. You can configure the SSID connection from the
available security type options. After you configure the SSID connection, the added SSID connection is listed on the
WLAN tab.

Remove—Use this option to remove an SSID connection from the list.

Scan—Use this option to allow your thin client to scan and identify a wireless network connection.

Connect—Use this option to join a wireless network from the list.

@ NOTE: From ThinOS 9.1.5067 onwards, when you enter a correct password to connect to the WPA and WPA2
personal wireless connection, the new password is saved and you do not need to enter the password again after you
restart the system.

Properties—Use this option to view and configure the authentication properties of an SSID connection that is displayed

in the list.

IPv4 Config—Click this option to configure the IPv4 settings for the wireless connection.

To set IPv4 connection using either DHCP or static IP address, configure any one of the following options:

o If you want to enable your thin client to automatically receive information from the DHCP server, click Dynamically
allocated over DHCP/BOOTP.

o If you want to manually configure the IP address, click Statically specified IP Address, and provide the IPv4 details.

IPv6 Config—Click this option to configure the IPv6 settings for the wireless connection.
a. To enable the wireless IPv6, click the IPv6 slider switch.
b. To set IPv6 connection using either DHCP or static IP address, configure any one of the following options:

o If you want to enable your thin client to automatically receive information from the DHCP server, click
Dynamically allocated over DHCP/BOOTP.

o If you want to manually configure the IP address, click Statically specified IP Address, and provide the IPv6
details.

Disable Wireless Device—Select this check box to disable a wireless device.
o Always—Click this radio button if you want to keep the wireless options always disabled.
o EnetUp—Click this radio button if you want to disable the wireless device whenever the wired network is connected.

Click OK to save your settings.
@ NOTE: If you have connected to Wi-Fi on a ThinOS device that is connected to the Dell WD19 docking station, you

may not be able to connect to Wi-Fi again after the ThinOS firmware update is installed and your device is automatically
restarted. To resolve this issue, you must restart the ThinOS client again.

WiFi 6E

The WiFi 6E regions that are supported on ThinOS are as follows:

Table 23. WiFl 6E regions and versions

Region First supported ThinOS version
Thailand ThinOS 2402

Mexico ThinOS 2402

Morocco ThinOS 231

Australia and New Zealand ThinOS 2306

Chile ThinOS 2306

Malaysia ThinOS 2306

United Kingdom and EU ThinOS 2303

United States of America ThinOS 2205

Enable captive portal detection for wireless

When you attempt to connect to WiFi, a web page is displayed to verify the authenticated users, before Internet access is
granted. ThinOS supports a captive portal that is based on HTTP redirect. Any captive portal that is based on DNS redirect or
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ICMP redirect is not supported in the current ThinOS release. If an OPT (options) record with DNS resource record (RR) type
41 is available in a received DNS response, the same OPT record must be available in the Additional records section. ThinOS
does not support the DNS response with an OPT record that is available in the Answer section.

Steps

1. Open the Admin Policy Tool on ThinOS or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. Click the Advanced tab and expand Network Configuration.

3. Click Wireless.
4

. On the Global Wireless Settings page, click the Enable Captive Portal Detection toggle switch. Enabling this feature
allows the ThinOS client to display the captive portal web page when you attempt to connect to WiFi.

o

In the Captive Portal Detection Interval Time field, specify the session timeout.

6. Click the Allow HTTP protocol redirection toggle switch if you want to use the HTTP protocol for redirecting to the
captive portal web page.

7. Specify the captive portal detection URL. If the URL is not configured, the system default URL is used.
8. Restart your thin client for settings to take effect.

®| NOTE: If your thin client is connected to a wired network, you must set the default gateway to WLANO.

Configure the proxy settings

About this task

This section describes how to configure the proxy settings on your thin client.

Steps

1. From the desktop menu, click System Setup > Network setup.
The Network setup dialog box is displayed.

Table 24. Supported protocols

Component Supported protocols Additional information
Wyse Management Suite HTTPS, and SOCKS5 N/A

Citrix RealTime Media Engine HTTP N/7A

(RTME)

Azure Virtual Desktop (AVD) HTTP N/A

Horizon HTTP N/A

2. Click the Proxy tab, and configure the following options:

e Proxy Types—You can use HTTP proxy, HTTPS proxy and SOCKS5 proxy types. The proxy type enables the thin client
to connect to the application such as Wyse Management Suite.

e Proxy values—You can enter values for the HTTP proxy, HTTPS proxy and SOCKS5 proxy types. Adding proxy values
enable the thin client to connect to the proxy server.

A new app list value HORIZON is added. For the VMware Broker agent logon to use the proxy, you should specify the Apply
proxy server on field as HORIZON. Unauthenticated proxy is accepted when using HORIZON. Username and password are
ignored.

A new proxy app list value called MTOP is added for Microsoft Teams in an ICA session.
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Figure 16. Proxy tab

Use the following guidelines:

a. Configure the proxy servers based on your requirement.

Enter the HTTP proxy port number or HTTPS proxy port number, username, and password in the respective fields.
However, credential pass through (SUN/$PW) is not recommended because it starts before user sign on.

Wyse Management Suite uses both HTTP/HTTPS and MQTT protocols to communicate with the WMS/MQTT
server. However, the HTTP proxy cannot redirect TCP packages to the MQTT server which requires a SOCKS5 proxy
server. If there is only the HTTP server available, the real-time command that requires MQTT does not work.

®| NOTE: The HTTP/HTTPS proxy default port is 8080.

Enter the SOCKS5 proxy port number, username, and password in the respective fields. If SOCKS5 proxy is
configured, Wyse Management Suite proxy uses the SOCKS5 only. If SOCKS5 is not configured, then Wyse
Management Suite proxy searches for alternative protocols, for example, HTTP in the configuration.

®| NOTE: The SOCKS5 proxy default port is 1080.

Select the Use the first proxy server for all protocols check box to enable all the protocols to use the same
server in the HTTP Proxy fields. Both HTTP and HTTPS proxy use the same host and port, and SOCKS5 proxy agent
uses HTTP host with default Socksb port (1080).

b. Specify the supported applications as Wyse Management Suite, Azure Virtual Desktop (AVD), and RTME separated by a
semicolon in the Apply proxy server on field.

3. Click OK to save your settings.

ThinOS supports the usage of DHCP option tag 252. This option enables the device to fetch the proxy information from
the DHCP server when the device is reset to factory default settings or when you restart the thin client. For example,
http://x.x.x.x/proxy.pac. The proxy settings from DHCP option 252 are not displayed on the ThinOS GUI.
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Proxy is enabled only for configured applications regardless of the availability of DHCP option 252. If you configure an empty
value on the ThinOS local user interface, proxy is enabled for all supported applications by default. If you configure an empty
value in the Wyse Management Suite policy settings or the Admin Policy Tool, proxy is not enabled for any applications. If
DHCP option 252 is available and is supported by the configured application, WPAD (DHCP 252) takes priority. If DHCP 252
is available, WMS is enabled to go through proxy even if it is not configured in the Proxy Application List configuration.
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Table 25. VDI logon or session launch that goes through proxy

Component Features PAC proxy GUI proxy
Citrix http broker log in No No
http broker session No No
launch
https broker log in Yes Yes (RTME value added in the Apply proxy
server on application list field)
https broker session Yes Yes (RTME value added in the Apply proxy
launch server on application list field)
VMware broker log in Yes Yes (HORIZON value added in the Apply
proxy server on application list field)
session launch Yes Yes (HORIZON value added in the Apply
proxy server on application list field)
Azure Virtual Desktop broker log in Yes Yes (AVD value added in the Apply proxy
server on application list field)
session launch No No
Microsoft Remote Desktop | broker log in No No
Services
session launch No No
Amazon WorkSpaces broker log in No No
session launch No No
Teradici Cloud broker log in No No
session launch No No
Wyse Management Suite Wyse Management Yes Yes (WMS value added in the Apply proxy
Suite connection server on application list field)

User scenario

1

Configure the HTTPS proxy server host and port.
2. Configure the user credentials according to the proxy server settings.

Configure the SNMPV3 settings

SNMPV3 in ThinOS requires a security level with both authentication and privacy. This setting can be configured in Wyse
Management Suite policy by going to Network Configuration > SNMPV3 Settings . ThinOS supports MIB tree 1.3.6.1.2.1 but
not 1.3.6.1.2.1.10, 1.3.6.1.2.1.4.20.1.5, and 1.3.6.1.2.1.4.21.1.10. ThinOS supports private MIB tree 1.3.6.1.4.1.714 as below:

Table 26. Private MIB tree

After you restart your system, the client checks in to the Wyse Management Suite server through the HTTPS proxy server.

ThinOS setting

MIB tree version

Serial Number

1.3.6.1.4.1.714.1.2.6.2.1

Undefined yet

1.3.6.1.4.1.714.1.2.6.2.2

Undefined yet

1.3.6.1.4.1.714.1.2.6.2.3

Network speed

1.3.6.1.4.1.714.1.2.6.2.4

Network Gateway

1.3.6.1.4.1.714.1.2.6.2.5

DHCP setting (1 as enabled, O as disabled)

1.3.6.1.4.1.714.1.2.6.2.6

DNS setting (1 as static, O as dynamic)

1.3.6.1.4.1.714.1.2.6.2.7
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Table 26. Private MIB tree (continued)

ThinOS setting MIB tree version

DNS server 1.3.6.1.4.1.714.1.2.6.2.8
Send message to client 1.3.6.1.4.1.714.1.2.6.1.2.0
Reboot client 1.3.6.1.4.1.714.1.2.6.1.1.0

NOTE: Set 1.3.6.1.4.1.714.1.2.6.1.2.0 to send message to client. The message character count is increased to 255
characters.

®

Set 1.3.6.1.4.1.714.1.2.6.1.1.0 to reboot the client. Reboot client behaviors are as below:

e Set to 0: Reboot immediately

e Set to x: Reboot after x minutes (x is integer)

e Set to -1: Cancel reboot

NOTE: If you set 1.3.6.1.4.1.714.1.2.6.1.1.0 to reboot the client, you cannot set another value to change the reboot timer
directly. You must set the value to -1 to cancel the reboot first, and then set another value to reboot again.

Configuring the remote connections

Use the Remote Connections dialog box to configure the connection broker settings, general connection options, and
authentication settings.

Configure the broker setup

About this task

This section describes how to configure the broker setup on your thin client.

Steps

1. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

2. On the Broker Setup tab, select a VDI broker from the Broker type drop-down list, and configure the broker settings.
3. Click OK to save your settings.

@ NOTE: ThinOS enables you to log in to a VDI broker using only a smartcard certificate. To enable this feature, go
to Advanced > Login Experience > Login Settings from the Wyse Management Suite policy settings or the Admin
Policy Tool, and enable the Login Use Smartcard Certificate Only option under Login Experience. When the option
is enabled, other certificates such as user certificates are ignored.

Configure the General Options

About this task

This section describes how to configure the general options on your thin client.

Steps

1. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

2. Click the General Options tab, and do the following:
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Figure 17. General options

a. Click one of the following options to set the action that the thin client should perform after you exit all sessions:

None—By default, None is selected and the thin client automatically returns to the terminal desktop.
Sign-off automatically

Shutdown the system automatically—If you select this option, you must specify a time period after which the thin
client shuts down.

Restart the system automatically—If you select this option, you must specify a time period after which the thin
client restarts.

@ NOTE: You can enable or disable the privilege to cancel shutdown or restart. From the Wyse Management Suite

policy settings or Admin Policy Tool, go to Advanced > Privacy & Security > Account Privileges > Previlige
Level, and select Customize from the drop-down list. Enabled or disable the Allow to Stop Forced Reboot/
Shutdown option. If the option is disabled, when all sessions are ended, users cannot click the Cancel button on the
reboot or shutdown countdown window to stop the process.

b. Enter the default username in the Default Sign-on Username field.
c. Enter the default password in the Default Sign-on password field.
d. Enter the default domain in the Default Sign-on Domain field.

3. Click OK to save your settings.

Configuring the central configurations

Use the Central Configuration dialog box to configure the Wyse Management Suite server settings.

Configure the Wyse Management Suite settings

About this task

This section describes how to configure the Wyse Management Suite settings on your thin client.
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Steps

1. From the desktop menu, click System Setup > Central Configuration.

The Central Configuration dialog box is displayed.
2. On the WMS tab, do the following:

<

Central Configuration

WME

B Enable Wyse Management Suite (WhS) B DNS SRY recoed

Group Regisiration Key

H Enable WIS Advanced Settings

WS server

MOTT ssrver

Enable CA Valsdation

Figure 18. Wyse Management Suite

Select the Enable Wyse Management Suite (WMS) check box to enable the Wyse Management Suite to discover
your thin client. By default, this option is selected. Wyse Management Suite service automatically runs after the client

@ NOTE: If the first discovery, for example, the Wyse Management Suite service is not successful, it continues until a

Select the DNS SRV record check box if you want the thin client to obtain the Wyse Management Suite values through
DNS server, and then try to register into the Wyse Management Suite server. By default, the check box is selected. If
the check box selection is canceled, the thin client cannot obtain the Wyse Management Suite values through the DNS

In the Group Registration Key field, enter the group registration key as configured by your Wyse Management Suite

NOTE: A Group Registration Key is not required for the private Wyse Management Suite server. You can provide
the Wyse Management Suite server details to enable the device to check in to Wyse Management Suite. ThinOS

Select the Enable WMS Advanced Settings check box to enter the Wyse Management Suite server details and to
enable the CA validation. By default, the MQTT server option is disabled. The MQTT server value is populated after the

automatically fetches the MQTT server <tls://xxx.xxx.xxx:8443>. |If port 1883 is blocked in the Wyse Management
Suite server, the ThinOS client cannot switch to the External Secure MQTT server from the External MQTT server.
If you are blocking port 1883, select External Secure MQTT as Preferred MQTT in the Wyse Management Suite

a.
boots.
discovery is successful. If all discoveries fail, it is started again automatically.
b.
server.
C.
administrator for your group. To verify the key, click Validate Key.
registers to a quarantine tenant in Wyse Management Suite.
d.
ThinOS device is checked in to the Wyse Management Suite.
@ NOTE: If you enable the external secure MQTT option on the Wyse Management Suite server, the thin client
server first.
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@ NOTE: The default domain is filled in the login window only when you login and is not displayed in the domain list.
If you want to view the domain in the list, configure the domain in Domain List policy in the Admin Policy Tool or
Wyse Management Suite server.

e. Select the CA validation check box if you want to enable the CA validation feature.

The CA validation is required when you import certificates into your Wyse Management Suite server. By default, the CA
Validation check box is selected to improve the security when using the Wyse Management Suite cloud. This change
affects connections to any of the following servers:

e *.dellmobilitymanager.com
e *.cloudclientmanager.com
e * wysemanagementsuite.com

Table 27. CA validation

Wyse Management CA Validation
Suite deployment

Private cloud When you deploy Wyse Management Suite on a private cloud, the Enable CA Validation
check box is available to configure after you specify the server details in the WMS Server
field. By default, the check box is selected.

Public cloud When you deploy Wyse Management Suite on a public cloud, the Enable CA Validation
check box is selected by default. You cannot disable the Enable CA Validation option.

3. Click OK to save your settings.

@ NOTE: When you modify the Wyse Management Suite information, a dialog box is displayed prompting you to restart
the thin client. To apply the settings immediately, click Reboot Now. If you do not want to restart your client, click
Cancel.

Configure the VPN Manager

VPN Manager is included to manage Virtual Private Network connections. ThinOS uses the OpenConnect client that is based on
the SSL protocol for connecting to a VPN.

About this task

This section describes how to configure the VPN Manager on your thin client.

Steps

1. From the desktop menu, click System Setup > VPN Manager.
The VPN Manager dialog box is displayed.

2. To create a session, click the + icon and do the following:
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Figure 19. VPN Manager

a. Enter the name of the session in the Name field. This option is mandatory. The maximum character limit is 255
characters.

b. Enter the IP address of the VPN server in the Server field. This option is mandatory and is defined as either an IP
address or a hostname. The maximum character limit is 255 characters.

c. Enter the login username in the Username field. This option is mandatory. The maximum character limit is 255
characters.

d. Enter the password in the Password field. This option is not mandatory. The maximum character limit is 255 characters.
e. Select the connection Protocol.

f. Select the Certificate, if needed, for the connection. To add the certificate from the desktop menu, click System
Settings > System Tools > Certificate > Import.

g. Click the Show debug information button to display the VPN debug details for better troubleshooting.
h. Click OK.

When connections are created, the Auto column displays which connection is automatically connected when the device
restarts. Only one session can be set to autoconnect.
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@ NOTE: From ThinOS version 9.1.6108, you can connect to VPN with Cisco AnyConnect, Pulse Secure, or Global
Protect.

3. Select a session, and click Action.

Configure VNC services

Steps

On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.

Click the Advanced tab.

Expand Services and click VNC Service.

To enable VNC shadowing, click the Enable VNC Daemon button.

a. Enter the password in the Password field. The password length is restricted to eight characters from ThinOS 9.1.2101.
b. Click the Enable 8 bits button to use 8-bit color resolution.

c. Click the Enable Zlib button to enable Zlib compression.

d. Click the Enable VNC Prompt button to display a prompt to allow or reject a VNC shadowing request.

N

The shadowing request times out if there is no user interaction. The following options can be set for a timeout.
e Select Timeout Type—Select the action to be performed after the VNC shadowing request times out. You can
select Accept or Reject.
e Timeout—Specify a time between 0 to 600 seconds for the VNC shadowing request to timeout, if there is no user
interaction.
e. Click the Enable View Only button to activate the view only mode.
Click the Active Visible button to notify the user that the device is being shadowed.
g. Enter the IP addresses from which VNC connections can be initiated, in the VNCD Server field. You can only enter a
valid IP address in this field.
h. Specify the VNC port used for TCP-based connections in the VNCD TCP Port field.

The default port is 5900. The current connection is not affected when you change the port. The port change takes
effect during the next VNC connection.

5. Click Save & Publish.

—h
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Configuring connection brokers

In a Virtual Desktop Infrastructure (VDI) environment, a connection broker is a software entity that enables you to connect
to an available desktop. The connection broker facilitates the VDI environment to securely and efficiently manage the centrally
hosted desktop environments.

Configuring Citrix

Citrix offers a complete virtualization solution, where all applications and resources are deployed on a centralized server, and
published to remote devices. In ThinOS 9.x, Citrix Receiver is replaced by Citrix Workspace app. Citrix Workspace app, a client
software released by Citrix, enables you to access all your virtual apps, desktops, and other Citrix products from a single
workspace Ul. For more information about Citrix Workspace App, see the Citrix documentation at docs.citrix.com.

@l NOTE: In ThinOS, USB device can only be redirected in to an ICA session when the mouse focus is inside the session.
For the Citrix VDI related settings in Wyse Management Suite and Admin Policy Tool, Dell Technologies recommends configuring
the settings before signing in to Citrix broker. If you have already signed in to the broker, you must sign off or reboot the client.

To access Citrix sessions using Citrix Workspace app, do the following:
1. Deploy the Citrix Workspace app package using Wyse Management Suite or Admin Policy Tool.
2. Go to System Setup > Remote Connections > Broker setup, and configure the Citrix broker.

NOTE: The Enable Volume Control for Client Volume option added in Personalization > Shortcut Keys, under Admin
Policy Tool or Wyse Management Suite policy settings can be used to control the ThinOS local volume from the remote
session. This option is added to resolve the Citrix limitation.

From Citrix Workspace app 2112 and ThinOS 9.1.5067, the following updates are added:

e The battery status indicator is displayed in the notification area for server VDAs. This feature is enabled by default. In the
previous version of Citrix Workspace app, only Windows VDA such as Windows 10 is supported.

e Adaptive audio works while using User Datagram Protocol (UDP) audio delivery. Adaptive audio is enabled by default. This
feature requires VDA version 2112 or later versions. For more information, see the Citrix Virtual Apps and Desktops product
documentation at docs.citrix.com.

@l NOTE: From ThinOS 9.1.5067 onwards. you can map a USB drive with NTFS format to Citrix and RDP sessions.

For information about the supported Citrix Workspace app features in ThinOS, see the Citrix Workspace app feature matrix
table in the Release Notes of your ThinOS version at www.dell.com/support

Android smartphone USB redirection through Citrix Configuration
Editor

From ThinOS 2402 and Citrix Workspace App 2311, you can configure the Android smartphone device redirection using Citrix
USB File Settings in Citrix Configuration Editor. To redirect the Android smartphone into an ICA session, do the following:

Steps
1. In the Key field, enter CONNECT.
2. In the Value field, enter vid=04e8 pid=6860 split=01 intf=00.

NOTE: The VID PID in the Value field must be replaced by the VID PID of your Android smartphone. Samsung Galaxy
SM-ES5260 phone is qualified with ThinOS 2402.
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Configure the Citrix broker setup

About this task

This section describes how to configure the Citrix broker setup on your thin client.

Steps

1. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

2. On

the Broker Setup tab, select Citrix Virtual Apps and Desktops from the Select Broker Type drop-down list, and do

the following:

$5 Remote Connections

Select Broker Type: | Citrix Virual Apps and Deskiops
Workspace Mode
Broker Server

Auto Connect List

Enable automatic reconnection at logon

Connect 1o disconnecied sessions only

Connect to active and disconnected sessions
Enable automatic reconnection from button menu

Connect to disconnecied sessions only

Connect 10 Active and disconnecied SEssons

Figure 20. Broker Setup

Select the Workspace Mode check box if you want to enable the Citrix Workspace based layout of published
applications and desktops.

In the Broker Server field, enter the IP address or hostname or FQDN of the Citrix server. You can enter the Citrix
NetScaler Gateway URL, StoreFront URL, or the web interface URL.

In the Auto Connect List field, enter the name of the connection that is displayed in Connection Manager to
automatically connect after you log in the Citrix broker. You can enter more than one connection name. Each connection
name is separated by semi-colon, and is case-sensitive.

NOTE: On the desktop taskbar, click % to open Connection Manager.

Select the Enable automatic reconnection at logon check box if you want to automatically reconnect to the
disconnected sessions or both active and disconnected sessions during login. You must click either of the following
options:

e Connect to disconnected session only

e Connect to active and disconnected sessions

Select the Enable automatic reconnection from button menu check box if you want to automatically reconnect to

the disconnected sessions or both active and disconnected sessions by using the Reconnect button in the button menu.
You must click either of the following options:

e Connect to disconnected session only
e Connect to active and disconnected sessions

To use the reconnect option, left-click the button menu, and click Reconnect.
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3. Click OK to save your settings.

Classic mode vs Workspace mode

This section summarizes the differences between classic mode and workspace mode.
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Figure 21. Classic mode
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Table 28. Classic mode vs Workspace mode

Item

Classic mode

Workspace mode

How to enable

By default, the ThinOS loads the classic mode
if you do not select the Workspace mode check
box during Citrix broker setup.

Select the Workspace mode check box during Citrix
broker setup.

Desktop elements

Displays the ThinOS full taskbar and the classic
desktop.

Displays the ThinOS full taskbar and the workspace
desktop.

Access all published
desktops

Click the icon on the classic desktop to launch
the published desktop.

Click the Desktops icon on the purple ribbon to
access all the published desktops.

Access all published
apps

Click the icon on the classic desktop to launch
the published application.

Click the APPS icon on the purple ribbon to access
all the published desktops.

Access favorites

Not applicable

Click the Favorites icon on the purple ribbon.

Access Connection
Manager

On the left corner of the taskbar, click .

Click the button menu in the upper-right corner of
the screen, and then click Connection Manager.

Switch account
when logged in with
multi server

Displays all icons of desktop and applications.
You cannot switch the account.

Click the button menu in the upper-right corner of
the screen, and then click Accounts.

Refresh Citrix
application

Click the PNAmenu button on the taskbar, and
then click Refresh.

Click the button menu in the upper-right corner of
the screen, and then click Refresh.

Reconnect a session

Click the PNAmenu button on the taskbar, and
then click Reconnect.

Click the button menu in the upper-right corner of
the screen, and then click Connection Center >
Reconnect.

Disconnect from the
session

Click the PNAmenu button on the taskbar, and
then click Disconnect.

Click the button menu in the upper-right corner of
the screen, and then click Connection Center >
Disconnect .
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Table 28. Classic mode vs Workspace mode (continued)

Item

Classic mode

Workspace mode

Log off all the
connected ICA
sessions

Click the PNAmenu button on the taskbar, and
then click Logoff.

Click the button menu in the upper-right corner of
the screen, and then click Connection Center >
Logoff.

Sign out of broker
agent

Click the Sign-off button in Connection
Manager or from the Shutdown menu.

Click the button menu in the upper-right corner of
the screen, and then click Sign out. You can also
click Sign out from the Shutdown menu.

Use search bar

Not applicable

Use the search bar on the upper-right of the screen
to search for your workspace item. You can open
apps directly from the search results.

Access Desktop
Viewer/Toolbar

Click the Desktop Viewer/Toolbar on the top
center of the Citrix session screen to use the
following toolbar options:

Home

Switch

Ctrl+Alt+Del
Window/Full-screen
Preferences

Save Layout
Disconnect

Sign Out

You can switch a session between a windowed
and a full-screen session window. Save layout is
available only for the local AD user session and
not for users who use SAML authentication to
log in to the Citrix session.

Click the Desktop Viewer/Toolbar on the top
center of the Citrix session screen to use the
following toolbar options:

Home

Switch

Ctrl+Alt+Del
Window/Full-screen
Preferences

Save Layout
Disconnect

Sign Out

You can switch a session between a windowed and
a full-screen session window. Save layout is available
only for the local AD user session and not for users
who use SAML authentication to log in to the Citrix
session.

Citrix ADC

ThinOS supports Citrix Application Delivery Controller (ADC), formerly known as Citrix NetScaler. The following authentication
methods are supported on ThinOS:

RSA

DUO

SMS PASSCODE
Native OTP

OKTA
PingID MFA

Lightweight Directory Access Protocol (LDAP)

Federated Authentication Service with Azure active directory

Timeout is enabled for Citrix ADC login by default. To disable the timeout, go to Advanced > Broker Settings > Citrix Virtual
Apps and Desktops Settings from the Wyse Management Suite policy settings or the Admin Policy Tool, and disable the
Netscaler/ADC Login Timeout option.

By default, the NetScaler/ADC Authentication using web-based login option is enabled for the applicable Citrix ADC server.
To disable the web-based login, go to Advanced > Broker Settings > Citrix Virtual Apps and Desktops Settings from

the Wyse Management Suite policy settings or the Admin Policy Tool, and disable the Netscaler/ADC Authentication using
web-based login option.

@ NOTE: Dell technologies recommends that you do not disable the Netscaler/ADC Authentication using web-based

login option.
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Citrix two-factor authentication

ThinOS supports Citrix two-factor authentication that authenticates the identity of the user twice before granting access,
adding an extra level of security.

For local authentication, there must be a user profile that is created in the Citrix ADC database. For external authentication,
the username and password that is entered must be the same as registered in the authentication server. After a successful
validation of the username and password, the user is requested for another level of authentication.

ThinOS supports LDAP, RSA+LDAP, SMS Passcode, DUO, OKTA, and Azure MFA authentications by default. The user must only
provide the Citrix ADC gateway address.

To log in to NetScaler Gateway that uses LDAP with RSA authentication, you must select LDAP+RSA in the Wyse
Management Suite policy. You can also go to Admin Policy Tool and configure the NetScaler/ADC Authentication Method
option in the Citrix Virtual Apps and Desktops Settings window.

For specific users who want to use Citrix ADC authentication methods, such as RSA, Dell Technologies recommends that you
configure the NetScaler/ADC Authentication Method with RSA either using the Wyse Management Suite policy or Admin
Policy Tool.

For specific users who want to use Citrix ADC authentication methods, such as LDAP with MFA, Dell Technologies recommends
that you configure the NetScaler/ADC Authentication Methodwith LDAP either using the Wyse Management Suite policy or
the Admin Policy tool.

For specific users who want to use Citrix ADC authentication methods, such as RSA+LDAP with MFA, Dell Technologies
recommends that you configure the NetScaler/ADC Authentication Method with RSA+LDAP either using the Wyse
Management Suite policy or the Admin Policy tool. This setting is supported from Wyse Management Suite 3.5 and later
versions.

Configure Citrix ADC using LDAP and RSA

About this task
This section describes how to configure the Citrix ADC (formerly NetScaler) using LDAP and RSA authentication.

Steps
1. Go to NetScaler > NetScaler Gateway > Virtual Servers, and click Edit.
2. Set the primary and secondary authentications based on the following scenarios:

e |f you use LDAP and RSA login, ensure that the primary authentication is LDAP and secondary authentication is RADIUS.
You must also ensure that the NetScaler Gateway Authentication Method in the Wyse Management Suite policy or
the Admin Policy Tool is configured as LDAP+RSA.

If you use RSA and LDAP login, ensure that the primary authentication is RADIUS and secondary authentication is LDAP.
If you use only LDAP login, ensure that the primary authentication is LDAP and secondary authentication is none.

3. Go to System Setup > Remote Connections and select Citrix Virtual Apps and Desktops from the Broker type
drop-down list.

4. Enter the Citrix ADC server address in the Broker Server field.

5. Log off from the client desktop, or restart the thin client.
The login window for Citrix ADC is displayed.

For more information about configuring Citrix ADC with LDAP, RSA authentication, see the Citrix NetScaler Gateway Guide
at www.citrix.com.

Configuring Citrix ADC using DUO

About this task
To configure the Citrix ADC (formerly NetScaler) using DUO authentication, do the following:

Steps
1. Go to NetScaler > NetScaler Gateway > Virtual Servers, and click Edit.
2. Ensure that the primary authentication is RADIUS that is configured with the DUO authentication RADIUS.
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3. Ensure that the secondary authentication is none.
4, Enter the broker address in the ThinOS user interface.

Example

For more information about configuring Citrix ADC with DUO authentication, see the Citrix NetScaler Gateway Guide at
www.duo.com.

Configure Citrix ADC using CensorNet MFA authentication

Prerequisites

SMS PASSCODE is re-branded as CensorNet MFA. You can configure the Citrix ADC (formerly NetScaler) to use a One

Time Passcode/Password (OTP) in the form of a personal identification number (PIN) or passcode. To obtain this one-time
password, you must install CensorNet app on your mobile. After you enter the passcode or PIN, the authentication server
invalidates the one-time password. You cannot enter the same PIN or password again. For more information about configuring
one-time passcode, see the Citrix documentation.

Prerequisites

e Citrix ADC (formerly NetScaler) v12.0 and later is installed on your client.

e SMS PASSCODE v9.0 SP1 or later is installed and configured in your network.

e Remote Authentication Dial-In User Service (RADIUS) authentication policy is configured and bind to the Citrix ADC server.
e CensorNet app is installed and configured on your mobile device.

About this task

To use the one-time passcode on ThinOS, do the following:

Steps
1. Log in to ThinOS and connect to the ADC URL.

2. Enter your credentials, and press Enter.
The PASSCODE dialog box is displayed. You will receive a push notification from the CensorNet App on your phone with the
code.

3. Click OK.
If the authentication is successful, you are logged into the Citrix session.

Citrix ADC Native OTP

Citrix ADC (formerly NetScaler) Native OTP enables Citrix ADC Gateway to use one-time passwords (OTPs) for authentication
without the need of an extra authenticating server. A one-time password that is generated by Google Authenticator is
considered to be highly secure as passcodes are randomly generated.

In ThinOS 2205 and earlier versions, if you access the Broker agent using Citrix ADC native OTP authentication, lock terminal

is not supported as it is a web-based authentication. When you try to use lock terminal, a message is displayed where you can
click either Continue to log off or click Cancel to stay on the screen. You are automatically signed off from the account in sixty
seconds for security purposes.

Unable to Lo unt X

em configuration prevents automatic locking of

For security purposes, you will be signed off in 00:56 seconds.

Continue” to sign off now, or "Cancel” to stop

Figure 23. Unable to lock account
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In ThinOS 2208 (9.3.2102), after logging into a VDI Broker agent with Web Authentication and locking the ThinOS session, you
must set a temporary password to unlock the system.

From ThinOS 2211 (9.3.3096) onwards, a temporary password is not required. You can use the password that is used at the time
of logging in to unlock the system directly.

For more information about Native OTP support for authentication, see the NetScaler Gateway12.0 documentation at
docs.citrix.com.

Log in to Citrix ADC using the passcode

Prerequisites

e Ensure that you are using Citrix ADC (formerly NetScaler) 12.0 build 51.24 and later versions.

e Ensure that you have registered your device with Citrix ADC. For a detailed procedure on how to register your device with
Citrix ADC, see the Native OTP support for authentication article at docs.citrix.com.

About this task
This section describes how to log in to Citrix ADC using the OTP.

Steps
1. From the desktop menu, click System setup > Remote Connections.
The Remote Connections dialog box is displayed.
2. Click the Broker Setup tab and select Citrix Virtual Apps and Desktops from the Broker Type drop-down list.

3. Enter the IP address of the Citrix ADC FQDN server in the Broker Server field.
You can configure other options if required.

4. Click OK.
The NetScaler login window is displayed.

5. Launch the Google Authenticator application on your phone and get the passcode.

6. In the Citrix ADC login window, enter the passcode and click OK.
If the authentication is successful, you are logged into Citrix ADC.

Citrix Federated Authentication Service SAML with Microsoft Azure Active
Directory

ThinOS supports the Citrix Federated Authentication Service with Microsoft Azure Active Directory during single sign-on to
Citrix ADC using the Security Assertion Markup Language (SAML) based authentication. The FAS server delegates the user
authentication to the Microsoft ADFS server or Azure AD with Security Assertion Markup Language (SAML). Both, Azure AD
Multiple Factors Authentication (MFA) and Self-service password reset (SSPR), are supported.

NOTE: To use this function, you must enable Federated Authentication Service. If Federated Authentication Service is
disabled, the Citrix ADC session fails to launch.

In ThinOS 2205 and earlier versions, if you access the Broker agent using SAML, lock terminal is not supported as it is a
web-based authentication. When you try to use lock terminal, a message is displayed where you can click either Continue to
log off or click Cancel to stay on the screen. You are automatically signed off from the account in sixty seconds for security
purposes.
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Unable to . unt X

Figure 24. Unable to lock account

In ThinOS 2208 (9.3.2102), after logging into a VDI Broker agent with Web Authentication and locking the ThinOS session, you
must set a temporary password to unlock the system.

From ThinOS 2211 (9.3.3096) onwards, a temporary password is not required. You can use the password that is used at the time
of logging in to unlock the system directly.

Limitation: Don't ask again for X days and Don't show this again messages are not displayed during Azure SAML MFA login
(X means the number of days). This issue also occurs in Citrix Workspace App Linux binary

Enable Azure Multiple Factor Authentication for Citrix ADC Single Sign-on with SAML
Authentication

Prerequisites

Create an Azure AD user in Azure Active Directory.

Enable the Multiple Factor Authentication (MFA) for the user.

Add the user to Azure AD Citrix ADC (formerly NetScaler) Enterprise application users and groups.
Ensure that the shadow account of the user exists in local domain users group.

Ensure that the SAML authentication policy is enabled. For more information, see the NetScaler Gateway documentation at
docs.citrix.com.

About this task

This section describes how to log in to Citrix ADC using SAML with Azure Multiple Factor Authentication.

Steps

1.

o

N o o b
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From the desktop menu, click System setup > Remote Connections.
The Remote Connections dialog box is displayed.

On the Broker Setup tab, select Citrix Virtual Apps and Desktops from the Broker Type drop-down list.

Enter the Citrix ADC Gateway URL in the Broker Server field, and click OK.
The login window is displayed.

Enter the username of the Azure AD user and click Next.

Enter the initial password for the Azure AD user, and click Sign in.

In the More information required window, click Next.

On the Additional Security Verification page, do the following:

a. From the How should we contact you? drop-down list, select any one of the following methods:
e Authentication phone
e Mobile app

b. If you select Authentication phone, enter your phone number. If you select Mobile App, click Set up and follow the
on-screen instructions to add an account to the Microsoft authenticator app.

c. Click Save.
Enter the Azure AD username with the initial password again.

If you are using mobile app, approve the notification. If you are using the authentication phone, verify your information
through a phone call or a text code.
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10. Log in to Citrix ADC and launch the session.

Enable Azure AD Self-Service Password Reset function for Citrix ADC Single Sign-on

with SAML authentication

Prerequisites

N N

Create an Azure AD user in Azure Active Directory.

Add the user to Azure AD Citrix ADC (formerly NetScaler) Enterprise application users and groups.
Ensure that the shadow account of the user exists in local domain users group.

Ensure that Self-Service Password Reset Enabled option is selected in Azure AD for the user.

About this task

This section describes how to enable Azure AD Self-Service Password Reset function for Citrix ADC Single Sign-on with SAML
authentication.

Steps

1

2.

On the Broker setup tab, select Citrix Virtual Apps and Desktops from the Broker type drop-down list.
In the Broker Server field, enter the Citrix ADC Gateway URL, and click OK.
The login window is displayed.
Enter the user credentials of the Azure AD user and click Next.
On the Don't lose access to your account! page, configure the following options:
e Authentication Phone
a. Click Set it up now.
b. From the drop-down list, select your country code.
c. Enter your phone number.
d. Click either text me or call me.

A verification code is received on your phone by call or text message.

e. Enter the verification code and click Verify.
e Authentication Email

a. Click Set it up now.

b. Enter the valid email address.

c. Click email me.

A verification code is sent to your email.

d. Enter the verification code and click Verify.
Click Finish.
Continue with the user login.

Configure Citrix NetScaler using Okta

Okta provides Single Sign-On (SSO) capability using Remote Authentication Dial-In User Service (RADIUS) for Citrix Virtual
Apps and Desktops. ThinOS supports Okta through the Citrix NetScaler Gateway 11.0 or later. The Okta RADIUS Agent is
used for user authentication. The Okta RADIUS server agent assigns the user authentication to Okta using single-factor
authentication (SFA) or multifactor authentication (MFA).

For more information about configuring Citrix NetScaler Gateway to use the Okta RADIUS Agent, see the Citrix NetScaler
Gateway Radius Configuration Guide at help.okta.com.

@ NOTE:

e On the ThinOS client, you need UPN at the login window.

e Phone authentication by using Okta is supported only in US and Canada.
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Limitation

In ThinOS 2208 and earlier versions, only OKTA with Citrix Gateway (RADIUS) is verified. However, the StoreFront with OKTA
SAML authentication or OKTA with Citrix Gateway (SAML) is not verified. OKTA with Citrix Gateway (SAML) is supported from
ThinOS 2211 and Citrix Workspace App 2209.

Log in to Citrix ADC using MFA with SAML, OKTA as IDP, and Citrix FAS for
SSO to VDA

This section describes how to log in to Citrix Application Delivery Controller (ADC) through Multiple Factors Authentication
(MFA) with Security Assertion and Markup Language (SAML). This section also describes how to log in to Citrix ADC using
OKTA as the identity provider, and Citrix FAS for Single Sign-On (SSO) to VDA.

Steps
1. From the desktop menu, go to System setup > Remote Connections.
The Remote Connections dialog box is displayed.
2. Click the Broker Setup tab and select Citrix Virtual Apps and Desktops from the Broker Type drop-down list.
3. Enter the Citrix ADC gateway server URL in the Broker Server field. You can also configure other options.

4. Click OK.
The NetScaler gateway Webview login window is displayed, and you are redirected to Okta IDP for authentication.

5. Enter the user credentials with UPN format and password.
If you have not registered your phone with Okta Verify, you are prompted to setup MFA.
6. Select Enter a code or Get a push notification security method using Okta Verify application.

7. Launch the Okta Verify application on your phone.
e |f you selected Enter a code previously, enter the code in the Citrix ADC login window and click Verify.
e If you selected Get a push notification, approve the push notification on your phone once you get it.
If the authentication is successful, you are logged into Citrix ADC.

®| NOTE: ThinOS does not support Okta Single Sign-On (SSO) with Certificate Authentication.
In ThinOS 2208 (9.3.2102), after logging into a VDI Broker agent with Web Authentication and locking the ThinOS session,
you must set a temporary password to unlock the system.

From ThinOS 2211 (9.3.3096) onwards, a temporary password is not required. You can use the password that is used at the
time of logging in to unlock the system directly

Log in to Citrix ADC using PinglD Multi Factor Authentication

From ThinOS 2306 and Citrix Workspace App 2305, you can log in to Citrix ADC (NetScaler) with PinglD Multi Factor
Authentication.
1. From the desktop menu, go to System setup > Remote Connections.

The Remote Connections dialog box is displayed.

2. Click the Broker Setup tab and select Citrix Virtual Apps and Desktops from the Broker Type drop-down list.
Enter the Citrix ADC gateway server URL in the Broker Server field. You can also configure other options.
4. Click OK.

o

The NetScaler gateway Webview login window is displayed, and you are redirected to Pingldentity for authentication.

5. Enter the user credentials with UPN format and password.

When you log in for the first time to PinglD, a download link and QR code is displayed that helps install the authenticator
application in your phone.

6. Launch the PinglD application on your phone and Slide up in the application to complete the authentication.
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FIDO2 authentication when connecting to on-premises stores

From ThinOS 2402 and Citrix Workspace App 2311, you can authenticate using FIDO2 security keys, which do not require
passwords, when signing in to on-premises stores. Citrix Workspace app uses the ThinOS Extension as the default browser
for FIDO2 authentication in ThinOS. Administrators can configure the ThinOS Extension using Admin Policy Tool or Wyse
Management Suite policy settings to authenticate to CWA. To enable FIDO2 authentication for logging in to on-premises stores,
do the following:

Steps

1. Open Admin Policy Tool or Wyse Management Suite policy.

2. Go to Broker Settings > Citrix Virtual Apps and Desktops Settings.

3. Set Broker server address to the address that has enabled FIDO2 authentication method.

@ NOTE: FIDO2 Security Key to log in to Citrix ADC with OKTA SAML MFA and FIDO2 Security Key to log in to Citrix ADC
with Azure AD MFA are two test environments that can be used in ThinOS.

4. Enable WebLogin Use External Engine.

B. Ensure that WebLogin Use ThinOS Extension is ThinOS Extension. ThinOS Extension is the only supported extension
and is the default value.

®| NOTE: To use ThinOS Extension, install the ThinOS Extension application package and enable the policy.
®| NOTE: Do not use the Citrix Enterprise Browser (CEB).

Click Save & Publish.
Sign out or restart the device for the settings to take effect.
In the webview login window, enter the PIN code of the Yubikey device.

© ® N O

Touch the Yubikey device to log in to the Citrix broker server.

Citrix Cloud services

ThinOS supports Citrix Cloud services. It acts as a single management console to deploy applications or desktops on any virtual
or cloud setup for a secure digital workspace. For more information about Citrix Cloud services, see the Citrix Cloud article at
docs.citrix.com.

Getting started with Citrix Cloud

About this task

This section describes how to log in to the Citrix Cloud server on your thin client.

Steps

1. From the desktop menu, click System Setup > Remote Connections.

The Remote Connections dialog box is displayed.

2. On the Broker Setup tab, select Citrix Virtual Apps and Desktops from the Broker Type drop-down list, and do the
following:

a. Select the Workspace Mode check box if you want to enable the Citrix Workspace-based layout of published
applications and desktops. If this option is not selected, you are logged in to the classic mode.

b. In the Broker Server field, enter the Citrix Cloud URL.

c. Inthe Auto Connect List field, enter the name of the desktops that you want to launch automatically after logging
in to Citrix Cloud. You can enter more than one desktop. Each desktop name is separated by a semi-colon and is case
sensitive.

d. Select the Enable automatic reconnection at logon check box if you want to automatically reconnect to the
disconnected sessions or both active and disconnected sessions during login. You must click either of the following
options:

e Connect to disconnected session only
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e Connect to active and disconnected sessions

e. Select the Enable automatic reconnection from button menu check box if you want to automatically reconnect to
the disconnected sessions or both active and disconnected sessions by using the Reconnect button in the button menu.
You must click either of the following options:

e Connect to disconnected session only
e Connect to active and disconnected sessions

3. Click OK to save your settings.
4. In the login window, enter your domain username and password to log in to Citrix Cloud.
ICA icons are displayed in Connection Manager and on the client desktop.

Automatically configure using DNS for email discovery

You can connect to a Citrix session by using an email address. The email address is used to discover the StoreFront or NetScaler
Gateway URL.

Prerequisites

e |Install a valid server certificate on the StoreFront/AppController server and Access Gateway appliance.
e The full chain or path to the root certificate must be correct.

About this task

This section describes how to connect to a Citrix session by using email-based discovery.

Steps

1. Add a service record (SRV) to your DNS server to enable email-based discovery. To add a service record to the DNS server,
do the following:

o

Log in to the DNS server.

Go to DNS > Forward Lookup Zone.

Right-click Forward Lookup Zone, and click Other New Records.

In the Resource Record Type dialog box, select Service Location (SRV).
Click Create Record.

In the Service field, enter citrixreceiver.

In the Protocol field, enter tcp.

In the Port number field, enter the port number.

In the Host offering this service field, enter the FQDN and the port for the StoreFront/AppController server or Access
Gateway appliance.

~TQ 0 Q0D

®| NOTE: You cannot use the same FQDN for both StoreFront and the Access Gateway virtual servers.

2. On ThinOS, go to System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

On the Broker Setup dialog box, select Citrix Virtual Apps and Desktops from the Broker Type drop-down list.
Enter the email address in the Broker Server field, and click OK.
Restart the thin client.

o o bHoo

In the login window, enter your email address and password to log in to the session.

Citrix HDX Adaptive transport (EDT)

ThinOS supports Citrix HDX Adaptive transport for Citrix Virtual Apps and Desktops. HDX Adaptive transport enables the ICA
virtual channels to automatically adapt to varying LAN and WLAN connections and improves the data throughput.

For more information about Citrix HDX Adaptive transport, see the Citrix documentation at docs.citrix.com.
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Enable HDX Adaptive Transport

About this task

This section describes how to enable the HDX Adaptive Transport policy setting on Citrix Studio.

Steps

1

2.

Go to Citrix Studio > HDX Adaptive Transport policy.

Set the value for HDX Adaptive Transport to either Preferred or Diagnostic mode.

For more information about configuration on Citrix Studio, see the Adaptive Transport article at docs.citrix.com.
On the ThinOS client, start a session from the Citrix Workspace app.

The connection is established using adaptive transport.

@ NOTE: If the connection type is HDX and the protocol is UDP, EDT is active for the session. If the protocol is TCP, the
session is in fallback mode.

For information about how to verify if HDX Adaptive Transport is active, see the FAQs section in this guide.

From ThinOS 2306 and Citrix Workspace app 2305, HDX Enlightened Data Transport can be disabled using Citrix
Configuration Editor. Follow these steps to disable the feature:

a. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

b. In the Citrix ICA File Settings, click Add Row.

c. In the Key field, enter HDXOverUDP.

d. In the Value field, enter Of£.

e. Sign out or restart the device for the settings to take effect.

To enable HDX Enlightened Data Transport using Citrix Configuration Editor, do the following:

a. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

b. In the Citrix ICA File Settings, click Add Row.

c. Inthe Key field, enter HDXOverUDP.

d. In the Value field, enter Preferred.

e. Sign out or restart the device for the settings to take effect.

Maximum Transmission Unit (MTU) discovery in Enlightened Data Transport
(EDT)

From ThinOS 2311 and Citrix Workspace App package 23.9.0.24.4, Maximum Transmission Unit (MTU) discovery in Enlightened
Data Transport (EDT) is supported.

MTU increases the reliability and compatibility of the EDT protocol and provides an improved user experience.

MTU Discovery enables EDT to automatically determine the Maximum Transmission Unit (MTU) when establishing a session.
This prevents EDT packet fragmentation that might result in performance degradation or failure to establish a session.
System requirements:

o Citrix Virtual Delivery Agent (VDA) 2003 and later

o Citrix Workspace app package version 23.9.0.24.4 and later

o Session reliability enabled

MTU Discovery is enabled by default. To disable EDT MTU Discovery, configure the following registry values and restart the
VDA:

o Key: HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\icawd

o Value name: MtuDiscovery

o Value type: DNORD

o Value data: 0

This setting is machine-wide and affects all sessions connecting from a supported client.

To configure Maximum Segment Size (MSS) when using EDT on networks with nonstandard MTU, do the following:
1. You can set the EDT MTU Discovery Registry key value below to disabled (value 0) and restart the VDA.
o Key: HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\icawd
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o Value name: MtuDiscovery
Value type: DWORD
o Value data: 0

®| NOTE: If the value is 1, then MTU discovery is enabled. If the value is 0, MTU discovery is disabled.

2. You can also configure the MTU or MSS rates manually by doing the following:
a. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor >

Citrix Configuration Editor.

In Citrix INI Settings, click Add Row.

From the File drop-down list, select All_Regions.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter Network\UDT.

In the Key field, enter edtMSS.

In the Value field, enter a value, such as 1480. The MTU value must be determined for each network independently

and is not a one-size-fits-all solution.

h. Sign out or restart the device for the settings to take effect.
NOTE: By design, Citrix Workspace App does not support disable EDT MTU Discovery from the client side. You
can enable or disable EDT MTU Discovery on VDA.

@ *0o0DT

HDX Adaptive Display V2

ThinOS supports the selective use of a video codec (H.264) to compress graphics during video playback in an ICA session. This
feature combines the H.264 mode and Thinwire Compatible mode for a better user experience.

For more information about HDX Adaptive Display V2, see the Citrix documentation at docs.citrix.com.

Enable HDX Adaptive Display V2

About this task
This section describes how to enable HDX Adaptive Display V2 using Citrix Studio.

Steps

1. Go to Citrix Studio > Use video codec for compression policy.

2. Select the For actively changing regions option.

3. On the ThinOS client, launch an ICA desktop.

4. Open the web browser and play your preferred video.
HDX adaptive display V2 is used for video decoding on the ThinOS client. Thinwire uses JPEG (lossy) for complex or
photographic imagery and RLE (lossless) for text imagery. The rest of the screen is decomposed by Thinwire.

For more information about the Use video codec for compression policy, see the Graphics Policy Settings article at
docs.citrix.com.

Browser content redirection

Browser content redirection (BCR) enables any web browser content, including HTML 5 videos, to be redirected to the ThinOS
client and not redirected on the VDA side.

Browser content redirection proxy setting— If you use the browser content redirection proxy settings, enter a valid proxy
address and port number in the browser content redirection proxy configuration policy. Citrix Workspace app follows the server
fetch and client render mechanism to fetch URL from VDA and redirect browser content from the client.

@ NOTE: In ThinOS 9.1.4234, BCR with Chromium Embedded Framework (CEF) is enabled by default. ThinOS does not
provide the configuration to change BCR with WebKitGKT +.

From ThinOS 2306 and Citrix Workspace app 2305, the Citrix browser content redirection CEF cache file is changed from the
default . ICAClient to/tmp/citrix. CEF cache filein /tmp/citrix is cleared when you log out.
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Enable Browser Content Redirection

Prerequisites

If you are using a Chrome browser, import the BCR extension into the browser.
If you are using an Edge browser, import the BCR extension into the browser.
If you are using a |IE browser, ensure the Citrix HDXJsInjector add-on exists in the browser.

If you are using an RDS-hosted desktop, and if you are using a |IE browser, install the BCR add-on manually from Citrix virtual
apps and desktops I0S installer.

e |f you want to play a QUMU video, you must add the QUMU video URL to the Citrix policy.

About this task

This section describes how to enable Browser Content Redirection using Citrix Studio.

Steps
1. Go to Citrix Studio > Browser Content Redirection policy.

2. Select the Allowed option.
This enables the Browser Content Redirection policy.

3. In the Browser Content Redirection Access Control List (ACL) policy settings, add URLs that can use the browser
content redirection.

®| NOTE: Ensure that the URL is not listed in the Browser Content Redirection Blacklist Configuration policy.

4. On the ThinOS client, launch an ICA desktop.

B. Open either IE or Chrome and enter the URL that you have added in the Access Control List (ACL).
The browser viewport is rendered on the ThinOS client side. Browser attributes such as Address Bar and Status Bar still run
on the VDA side.

For more information about Browser Content Redirection, see the Browser Content Redirection article at docs.citrix.com.

HTMLS5 Video Redirection

HTMLS Video Redirection controls and optimizes the way Citrix Virtual Apps and Desktops servers deliver HTML5 multimedia
web content to users. This feature is available for internal web pages only. It requires the addition of JavaScript to the web
pages where the HTML5 multimedia content is available, for example, videos on an internal training site.

The following policies must be enabled on the server side:

e Windows Media redirection—By default this option is enabled.
HTMLS5 video redirection—By default this option is disabled.

For more information about the ICA Multimedia policy settings, see the Citrix documentation at docs.citrix.com.

For information about how to verify if HTMLb Video Redirection is working, see the FAQs section in this guide.

Windows Media Redirection

Windows Media Redirection enables the audio and video to be rendered on the user device instead of running on the server side.
Using the Windows Media Redirection feature, you can optimize the performance of Windows Media player on virtual Windows
desktops.

For more information about Windows Media Redirection, see the Citrix documentation at docs.citrix.com.

Enable Windows Media Redirection

Prerequisites

Ensure that the Windows Media redirection policy is set to Allowed in Citrix Studio. By default, the value is set to Allowed.
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About this task

This section describes how to enable the Windows Media Redirection feature on your thin client.

Steps
1. On the ThinOS desktop, click Connection Manager.
2. Click Global Connection Settings.
3. Select the Enable HDX/MMR check box for the ICA connection.
4. Go to System Setup > Remote Connections.
5. On the Broker Setup tab, select Citrix Virtual Apps and Desktops from the Broker type drop-down list.
6. Enter the Citrix server in the Broker Server field, and click OK.
7. Launch an ICA desktop.
8. Open Windows Media Player and play a video or an audio file.
The following types are supported:
e H.264 video
e WMV-9 video
e \WMV-8 video
e WMV-7 video
e \WMC1 video
e MP4 video
e 4K video
e MOV/AVI video
e AAC/MP3/WMA file

For information about how to check if Windows Media Redirection is working, see the FAQs section in this guide.

For more information about the ICA Multimedia policy settings, see Citrix Product documentation at docs.citrix.com.

QUMU Video Optimization Pack for Citrix

QUMU's Video Optimization Pack (VOP) for Citrix enables you to stream quality videos to endpoints managed by Citrix Virtual
Apps and Desktops servers by enabling client-side fetching. The QVOP video player runs on the client side, and the video stream
uses the client's network to go directly to QUMU's Video Control Center instead of accessing through VDI desktops.

Prerequisites

Ensure that the Windows Media redirection policy is set to Allowed in Citrix Studio. By default, the value is set to Allowed.

About this task

This section describes how to use QUMU Video Optimization Pack for Citrix on your thin client.

Steps

1. On the ThinOS desktop, click Connection Manager.

2. Click Global Connection Settings.

3. Select the Enable HDX/MMR check box for the ICA connection.
4

. Go to System Setup > Remote Connections, select Citrix Virtual Apps and Desktops from the Broker type drop-down
list.

o

On the Broker Setup tab, enter the Citrix server in the Broker Server field, and click OK.
6. Launch an ICA desktop.
7. Use Citrix Browser Content Redirection to play QUMU videos.

For information about Browser Content Redirection, see Browser Content Redirection. For more information about the ICA
Multimedia policy settings, see Citrix Product documentation at docs.citrix.com.
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Citrix Self-Service Password Reset

You can reset the password or unlock the account after you complete the security questions enrollment.
Supported Environment

e Citrix Virtual Apps and Desktops 7.11 and later versions
e Support StoreFront Server 3.7 and later versions
e Self-Service Password Reset Server 1.0 and later versions

Supported platforms—All platforms are supported.

Limitation
e Supports only StoreFront Server

Before resetting a password or unlocking an account

Before resetting your password or unlocking your account, you must register for the security questions enroliment. To register

your answers for the security questions, do the following:

1. To access the Security Questions Enrollment window, do the following step that is applicable to the mode:
a. In Classic mode, click the Manage Security Questions option from the PNAmenu.
b. In Workspace mode, click the TASKS icon on the purple ribbon and click Start.

The Security Questions Enrollment window is displayed.

2. Enter the appropriate answers to the question set.
3. Click OK to register the security questions.

Use the Account Self-Service
After the security questions enrollment is complete, and when ThinOS is connected to a StoreFront server with Self-Service
Password Reset enabled, the Account Self-Service icon is displayed in the sign-on window.

@ NOTE: If you enter the wrong password more than four times in the Sign-on window, the client automatically enters the
unlock account process.

1. Click the Account Self-Service icon to unlock your account or reset your password.

®| NOTE: You must register the security questions for users before using the unlock account or reset password feature.

2. Click Unlock account or Reset password based on your choice, and then click OK.

Unlock an account

After you register the security questions, do the following to unlock your account:

1. Choose a task (Unlock account) in the Account Self-Service window.
2. Enter the username.

The Unlock Account dialog box is displayed.
3. Enter the registered answers to the security questions.
If the provided answers match the registered answers, then the Unlock Account dialog box is displayed.

4, Click OK to successfully unlock your account.

@ NOTE:

e |f the provided answers are incorrect, an error message is displayed.

e |f you provide the wrong answers more than three times, you cannot unlock the account or reset the password, and
error messages are displayed.
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Reset a password

After you register the security questions, do the following to reset your password:

1. Choose a task (Reset password) in the Account Self-Service window.
2. Enter the username.

The Reset Password dialog box is displayed.
3. Enter the registered answers to the security questions.

If the provided answers match the registered answers, then the Reset Password dialog box is displayed.
4. Enter and confirm the new password.
B. Click OK to successfully change the password.

If you provide the wrong answers, you cannot reset the password, and an error message is displayed.

Citrix SuperCodec

Citrix SuperCodec is a H.264 decoder integrated on the ThinOS client side. The server encodes the session image into the
H.264 stream and sends it to the client side. The client decodes the H.264 stream by SuperCodec and display the image on the
screen. This feature improves the user experience, especially for HDX 3D Pro desktops.

Citrix SuperCodec is supported in Citrix Virtual Apps and Desktops (XenApp and XenDesktop) version 7.5 or later versions.

In Citrix Virtual Apps and Desktops version 7.9 and later, the default setting for Use video codec for compression is

Use when preferred. For best performance on ThinOS device, it is recommended that you set the Use video codec for
compression policy to For the entire screen. You can set the policy to Do not use video codec. This policy setting allows
ThinOS to use ThinWire Plus that saves bandwidth and reduces the CPU overhead. You can also set the policy to For actively
changing regions. This policy setting allows ThinOS to use Selective H.264.

e ThinWire Plus—Equivalent to the Do not use video codec option

o Fullscreen H.264—Equivalent to the For the entire screen option

e Selective H.264—Equivalent to the For actively changing regions

Anonymous logon

The Anonymous logon feature enables the users to log into the StoreFront server configured with unauthenticated store
without Active Directory (AD) user credentials. It allows unauthenticated users to access the applications instead of AD
accounts.

®| NOTE: Anonymous logon is not supported with legacy mode of StoreFront server.

®| NOTE: After ThinOS 2208, Lock Terminal is supported for Anonymous logon.

Enable UDP audio in a Citrix session

Citrix recommends that you use audio over User Datagram Protocol (UDP) in low-bandwidth network connections for better
audio quality. ThinOS does not support UDP audio over Citrix ADC (formerly NetScaler) due to Linux Citrix Workspace app
limitation.

Steps
1. Start the Admin Policy Tool on your ThinOS 9.0-based device or open the ThinOS 9.x Policy settings in Wyse
Management Suite.

If you are using the Admin Policy Tool on ThinOS, you must first select the audio quality as Medium and then enable UPD
audio. UPD audio is automatically disabled when you select the audio quality as High on Admin Policy Tool. However, the
UPD audio is not automatically disabled when you are configuring the setting using Wyse Management Suite. UPD audio may
not work if you set the audio quality as High using Wyse Management Suite.

2. On the Advanced tab, expand Session Settings, and click Citrix Session Settings.
3. In the Basic Settings section, click the Enable UPD Audio toggle key to ON state.
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NOTE: From Citrix Workspace app 2112 and ThinOS 9.1.5067, Adaptive audio works while using User Datagram Protocol
(UDP) audio delivery. Adaptive audio is enabled by default. This feature requires VDA version 2112 or later versions. For
more information, see the Citrix Virtual Apps and Desktops product documentation at www.docs.citrix.com.

4. From the Audio Quality drop-down list, select Medium.

If you are using the Admin Policy Tool on ThinOS, you must first select the audio quality as Medium and then enable UPD
audio. UPD audio is automatically disabled when you select the audio quality as High on Admin Policy Tool. However, the
UPD audio is not automatically disabled when you are configuring the setting using Wyse Management Suite. UPD audio may
not work if you set the audio quality as High using Wyse Management Suite.

Keyboard layout synchronization in VDA

In Citrix Workspace app, the Keyboard Dynamic synchronization mode functions differently on a Linux client from a Windows
client. In general, on a Linux client, the keyboard output follows the client keyboard layout, which is different from the Windows
VDA layout. If a Linux client keyboard is synchronized to a Windows VDA, users may observe unpredictable keyboard output.
Also, in dynamic synchronization mode, Citrix Workspace app for Linux does not support VDA users to switch the keyboard
layout inside a VDA session.

In the server default mode, both Linux and Windows use the session (VDA) side keyboard layout with predictable output. You
can configure the keyboard layout mode using either Wyse Management Suite or Admin Policy Tool. The keyboard layout that
you select on the thin client is not automatically synchronized in the VDA session. ThinOS supports the server default mode that
enables VDA users to select or switch the keyboard layout inside the VDA session using the Windows Input Method Editor (IME)
language bar. For other modes such as Specific keyboard, Client Setting, or Dynamic Sync, there can be unpredictable mismatch
in the keyboard output if you switch the keyboard layout in VDA. This is because the Citrix Workspace app Linux keyboard sync
mode does not support switching the layout in VDA.

As a VDA administrator, you must configure the VDA desktop with the required keyboard language layout options. The IME
language bar must be enabled on the Windows lock screen. The VDA user can select the appropriate keyboard language layout
on the Windows lock screen.

In scenarios such as opening a new application in a VDA session, locking, or unlocking the VDA session, the keyboard layout falls
back to the VDA default layout. For example, EN_US. This is a known issue for a Linux client in the server default mode.

You can customize VDA registry settings for a consistent keyboard layout in the VDA session.

e [or a desktop operating system VDA, the feature is enabled by default.
e For a server operating system VDA, you can enable the feature using the system registry.
1. In the system registry of VDA, go to HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard
Layout.
2. Create a DWORD entry IgnoreRemoteKeyboardLayout=1.

By default, the ITgnoreRemoteKeyboardLayout entry is unavailable. The default keyboard is set to ENG, irrespective
of the Control Panel setting.

For example, open an application, lock, or unlock the session, the keyboard is set to ENG. To resolve this issue, ensure
that you set TgnoreRemoteKeyboardLayout=1.

For information about the Keyboard Layout Modes and Keyboard Layout rules in Citrix Workspace app, see the Citrix Virtual
Apps and Desktops keyboard and IME configurations article at www.citrix.com/blogs.

Table 29. Citrix Workspace app keyboard layout configuration for VDA users on ThinOS

VDA user scenario Wyse Management | VDA settings Summary

Suite settings
The client keyboard is Configure the Set the VDA Keyboard output follows the client Linux keyboard
synchronized to VDA, required keyboard policy for Dynamic layout and not the Windows layout. As a result,
and the keyboard layout |layout for local client | synchronization. there can be an unpredictable mismatch in the
is not switched in users and remote VDA keyboard output. Citrix Workspace app Linux
the VDA desktop or users. keyboard sync mode does not support switching
application. the layout in VDA.

The client keyboard is
synchronized to VDA,
and the keyboard layout
is switched in the VDA
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Table 29. Citrix Workspace app keyboard layout configuration for VDA users on ThinOS (continued)

VDA user scenario

Wyse Management
Suite settings

VDA settings

Summary

desktop using the IME
language bar.

The client keyboard is
synchronized to VDA,
and the keyboard layout
is switched in VDA
published applications
using the IME language
bar.

The client keyboard is
not synchronized to
VDA, and the keyboard
layout is not switched
in the VDA desktop or
application.

The client keyboard is
not synchronized to
VDA, and the keyboard
layout is not switched in
the VDA desktop using
the IME language bar.

The client keyboard

is not synchronized

to VDA, and the
keyboard layout is

not switched in VDA
published applications
using the IME language
bar.

Configure the
required keyboard
layout for using the
client locally. There
is no impact to the
keyboard usage on
remote VDA.

No specific settings
are required.

For recommended
settings, see the VDA
settings for server
default mode section.

Keyboard layout follows the VDA Windows layout
with predictable output.

When opening a new application in a VDA session,
locking the VDA session, or unlocking the VDA
session, the keyboard layout falls back to the VDA
default layout. For example, EN_US.

The following are the recommended settings for
VDA administrators:

Enable multiple layouts in VDA IME.
Enable IME on the Windows lock screen.

o Set the default keyboard layout to any non-
English keyboard layout.

e In the system registry of VDA, go to
HKEY LOCAL MACHINE\SYSTEM\Current
ControlSet\Control\Keyboard
Layout and create the following DWORD
entry:

IgnoreRemoteKeyboardLayout=1.

For more information, see the Citrix article
CTX223316 at www.support.citrix.com.

Table 30. Language keyboard layout settings

ThinOS Windows layout |Wyse Management Suite Citrix Recommended settings
keyboard settings Workspace app
layout Linux dynamic
synchronization
Polish Keyboard layout Supported Enabled e On the client side, select the
partially matches keyboard layout that fully matches
with the Windows with the Windows layout for local
layout. usage.
Polish Keyboard layout Supported Enabled * Onthe VDA side, ;elect the best
layout from the Windows IME
(Legacy) fully matches S
. ) language bar after the connection is
with the Windows i
established.
layout. o
e For VDA administrators, see the
French Keyboard layout Supported Enabled Citrix Workspace app keyboard
(France) partially matches layout configuration for VDA users
with the Windows on ThinOS table in this document.
layout.
French Keyboard layout Supported Enabled
(Microsoft) | fully matches
with the Windows
layout.
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Table 30. Language keyboard layout settings (continued)

ThinOS Windows layout |Wyse Management Suite Citrix Recommended settings
keyboard settings Workspace app
layout Linux dynamic
synchronization

Belgian Keyboard layout Supported Enabled

does not match

with the Windows

layout.
Belgian Keyboard layout Supported Enabled
(Comma) fully matches

with the Windows

layout.
Spanish Keyboard layout Supported Enabled

does not match

with the Windows

layout.

VDA settings for Server Default mode

When set to server default mode, the keyboard layout falls back to the VDA default layout. For example, EN_US. This issue
can be related to Citrix Workspace app or Windows server operating system 2016 and 2019. All workarounds may require you
to modify registry keys on the server side. For more information about workarounds, see the Citrix articles CTX269153 and

CTX223316 at support.citrix.com. If you do not want to modify registry keys, contact the Citrix support team or the Microsoft

support team.

Table 31. Citrix Workspace app Linux keyboard layout settings—Client and VDA

[WFClient]

keyboardlayout=French

on the server side:

e Set the Enable Unicode
keyboard layout mapping to
Allowed.

XenApp server version before 2006

—There are no policies available to

enable specific keyboard sync mode.

You must set the registry key in the

Windows VDA desktop Keyboard sync

configuration. The setting is enabled

by default on Windows Server 2012

and Windows 10 operating system.

The setting is disabled by default on

Windows Server 2016 and Windows

Server 2019.

To enable Unicode Keyboard Layout
Mapping for Windows VDA, add the
following registry keys:

Mode Client-side settings Server or VDA-side settings Additional information
Server ~/.ICAClient/wfclient.ini |Setting is configured on the Set the mode on either the client
default . StoreFront server. For example, side or the server side. This
[WEFClient] . -
) . ) mode takes the highest priority.
C:\inetpub\wwwroot\Citrix\
keyboardlayout=(Server
Default) [store name]
\App Dataldefault.ica
[WEClient]
keyboardlayout=(Server
Default)
Specific ~/.ICAClient/wfclient.ini | XenApp server version 2006 and Set the mode on either the client
keyboard higher—Enable the following policies | side or the server side. You must

set the value in /opt/Citrix/

ICAClient/module.ini
[KeyboardLayout].
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Table 31. Citrix Workspace app Linux keyboard layout settings—Client and VDA (continued)

Mode

Client-side settings

Server or VDA-side settings

Additional information

° HKEYiLOCALiMACHINE\SOFTWA
RE\Citrix\CtxKlMap\Enable
KlMap value= DWORD 1

e HKEY LOCAL MACHINE\SOFTWA
RE\Citrix\CtxKlMap\Disabl
eWindowHookvalue=DWORD 1

Dynamic
sync

/opt/Citrix/ICAClient/
config/module.ini

[ICA 3.0]

KeyboardSync=0n
~/.ICAClient/wfclient.ini
[WFClient]

keyboardlayout= (User
Profile)

XenApp server version 2006 and
higher—Enable the following policies
on the server end:

e Set the Client Keyboard
Layout synchronization and IME
improvement policy to Support
dynamic client keyboard
layout sychronization and IME
improvement.

e Set the Enable Unicode
keyboard layout mapping to
Allowed.

XenApp server version before 2006

—There are no policies available

to enable dynamic sync mode. You

must set the registry key in the

Windows VDA desktop Keyboard sync

configuration. The setting is enabled

by default on Windows Server 2012

and Windows 10 operating system.

The setting is disabled by default on

Windows Server 2016 and Windows

Server 2019.

To enable the setting, add the
following registry key:
HKLM\Software\Citrix\ICA\Ic
aIme\DisableKeyboardSync
value=DWORD 0.

To enable Unicode Keyboard Layout
Mapping for Windows VDA, add the
following registry keys:

[ HKEY_LOCAL_MACHINE\SOFTWA
RE\Citrix\CtxK1lMap\Enable
K1lMap value= DWORD 1

e HKEY LOCAL MACHINE\SOFTWA
RE\Citrix\CtxKlMap\Disabl
eWindowHook value=DWORD 1

Set the mode on both the client
side and the server side.

Sync once

/opt/Citrix/ICAClient/
config/module.ini

[ICA 3.0]
KeyboardSync=0ff
~/.ICAClient/wfclient.ini
[WEFClient]

keyboardlayout= (User
Profile)

Not available

Not available

102

Configuring connection brokers




Table 32. ThinOS dynamic synchronization support

Keyboard

Synchronization

Arabic (Algeria)

Not supported

Arabic (Bahrain)

Not supported

Arabic (Egypt)

Not supported

Arabic (Iraq)

Not supported

Arabic (Jordan)

Not supported

Arabic (Kuwait)

Not supported

Arabic (Lebanon)

Not supported

Arabic (Libya)

Not supported

Arabic (Morocco)

Not supported

Arabic (Oman)

Not supported

Arabic (Qatar)

Not supported

Arabic (Saudi Arabia)

Not supported

Arabic (Syria)

Not supported

Arabic (Tunisia)

Not supported

Arabic (U.A.E)

Not supported

Arabic (Yemen)

Not supported

Canadian Multilingual

Supported.

Chinese (Simplified)

Supported. When you switch to the language Keyboard layout in VDA, the
keyboard layout is synchronized to the English layout.

Chinese (Traditional)

Supported. When you switch to the language Keyboard layout in VDA, the
keyboard layout is synchronized to the English layout.

Croatian Supported
Czech (Qwerty) Supported
Czech Supported
Danish Supported
Dutch Supported
English (3270 Australian) Supported
English (Australian) Supported
English (New Zealand) Supported
English (United Kingdom) Supported
English (United States) Supported
Estonian (Estonia) Supported
Finnish Supported
French (Canadian Legacy) Supported

French (Canadian)

Not supported

French (France)

Supported

French (France Microsoft)

Not supported

French (Switzerland)

Supported
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Table 32. ThinOS dynamic synchronization support (continued)

Keyboard Synchronization
German (Switzerland) Supported
German Supported
Greek Supported
Hungarian Supported
Icelandic Supported

Italian (Switzerland)

Not supported

[talian

Supported

Japanese (OADG109A)

Supported

Japanese (KWD)

Supported. When you switch to the language Keyboard layout in VDA, the
keyboard layout is synchronized to the English layout.

Korean (MS-IME2002)

Supported. When you switch to the language Keyboard layout in VDA, the
keyboard layout is synchronized to the English layout.

Korean

Supported. When you switch to the language Keyboard layout in VDA, the
keyboard layout is synchronized to the English layout.

Latvian (Latvia) Supported
Lithuanian (IBM) Supported
Lithuanian (Standard) Supported
Norwegian Supported
Polish Supported

Polish (Legacy)

Not supported

Portuguese (Brazil) Supported

Portuguese Supported

Romanian Not supported

Russian Supported. When you switch to the language Keyboard layout in VDA, the

keyboard layout is synchronized to the English layout.

Serbian Supported

Slovenian Supported

Spanish Supported

Swedish Supported

Turkish Supported

U.S.International

Not supported

Enable keyboard layout mode

Steps

1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.

2. On the Advanced tab, expand Session Settings, and click Citrix Session Settings.

3. In the Basic Settings section, select one of the following options from the Keyboard Layout Mode drop-down list.

o Server Default—ThinOS allows VDA users to use the VDA-side default keyboard when logging in or reconnecting to
VDA. The VDA-side default keyboard is the default setting in ThinOS. Any keyboard layout change on the client side is

not synchronized to the VDA session.
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e Specific Keyboard—ThinOS allows VDA users to use a specific keyboard when logging in or reconnecting to VDA. Any
keyboard layout change on the client side is not synchronized to the VDA session. Ensure that you select a specific
keyboard on the ThinOS client before configuring the Admin policy tool or the Wyse Management Suite policy. If not
selected, you must reboot the thin client to synchronize the specific keyboard into VDA.

e Client Setting—ThinOS allows VDA users to synchronize only the VDA-side keyboard with the client-side default
keyboard when logging in or reconnecting to VDA. Any keyboard layout change on the client-side is not synchronized to
the VDA session.

e Dynamic Sync—ThinOS allows VDA users to synchronize the VDA-side keyboard with the client-side default keyboard
dynamically in the VDA session. When the VDA user changes the client keyboard, the VDA keyboard is synchronized
automatically in the session. You must configure both the client and VDA-side settings to enable this mode.

4. Click Save & Publish.
From ThinOS 2402 and Citrix Workspace App 2311, the Citrix VDI Configuration Editor is not required to configure the Citrix

keyboard Server default mode and Dynamic Sync mode. All the Citrix keyboard layout modes can be configured through the
Keyboard Layout Mode setting in Session Settings > Citrix Session Settings.

Keyboard layout server default mode enhancement

Keyboard Layout Server Default Mode enhancement—From Citrix Workspace App 2109 and ThinOS 9.1.5067 onwards, only
the Server Default mode uses the Scancode. Other Keyboard layout modes such as Specific Keyboard, Client Setting, and
Dynamic Sync use the default Unicode. There are no changes to the other keyboard layout modes in Citrix Workspace App 2109.

To configure, do the following:

1. Set the Keyboard Layout Mode to Server Default using Admin Policy Tool or Wyse Management Suite.

2. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced tab > VDI Configuration Editor >
Citrix Configuration Editor.

In the Citrix INI settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter WFClient.

In the Key field, enter KeyboardEventMode.

In the Value field, enter Scancode.

Sign out or restart the device for settings to take effect.

@ NOTE: If you want to change the Server Default mode to other keyboard layout modes, you must remove the
KeyboardEventMode with Scancode setting from Citrix Configuration Editor.

© 0N oo s W

Keyboard layout Dynamic Sync mode enhancement

When setting the keyboard layout to Dynamic Sync, the switching keyboard progress bar is not displayed in desktop sessions
after switching the keyboard language on the thin client. Hence, the keyboard layout in session is not automatically synced with
the client. The issue also occurs in Linux Citrix Workspace app binary. To resolve the issue, do the following:

Steps
1. Set the Keyboard Layout Mode to Dynamic Sync using Admin Policy Tool or Wyse Management Suite.

On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.
In the Section field, enter WFClient.

In the Key field, enter KeyboardSyncMode.

In the Value field, enter Dynamic.

© 0 No o bW

Sign out or restart the device for the settings to take effect
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Cursor pattern in ICA session
In ThinOS 9.1.2101, you can change the cursor pattern in the ICA session.

Steps
1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. On the Advanced tab, expand Session Settings, and click Citrix Session Settings.
3. Enter one of the following values in the Cursor Pattern field to change the cursor pattern:
e ffff, £fff—FEnter this value to set the cursor color as black. This value is set by default.
e 0,0—Enter this value to set the cursor color as white.
e aaaa,5555—Enter this value to set the cursor color in a dotted pattern.

4. Click Save & Publish.
For the setting changes to take effect, you must either sign off from the Broker agent or restart the client.

Citrix multiple virtual channels

From ThinOS 9.1.3112 and later versions with Citrix Workspace app 2104 and later, ThinOS Citrix UC Virtual Channel Settings
and Other Citrix Virtual Channels Settings are deprecated. The configuration changes that you make to the Admin Policy Tool
or the Wyse Management Suite policy settings does not affect the Citrix multiple channel settings since multiple virtual
channels are always enabled on the thin client. However, ensure that you uninstall the Unified Communications (UC) packages
that are not required, to prevent the consumption of server and client resources. Dell Technologies recommends that you install
the Citrix Workspace app package first, and then install the Citrix Unified Communications package.

Citrix UC Virtual Channel Settings and Other Virtual Channel Settings in the Admin Policy Tool or Wyse Management Suite
server are only applicable for ThinOS 9.1.2101 or earlier versions. From ThinOS 9.1.3112 to 2208 (9.3.2102), Admin Policy
Tool does not sync the Citrix Unified Communication Virtual Settings and Other Virtual Channel Settings from Wyse
Management Suite policy settings.

The following combinations of UC optimizations and their virtual channel settings are tested on ThinOS 9.1.2101 and 131:

Table 33. Unified Communication optimizations and their default virtual channel settings

Virtual Settings | Default Combinat | Combinat | Combinat | Combinat | Combinat | Combinat | Combinat
Channel status ion 1 ion 2 ion 3 ion 4 ion 5 ion 6 ion7
categorie

s

UC Virtual | Microsoft | Enabled Enabled Disabled Disabled Enabled Disabled Enabled Disabled
Channel Teams
Settings Optimizati
on

RTME for | Enabled Enabled Disabled Disabled Disabled Disabled Disabled Enabled
Skype for
Business

Zoom Disabled Disabled Disabled Enabled Enabled Disabled Disabled Disabled
Meetings
Optimizati
on

JVDI for Disabled Disabled Disabled Disabled Disabled Enabled Disabled Disabled
Cisco
Jabber

Cisco Disabled Disabled Enabled Disabled Disabled Disabled Disabled Disabled
Webex
Meetings
for VDI
Plugin

Cisco Disabled Disabled Enabled Disabled Disabled Disabled Disabled Disabled
Webex
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Table 33. Unified Communication optimizations and their default virtual channel settings (continued)

Virtual Settings | Default Combinat | Combinat | Combinat | Combinat | Combinat [ Combinat | Combinat
Channel status ion 1 ion 2 ion 3 ion 4 ion 5 ion 6 ion 7
categorie
s

Teams for

VDI Plugin
Other USB Enabled Enabled Enabled Disabled Disabled Enabled Enabled Enabled
Citrix redirection
Virtual - :
Channels Imprivata | Enabled Enabled Enabled Enabled Disabled Enabled Enabled Enabled
Settings

In ThinOS 9.1.2101 and earlier versions, Zoom Meetings Optimization plug-in uses four virtual channels. To use Zoom
Optimizations along with Microsoft Teams or any other Cisco optimizations, you must disable other virtual channels. For
example, if you are not using Imprivata SSO, you can choose to disable the Imprivata virtual channel. Similarly, if you do not use
Skype for Business, you can choose to disable the RTME for Skype for Business virtual channel.

NOTE: The UC Virtual Channel settings do not apply to ThinOS versions later than 9.1.2101 but earlier than or equal to 2208

(9.3.2102). These settings are supported again from ThinOS 2211 and later. From ThinOS 2211, the default values of all UC
virtual channel settings have been changed to Enabled.

@ NOTE: When the UC virtual channels are disabled, the Unified Communication software on ThinOS uses the fallback mode,
which uses the HDX webcam and HDX audio. Using the fallback mode consumes more remote desktop resources such as
CPU, GPU, RAM, and Network.

@ NOTE: Enabling or disabling the UC plug-in settings in VDI Configuration Editor > Citrix Configuration Editor is
deprecated from ThinOS 2211.

For ThinOS 9.1.2101 or earlier versions, see ThinOS 9.1 Administrator's Guide at www.dell.com/support on the number of allowed
virtual channels and tested combinations of Unified Communication optimizations.

Configure the Citrix virtual channels settings

About this task
This task is only applicable for ThinOS 9.1.2101 and earlier versions.

Steps

1. On the ThinOS client, open Admin Policy Tool, or go to the ThinOS 9.x policy settings on Wyse Management Suite.

2. On the Advanced tab, expand Session Settings, and click Citrix Session Settings.

3. In the UC Virtual Settings section, enable one or more Unified Communications (UC) virtual channels as per your
preference. The available options are:

Microsoft Teams Optimization

RTME for Skype for Business

Zoom Meetings Optimization

JVDI for Cisco Jabber

Cisco Webex Meetings for VDI

Cisco Webex Teams for VDI

4. In the Other Citrix Virtual Channel settings, enable one or more virtual channels as per your preference. The available
options are:
e USB redirection
e Imprivata

5. Click Save & Publish.
For the list of virtual channel combinations that are tested on ThinOS, see Citrix multiple virtual channels.

From ThinOS 2211, UC Virtual Channel settings in Citrix Session Settings in Admin Policy Tool or Wyse Management Suite
policy is enabled again.

To configure UC Virtual Channel settings in Citrix Session Settings, do the following:
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d.

On the ThinOS client, open Admin Policy Tool, or go to the ThinOS 9.x policy settings in Wyse Management Suite.
In the Advanced tab, expand Session Settings, and click Citrix Session Settings.

In the UC Virtual Channel Settings section, enable or disable one or more Unified Communications (UC) virtual
channels as per your preference. The available options are:

Microsoft Teams Optimization

HDX RealTime Media Engine for Microsoft Skype for Business
Zoom Meetings Optimization

Cisco Jabber Softphone for VDI (JVDI)

Cisco Webex Meetings for VDI

Cisco Webex VDI (formerly Cisco Webex Teams)

Sign out or restart the device for the settings to take effect.

The following UC virtual channels labels are renamed in ThinOS 2211 Admin Policy Tool and Wyse Management Suite version

4.0

®

using the Configuration Ul package vxxxxx:

RTME for Skype for Business is renamed to HDX RealTime Media Engine for Microsoft Skype for Business.
JVDI for Cisco Jabber is renamed to Cisco Jabber Softphone for VDI (JVDI).

Cisco Webex Meetings for VDI is renamed to Cisco Webex Meetings for VDI.

Cisco Webex Teams for VDI is renamed to Cisco Webex VDI (formerly Cisco Webex Teams).

NOTE: The UC Virtual Channel settings do not apply to ThinOS versions later than 9.1.2101 but earlier than or equal to
2208 (9.3.2102). These settings are supported again from ThinOS 2211 and later. From ThinOS 2211, the default values
of all UC virtual channel settings have been changed to Enabled.

NOTE: When the UC virtual channels are disabled, the Unified Communication software on ThinOS uses the fallback
mode, which uses the HDX webcam and HDX audio. Using the fallback mode consumes more remote desktop resources
such as CPU, GPU, RAM, and Network.

NOTE: Enabling or disabling the UC plug-in settings in VDI Configuration Editor > Citrix Configuration Editor is
deprecated from ThinOS 2211.

Configure the Citrix session properties

About

This se

Steps
1. On

this task

ction describes how to configure the Citrix HDX connections on your thin client.

the taskbar, click Connection Manager.

The Connection Manager dialog box is displayed.

2. Select a Citrix connection from the list, and click Properties.

3. Click the Connection tab and do the following:

You can view Server or Published Application, Connection Description, Browser Servers, Host Name or Application
Name, and Encryption Level but cannot edit these options.

a.

Display Resolution—Select the display resolution for this connection.

If you select the Published Application option, the connection display enables you to select the Seamless Display
Resolution option.

Window mode and Full screen mode—Select the initial view of the application and desktop in a windowed screen or
full screen.

Autoconnect on start-up—\When this option is selected, the thin client automatically connects the session on start-up.
Reconnect after disconnect—\When this option is selected, the thin client automatically reconnects to a session after
a non operator-initiated disconnect. The wait interval is the value that you set in the Delay before reconnecting box
(enter the number of s 1-3600). The default is 20 s if you are a stand-alone user.

4. Click the logon tab to view Logging on area.

You can view Login Username, Password, Domain name, and Logon Mode.
B. Click the Options tab, and do the following:
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a. Autoconnect to local devices—Select any options—Printers, Serials, Smart Cards, Sound, and Disks—to have the thin
client automatically connect to the devices.

®| NOTE: USB devices that are connected are managed in Global Connection Settings.

b. Audio Quality—From the drop-down list, select your preferred audio quality.

c. Enable session reliability—\When enabled, session reliability allows you to momentarily lose connection to the server
without having to re-authenticate upon regaining a connection. Instead of the connection time-out, the session is kept
alive on the server and is made available to the client upon regaining connectivity. Session reliability is most relevant for
wireless devices. From version 21.12.0.18.2, the screen changes when session reliability begins. The session window is
disabled and a countdown timer with the time until the next reconnection attempt is displayed.

6. Click OK to save your settings.

Using multiple displays in a Citrix session

ThinOS supports ICA desktop multiple displays in Citrix Virtual Apps and Desktops/Citrix Virtual Apps 7.6 and later versions.

Prerequisites

Increase the value of MaxVideoMemoryBytes REG_DWORD to support one or more 4K resolution-displays. For more
information, see the Citrix documentation at support.citrix.com.

Increase the display memory limit to support more color depth and higher resolution. For more information, see the Citrix

documentation at citrix.com.

Steps

1.
2.
3.

Connect multiple displays to ThinOS device.

Go to System Setup > Display, disable Mirror Mode, and configure the display layout.

Launch an ICA desktop. By default, the ICA desktop is launched in the full-screen mode.

Table 34. Display details

Platforms

Best Display resolution

Maximum number of system displays

Standard or RDS desktop—
Windows 10, 2012 R2, and 2016

HDX 3D Pro desktop—
Windows 10 with NVIDIA
TESLA P40 GPU

Wyse 5070 Extended Thin 1920 x 1080 6 4
Client

2560 x 1440 6 4

3840 x 2160 4 4

5120 x 1440 2 2
Wyse 5070 Thin Client— 1920 x 1080 3 3
Pentium processor

2560 x 1440 3 3

3840 x 2160 3 3

5120 x 1440 2 2
Wyse 5070 Thin Client— ] 1920 x 1080 2 2
Celeron processor

2560 x 1440 2 2

3840 x 2160 2 2

5120 x 1440 2 2

4. Move the display blocks as per your requirement.
@ NOTE: For more information about the Citrix official multiple displays support, see the Citrix documentation at

support.citrix.com.
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Limitation—If you set all monitors with either horizontal or vertical layout, the maximum supported resolution is 4x4 K. If
you connect five or six monitors with 4x4 K + 1920x1080 or 4x4 K + 2x1920x1080 resolution combinations, you cannot launch
ICA desktop by horizontal or vertical layout. Dell Technologies recommends using grid layout such as 2x3 or 3x2 or 2x2+1.

USB Printer Redirection

Prerequisites

Go to Citrix Studio, and enable the Client USB device redirection policy.

About this task

This section describes how to configure USB Printer Redirection in a Citrix session.

Steps

1. On the ThinOS desktop, open the Connection Manager window, and click Global Connection Settings.
The Global Connection Settings dialog box is displayed.

Clear the Exclude printer devices check box, and click OK.

Log off from Citrix Broker agent, and then log in again.

Connect a USB printer to the thin client.

Log in to a Citrix session.

SIS NN

Go to Control Panel > Devices and Printer, and verify if the printer driver is automatically installed.
After the printer drive installation is complete, the redirected printer is listed in the Printers section.

USB device redirection using Citrix Desktop Viewer

From ThinOS 2208 and Citrix Workspace App 2207, Devices section is able to show in Citrix Desktop Viewer.

Redirect USB devices from the Devices section

To redirect the USB devices from the Devices section to session, do the following:

Steps

1. In a desktop session, navigate to the Desktop Viewer under Devices.
The USB devices are displayed.

2. To redirect a device to session, select the device from the menu item.

NOTE: To disconnect a device from the session, clear the required menu item or check boxes next to the devices when
the devices are mapping in session.

Redirect the USB devices from the Preferences section

To redirect the USB devices from the Preferences section to session, do the following:

Steps

1. Navigate to the Preferences > Devices section.
The USB devices are displayed.
2. Select the Redirect check boxes next to the devices.
3. Click OK.
NOTE: To disconnect a device from the session, clear the required menu item or check boxes next to the devices when
the devices are mapping in session.
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Configure the Citrix UPD printer

Use of Citrix Universal Print Driver (Citrix UPD) ensures that all printers that are connected to the thin client can also be used
from a virtual desktop or application session without integrating a new printer driver in the data center. Citrix UPD is the base of
Citrix Universal Printer. It is an autocreated printer object that uses the Citrix UPD and is not tied to any specific printer defined
on the client.

About this task

This section describes how to configure the Citrix UPD usage on your thin client.

Steps

1

Connect a printer to the ThinOS client.

2. On the ThinOS desktop menu, do the following:
a. Open the Connection Manager window.
b. Click Global Connection Settings.
c. Go to the Session tab and select the Exclude printer devices check box.
d. Click OK.
3. From the desktop menu, click System Setup > Printer Setup.
The Printer Setup dialog box is displayed.
4. Enter the name of the printer in the Printer Name box.
B. Enter any string of the Printer identification in the Printer Identification box.
6. Select the type of the printer class from the drop-down list, select the check box to enable the printer device, and click OK.
®| NOTE: In ThinOS, only PS class is supported.
7. Start a Citrix Virtual Apps and Desktops application connection.
8. Open the Devices and Printers in the desktop or application. The printer is mapped as the UPD printer by default.
Next steps

To enable the printer server policies for Citrix UPD printer, see the Citrix documentation at docs.citrix.com.

Configure the device-specific printer driver

Based on the Citrix Host Printer Policy settings, ThinOS supports device-specific printer drivers. This method allows Citrix hosts
to automatically create client redirected printer queues based on the peripheral management printers settings of the ThinOS
client. The host print manager uses the printer name and the printer ID to automatically create the printer queues.

About this task

This section describes how to configure the device-specific printer driver usage on your ThinOS client.

Steps

1

2.

Connect a printer to the ThinOS client.

From the desktop menu, click System Setup > Printer.
The Printer Setup dialog box is displayed.

On the ThinOS desktop menu, do the following:

a. Open the Connection Manager window.

b. Click Global Connection Settings.

c. Go to the Session tab and select the Exclude printer devices check box.
d. Click OK.

Enter the name of the printer in the Printer Name box.
Enter the specific printer driver identification in the Printer Identification box.
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NOTE: The specific printer driver identification is installed on the remote Citrix desktop and you must note the specific
printer driver identification.

®

6. Select the check box to enable the printer device, and click OK.

®| NOTE: In ThinOS, only printer driver type 3 is supported.

7. Start a Citrix virtual connection.
8. Open the Devices and Printers in the desktop or application. The printer is mapped to the session.

Invert cursor color

From Citrix Workspace app 2112 and ThinOS 9.1.5067, the cursor color can be inverted based on the background color of a
text. As a result, you can easily locate the position of the cursor in between texts. By default, this feature is disabled. To enable
cursor color inverting feature, do the following:

Steps

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter Thinwire3.0.

In the Key field, enter InvertCursorEnabled.

In the Value field, enter True.

® N o o s oD

Sign out or restart the device for the settings to take effect.

@ NOTE: If you have enabled the cursor color inverting feature, the Cursor Pattern setting from Advanced > Session
Settings > Citrix Session Settings in the Admin Policy Tool or Wyse Management Suite policy settings is deprecated.

Echo cancellation for Microsoft Teams

From Citrix Workspace app 2112 and ThinOS 9.1.5067, Microsoft Teams optimization supports echo cancellation. The echo
cancellation option for Microsoft Teams is disabled by default.

Enable echo cancellation for Microsoft Teams

Steps

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix JSON Settings, click Add Row.

From the File drop-down list, select hdx_rtc_engine/config.json.

From the Operation drop-down list, select Add or Update.

In the Key field, enter EnableAEC.

In the Value field, enter 1.

No o b oun

Sign out or restart the device for the settings to take effect.

Limitation: If you set EnableAEC as 1, and if there is a Microsoft Teams call or meeting happening between a Wyse 5470
thin client and a thin client that is or is not Wyse 5470 thin client, you may encounter audio issues when you enable the
camera.

If you encounter audio issues during Microsoft Teams calls or meetings, you can change the default settings to troubleshoot
the audio issues (like robotic voice, increased system performance causing audio issues, and so on) by doing the following:
a. Inthe Citrix JSON Settings, click Add Rowto add the setting

b. From the File drop-down list, select hdx_rtc_engine/config.json.
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From the Operation drop-down list, select Add or Update.

In the Key field, enter EnableAGC.

In the Value field, enter 0.

In the Citrix JSON Settings, click Add Row to add the setting.
From the File drop-down list, select hdx_rtc_engine/config.json.
From the Operation drop-down list, select Add or Update.

In the Key field, enter EnableNS.

n the Value field, enter 0.

k. Sign out or restart the device for the settings to take effect.
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Multiwindow chat and meetings for Microsoft Teams

From ThinOS 2208 and Citrix Workspace App 2207, Microsoft Teams optimization supports the multiwindow chat and meetings
feature. Using this feature, you can view chat and meetings in separate windows.

NOTE: For this feature to work, the Citrix Workspace app package version must be 22.7.0.20.2 or later, Citrix VDA version
must be 2112 or later, and Microsoft Teams version must be 1.5.00.11865 or later. You must sign out from Microsoft Teams
and restart the device for the feature to be enabled.

UDP audio through Citrix Gateway

From Citrix Workspace app 2112 and ThinOS 9.1.5067, Citrix Workspace app supports Datagram Transport Layer Security
(DTLS) protocol for UDP audio. As a result, you can access the UDP audio through Citrix Gateway. By default, this feature is
disabled.

Enable UDP audio through Citrix Gateway feature

Prerequisites

Ensure that UDP audio is enabled in ThinOS. To configure the settings, do the following:

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > Session Settings > Citrix Session
Settings.

2. Select the Enable UDP audio check box.
Select Audio quality as Medium. Ensure that Citrix Audio quality policy is High or Medium in Citrix Studio.
4. Sign off from the session and the broker for the changes to take effect.

o

Steps

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter WFClient.

In the Key field, enter EnableUDPThroughGateway.

In the Value field, enter True.
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Sign out or restart the device for the settings to take effect.

Disable UDP audio through Citrix Gateway feature

Steps

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > Session Settings > Citrix Session
Settings.

2. Clear the Enable UDP audio check box.
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On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

Remove the EnableUDPThroughGateway setting.
Sign out or restart the device for the settings to take effect.

Multiple audio redirection

From ThinOS 2205 and Citrix Workspace app 2203, Citrix Workspace app displays all available local audio devices in a session
with their names. Plug-and-play support for Bluetooth and HDMI audio devices are also provided. This feature is disabled by
default.

About this task

Follow this task to enable the feature.

Steps
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On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

On the Advanced tab, go to Peripheral Management > VDI Configuration Editor > Citrix Configuration Editor.
In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter ClientAudio.

In the Key field, enter AudioRedirectionV4.

In the Value field, enter True.

Click Save & Publish.

. Sign out and restart the device for the settings to take effect.

For limitations and known issues, see the Release Notes of your ThinOS version at www.dell.com/support.

ThinOS 2303 and Citrix Workspace App 2302 supports multiple audio devices by default. From ThinOS 2303 and Citrix
Workspace App 2302, Citrix Workspace app displays all available local audio devices in a session with their names.
Plug-and-play functionality is also supported. Multiple audio devices redirection feature is enabled by default. In other
words, AudioRedirectionV4=True parameter has already been configured during Citrix Workspace App 2302 package
installation. You need not change the Citrix INI settings in Citrix configuration editor in Wyse Management Suite or Admin
Policy Tool. To disable this feature, do the following:

a. In Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter ClientAudio.

In the Key field, enter AudioRedirectionV4.

In the Value field, enter False.

Sign out or restart the device for the settings to take effect.

@ NOTE: Cisco JVDI does not support multiple audio devices feature, which is a known Cisco limitation. To ensure
there is no confusion or mistakes for users who use JVDI in a Citrix environment, multiple audio devices feature is
dynamically disabled after JVDI package is installed, and the feature is dynamically enabled after JVDI package is
uninstalled.
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@ NOTE: There is an eight-device limitation on HDX session redirection, which is a Citrix VDA limitation.

Citrix multiple audio redirection limitation

If JVDI package is installed in ThinOS, audio devices cannot be switched in the applications in session, and the session is
disconnected when you open Windows > Sound, and go to the Recording devices list. If you want to use multiple ICA audio
devices, it is recommended that you do not install the JVDI package.
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Smart card reader plug and play

From Citrix Workspace app 2112 and ThinOS 9.1.5067, Citrix Workspace app supports plug and play functionality for smart card
reader. When you insert a smart card, the smart card reader detects the smart card in the server and the client. You can plug
and play multiple cards simultaneously, and all these cards are detected. This feature is enabled by default. From ThinOS 2205
and Citrix Workspace app 2203, you are allowed to disable smart card plug and play functionality.

Disable smart card plug and play

Steps

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter SmartCard.

In the Key field, enter DriverName.

In the Value field, enter VDSCARD . DLL.

Sign out or restart the device for the settings to take effect.
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HDX RealTime Webcam Video Compression for 32-bit apps

Only 32-bit apps on the virtual desktop with HDX RealTime Webcam Video Compression are supported by ThinOS. Dell
Technologies only qualified this feature using Citrix Workspace App 2109 package. With this feature, you can customize the
camera resolution and frames per second from System Setup > Peripherals > Camera. You can also customize this feature
using Admin Policy Tool or Wyse Management Suite policy settings. HDX RealTime Webcam Video Compression is compatible
with most unified communications clients. The feature has been tested for compatibility with Cisco Webex Meetings, Cisco
Webex Teams, Cisco Jabber, Microsoft Teams, Skype for Business 365, and Zoom. You can use a 32-bit browser such as
Google Chrome or Mozilla Firefox to verify the webcam redirection online. External USB cameras or the integrated camera
can be used with HDX RealTime Webcam Video Compression. Webcam bandwidth consumption can vary with webcam models.
Different webcams offer different frame rates and resolution. Dell Technologies used the following webcams for initial feature
validation:

e Microsoft LifeCam HD-3000—Highest supported resolution with HDX RealTime Webcam Video Compression is 1920x800.
e |ogitech C920, C922, C930e—Highest supported resolution with HDX RealTime Webcam Video Compression is 1600x896.
e Wyse 5470 and 5470 All-in-One thin clients with built-in camera.

HDX RealTime Webcam Video Compression limitations

Camera with hardware encoding is not supported in ThinOS.

Since x264 library is not integrated into ThinOS, 64-bit apps with HDX RealTime Webcam Video Compression are not
supported by Citrix Workspace App. Hence, only 32-bit apps with HDX RealTime Webcam Video Compression are supported
in ThinOS.

e Citrix Workspace App 2112 with HDX RealTime Webcam Video Compression works only with built-in camera. The issue
is also reproduced in Linux Citrix Workspace app binary. Hence, from this ThinOS release, HDX RealTime Webcam Video
Compression is only supported with Citrix Workspace app 2109.

e Sometimes, the updated Camera Width, Camera Height and Camera FPS settings does not sync from Wyse Management
Suite to the thin client. You must reboot the client for the changes to take effect.

e HDX RealTime Webcam Video Compression in ThinOS supports only one webcam at a time. Citrix Workspace Linux binary
can update the default webcam by modifying HDXWebCamDevice in SHOME/ . ICAClient/wfclient.ini configuration
file. For example, add HDXWebCamDevice=/dev/video2 to set the webcam mapped to /dev/video?2 in a system.
However, ThinOS does not allow to input the value /dev/video?2 in VDI Configuration Editor due to security reasons.

e |[f client camera is set to 2304x1296 or 2304x1536 video resolution, the HDX webcam redirection cannot be previewed in the
session. This limitation is reproduced in CWA 2109 Linux binary as well.

e If client camera is set to 1920x1080 video resolution, the HDX webcam redirection falls back to 325x288 video resolution in
the session. This limitation is reproduced in CWA 2109 Linux binary as well.
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e HDX webcam camera sometimes does not work on Webex Meeting call. This limitation is reproduced in CWA 2109 Linux
binary as well.

e Zoom application video preview sometimes fails when you use Citrix HDX Webcam. This limitation is reproduced in CWA 2109
Linux binary as well.

e Webex application video fails to preview when you use Citrix HDX Webcam. This limitation is reproduced in CWA 2109 Linux
binary as well.

e External USB camera does not work with Citrix HDX Webcam in Citrix Workspace app 2112. Only the built-in camera works.
This limitation is reproduced in CWA 2109 Linux binary as well.

Prerequisites for HDX RealTime Webcam Video Compression

e On the VDA, HDX RealTime Webcam Video Compression is enabled by default. Additional configurations are not required.
Dell Technologies recommends using Citrix VDA version 1912CU3 or later.

e HDX webcam video compression requires Multimedia conferencing and Windows Media Redirection policy settings to
be enabled. The settings are enabled by default.
Ensure that Citrix_Workspace_App_21.9.0.25_6.pkg is installed.

e To use HDX RealTime Webcam Video Compression in the unified communication software in VDA, ensure that the following
conditions are met:
o For Skype for business application, ensure that the software is 32-bit and do not install the Citrix HDX RealTime

Connector in VDA.

o For ZoomVDI application, ensure that the software is 32-bit. Do not install Zoom_Citrix package in the thin client. Disable
Zoom VDI optimization using Admin Policy Tool or Wyse Management Suite policy settings, if you have installed Zoom
package in thin client.

o For Microsoft Teams application, ensure that the software is 32-bit. Disable Microsoft Teams VDI optimization in thin
client using Admin Policy Tool or Wyse Management Suite policy settings.

o For Webex meeting application, ensure that the software is 32-bit. Do not install Webex Meetings VDI package in thin
client. Disable Webex Meetings VDI optimization using Admin Policy Tool or Wyse Management Suite policy settings, if
you have installed Webex Meetings VDI package in thin client.

o For Webex VDI application, ensure that the software is 32-bit. Do not install Webex VDI package in the thin client. Disable
Webex VDI optimization using Admin Policy Tool or Wyse Management Suite policy settings, if you have installed Webex
VDI package in thin client.

o For Cisco Jabber application, ensure that the software is 32-bit. Do not install Cisco Jabber package in the thin client.
Disable JVDI optimization using Admin Policy Tool or Wyse Management Suite policy settings, if you have installed Cisco
Jabber package in thin client.

Configure camera for HDX RealTime Webcam Video Compression using
Admin Policy Tool or Wyse Management Suite policy settings

Steps
1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. On the Advanced tab, expand Peripheral Management, and click Camera.
3. Click Enable Camera to enable the camera.
By default, the option is enabled. If the option is disabled, the cameras on the thin clients are not shown.

4. Enable Optimize for CPU.
By default the option is enabled. The default settings are format=RAW, resolution=320X240, and FPS=10. Disable the
Optimize for CPU option to customize the camera format, resolution, and FPS settings. Ensure that the camera supports
the custom values before continuing. Increasing the resolution and FPS impacts the performance.

5. Click Save & Publish.

HDX RealTime Webcam Video Compression for 64-bit apps

From ThinOS 2208 and Citrix Workspace App 2207, HDX RealTime Webcam Video Compression for 64-bit applications is
supported. Webcam redirection works for 32-bit and 64-bit applications such as Skype or GoToMeeting. Use a 32-bit browser
or 64-bit browser to verify the webcam redirection online. For example, use a 32-bit browser or 64-bit browser and go to
www.webcamtests.com.
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By default, ThinOS only supports webcam redirection feature for 32-bit apps. To enable webcam redirection feature for 64-bit
apps, see Enable HDX RealTime Webcam Video Compression for 64-bit apps.

Enable HDX RealTime Webcam Video Compression for 64-bit apps

Steps

1.
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On Admin Policy Tool or the Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix

Configuration Editor.

Under Citrix INI Settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.
In the Section field, enter WFClient.

In the Key field, enter HDXH264InputEnabled.

In the Value field, enter True.

Sign out or restart the device for the settings to take effect.

Export Citrix Workspace App logs

From ThinOS 9.1.5xxx release onwards, Citrix Workspace App logs can only be exported from Troubleshooting > General
> Export Logs. From ThinOS 2402 and Citrix Workspace App 2311, the Citrix log path is changed from /var/log/citrix
to /compat/linux/var/log/citrix. Citrix log can be enabled through the Log Level setting in Session Settings >

Citrix Session Settings inside Wyse Management Suite.

Steps

1.
2.
3.

10.
1.

From the desktop menu, click System Tools.

Click the Packages tab.

Select Citrix Workspace App, and click Advanced.

The Citrix Log Preferences window is displayed.

Right-click the classes that you require, and select Verbose.

Select the check boxes to select specific log items.

Click Set All Enabled to select all the check boxes.

Enter the file name and the output file pat in the Log Output Path field.

The default path is var/log/ICAClient. log. Dell Technologies recommends using the default log output path.
Click Apply Changes and close the Citrix Log Preferences window.

Connect the ICA session, reproduce the scenario that you require the log from, and disconnect the ICA session.
Connect a USB drive that is formatted with the FAT32 file allocation.

From the desktop menu, click Troubleshooting.

On the General tab, click Export Logs.
Citrix Workspace app logs are exported to the USB drive.

Next steps

1.

o

Reopen the Citrix Log Preferences window by performing the following steps:
a. From the desktop menu, click System Tools.

b. Click the Packages tab.

c. Select Citrix Workspace App, and click Advanced.

The Citrix Log Preferences window is displayed.

Click both the Set All Default buttons.
Click the Load Default button.
Click Apply Changes.

The Citrix Workspace Log capture is disabled.
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Configure multifarm

In ThinOS, multifarm works with only a Citrix Broker agent. You cannot use multifarm with other connection brokers.

Steps

1. Log in to the Wyse Management Suite server.

2. Go to the Groups & Configs page, and select your preferred group.

3. Click Edit Policies > ThinOS 9.x.

4. Click the Advanced tab.

5. Expand Broker Settings, and click Global Broker Settings.

6. Enable MultiFarm.

7. Click Save & Publish.

8. Check in the thin client to WMS group, and restart the thin client.

9. From the desktop menu, click System Setup, and then click Remote Connections.

—
o

. Go to the Broker Setup tab, and enter the multi broker server in the Broker Server field.
For example, https://brokerl https://broker2 or https://brokerl ;https://broker2.

_
=y

. You can now log in to multi server with one user.

@ NOTE: If there is a server logon failure due to invalid credentials when you enable Multifarm and MultiDomain, the logon
continues. If there is no failure, logon exits immediately. You can switch between servers when you are logged in with
multiple servers using Citrix Workspace mode. To switch between servers, click the menu button at the upper-right
corner, and then click Accounts.

Configure multilogon

In ThinOS, multilogon works with only a Citrix Broker agent. You cannot use multilogon with other connection brokers.

Steps

1. Log in to the Wyse Management Suite server.

2. Go to the Groups & Configs page, and select your preferred group.

3. Click Edit Policies > ThinOS 9.x.

4. Click the Advanced tab.

5. Expand Broker Settings, and click Global Broker Settings.

6. Enable MultiLogon.

7. Click Save & Publish.

8. Check in the thin client to WMS group, and restart the thin client.

9. From the desktop menu, click System Setup, and then click Remote Connections.

—
o

. Go to the Broker Setup tab, and enter the multi broker server in the Broker Server field.
For example, https://brokerl https://broker2 or https://brokerl ;https://broker2.

=N
=y

. You can now log in to multi server with two different users.

@ NOTE: You can switch between servers when you are logged in with multiple servers using Citrix Workspace mode. To
switch between servers, click the menu button at the upper-right corner, and then click Accounts.

Virtual Display Layout

From ThinOS 2211 and Citrix Workspace App 2209, virtual display layout on VDA is supported. This section describes how to
configure the virtual display layout on VDA.

Prerequisites

e Single-session or multisession operating system VDA must be supported.
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e The graphics status indicator policy must be enabled.
e /DA version 2019 or later (Dell Technologies qualified VDA 2203 LTSR and 2206).

®| NOTE: Only desktop sessions can be configured.

Steps

1. Right-click the graphics status indicator icon from the system tray and select Configure virtual displays.
The virtual display configuration interface is launched.

2. Right-click a virtual display to mark it as the primary monitor.

8. Use the DPI drop-down list to set a preferred scaling factor for the virtual display.

You can draw horizontal or vertical lines to separate the screen into virtual monitors. The screen is split according to
specified percentages of the session monitor resolutions.

4. After defining a virtual display layout, click OK to save the layout, or Cancel to discard the changes.
Use Reset to undo the configuration and restore the original layout.

Extended keyboard layouts

Japanese 106 keyboard, Portuguese ABNT/ABNT2 keyboards, and Multimedia keyboards are supported in Citrix VDI sessions
from ThinOS 2211 and Citrix Workspace App 2209.

Prerequisites

e To enable the extended keyboard layouts in Citrix VDI session, ensure that the Scancode keyboard input mode is configured.

e Ensure that the setting Enabled Volume Control for Client Volume is disabled in Admin Policy Tool or Wyse Management
Suite policy. Otherwise, the Multimedia keyboards do not work.

Steps

1. In Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In Citrix INI Settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter WFClient.

In the Key field, enter KeyboardEventMode.

In the Value field, enter Scancode.
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Sign out or restart the device for the settings to take effect.

32-bit cursor

32-bit cursor is supported on ThinOS 2303 and Citrix Workspace App 2302.
The black box around the cursor issue is resolved when using 3D applications in HDX 3D Pro VDA desktop.

There is a black box around the 32-bit cursor in Adobe Acrobat reader in Citrix HDX Pro 3D desktop. This issue is also
reproduced in Citrix Workspace App Linux binary.

e From ThinOS 2306 and Citrix Workspace App 2305, you can disable support for the 32-bit cursor. By default, 32-bit cursor is
enabled. To disable support for the 32-bit cursor, do the following:

1. On Admin Policy Tool or Wyse Management Suite policy settings, go to Advanced > VDI Configuration Editor > Citrix
Configuration Editor.

In the Citrix INI Settings, click Add Row.

From the File drop-down list, select wfclient.ini.

From the Operation drop-down list, select Add or Update.
In the Section field, enter Thinwire3.0.

In the Key field, enter Cursor32bitSupport.

In the Value field, enter False.

Sign out or restart the device for the settings to take effect.

© N O OoabhNN
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Configuring VMware

VMware virtualization enables you to run multiple virtual machines on a single physical machine. VMware Horizon Client is a
locally installed software application that communicates between View Connection Server and the thin client operating system.
It provides access to centrally hosted virtual desktops from your thin clients.

In every ThinOS release, the VMware Horizon Client version may get updated to a newer version. You must upgrade the
VMware Horizon package along with the ThinOS firmware. VMware Horizon package versions have a dependency on the
ThinOS firmware versions. See the Release Notes of your ThinOS version at www.dell.com/support to know the corresponding
VMware Horizon package version.

From ThinOS 2205, you can use touch screen gestures in both remote desktop and application sessions. Both full-screen mode
and window mode support touch screen functionality. You can also use touch screen with the VMware Horizon Client user
interface. Swiping down the screen, touch screen gestures, and multi-touch are not supported. If you enable relative mouse, the
touch screen functionality may not work properly.

For information about the latest VMware Horizon Client version and the known issues, see the Release Notes of your ThinOS
version at www.dell.com/support.

@ NOTE: If you are upgrading your thin client to the latest ThinOS version, you must ensure that the Horizon server or agent
version is updated to support the latest Horizon client version. For more information about the client and server/agent
version compatibility, see the VMware Product Interoperability Matrices page at www.vmware.com.

Configure the VMware broker connection

About this task

This section describes how to configure the VMware broker setup on your thin client.

Steps

1. From the desktop menu, click System Setup, and then click Remote Connections.
The Remote Connections dialog box is displayed.

2. In the Broker Setup tab, select VMware Horizon from the Select Broker Type drop-down list, and do the following:

o Broker Server—Enter the IP address/Hostname/FQDN of the broker server.

e Auto Connect List—Enter the name of the desktops that you want to launch automatically after logging in to the
respective broker. You can enter multiple desktop names. Each desktop name is separated by semicolon, and is case-
sensitive.

e Security mode—Select the preferred security mode from the following options:

o Full—Full Security requires an FQDN address with a domain certificate.

o Warning—Warn Security requires an FQDN address with a self-signed certificate, or without any certificate. But the
corresponding warning message is displayed for user to continue.

o Low—Security allows an FQDN or IP address with or without a certificate.

e Connection Protocol—From the drop-down list, select the type of protocol connection. By default, the option is set to
Server Default.

NOTE: The PColP only connection protocol is applicable only to PColP clients. If you do not install the Teradici

PColP package, then the PColP protocol option is not available.
The available options are:

o Server default—Select this protocol connection to display the desktop with default protocol as configured in the
VMware View Admin console, for each pool in the broker. If a desktop pool is configured with default protocol as RDP
in the View Admin console, then only the RDP connection of the desktop is displayed in ThinOS after users sign in to
the device.

o All Supported—Select this protocol connection to display the desktop in all the available connections. This is
applicable when a desktop pool is configured to allow users to select the protocol as yes. If the desktop is configured
with default protocol as PColP and allow user to select protocol as no, then ThinOS only displays the desktop in the
PColP connection.

o RDP only—Select this protocol connection to display the desktop in RDP connection only. If a desktop pool is
configured with default protocol as PColP in the View Admin console, and allow users to select the protocol as no,
then this desktop is not displayed in ThinOS after user signs in to the device.
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o PColP only—This option is available only for PColP enabled clients. Select this protocol connection to display only
the desktop in the PColP connection, for each pool in the broker. If a desktop pool is configured with default protocol
as RDP in the View Admin console, and allow user to select the protocol as no, then this desktop is not displayed in
ThinOS after user signs in to the device.

o Blast only—VMware Blast display protocol can be used for remote applications and for remote desktops that use
virtual machines or shared-session desktops on an RDS host. Select this protocol connection to display the desktop
with the Blast protocol.

e Log in anonymously using Unauthenticated Access—Select this check box to anonymously log in to the VMware
session with application remoting.

3. Click OK to save the settings.

VMware Real Time Audio-Video

About this task

Use the Real-Time Audio-Video feature to run Skype and other online conference applications on the remote desktop. Both
audio and video devices that are connected to your thin client can be used for VoIP in a remote desktop. From ThinOS 2205,
the Real-Time Audio-Video feature displays the names of redirected devices with (VDI) added to the name. For example, the
C670i FHD Webcam is displayed as C670i FHD Webcam (VDI). For audio playback, (VDI) is not added to the device name.

To know more about the VMware Real Time Audio-Video support, go to pubs.vmware.com.
®| NOTE: There is no additional configuration for ThinOS.

To validate the VMware Real Time Audio-Video, do the following:

Steps
1. Connect to the VMware PColP or Blast desktop with the audio and video devices.

®| NOTE: USB redirection must be disabled for the audio and video devices.

Verify the audio playback of the system using the VMware virtual audio.

Verify the system audio recording using the VMware virtual microphone.

Verify the audio settings in the VolP application.

Verify the video settings in the VolP application using the VMware virtual webcam.

SIS IENENIN

Start the audio or video calls.

®| NOTE: Skype for Business is not supported from ThinOS 2306 version.

High Efficiency Video Coding

In ThinOS 9.1.4234, VMware Blast Extreme supports High Efficiency Video Coding (HEVC). HEVC is also known as H.265 and

it is the industry successor to H.264. Compared to H.264, H.265 provides 50% more compression by maintaining the same
quality as H.264. This feature is disabled by default. HEVC in Blast Extreme requires both the ESXi hosts that support the virtual
desktops, and RDSH servers to have NVIDIA Tesla or newer graphics cards to offload the encoding. HEVC does not work with
only ESXi CPU encoding. If there are no supported graphics cards present, the H.264 or JPEG/PNG encoding is used.

®

NOTE: HEVC requires hardware support including the graphics card, on both the client and the agent side. If either the
client or the agent cannot support HEVC, the session falls back to H.264.

To enable this feature from the local user interface, select the Allow High Efficiency Video Decoding (HEVC) check box
from Connection Manager > Global Connection Settings > Horizon. You can go to the VMware Horizon Performance
tracker and see Encoder Name to verify whether HEVC is working. If you launch a session that has been launched from
another device, the HEVC feature does not work. The server uses H.264 in this scenario. To use HEVC, sign off other sessions
before connecting to the session from the ThinOS client.

®| NOTE: You must upgrade Wyse Management Suite to version 3.5 or later to support the HEVC feature.

For more information, see the VMware Blast Extreme Optimization Guide at techzone.vmware.com.
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Enable or disable HEVC from Admin Policy Tool and Wyse Management Suite
Policy settings

Steps

1. Go the Admin Policy Tool or Wyse Management Suite policy settings.

In the Advanced tab, expand Session Settings.

Click Blast Session Settings.

Click the Allow High Efficiency Video Decoding toggle to enable or disable HEVC.
Click Save & Publish.

o b omn

Switch between codecs in Blast sessions

VMware Blast sessions support the use of industry-standard codecs such as H.264, HEVC for remoting screen content from
Horizon Agent to Horizon Client.

e Prerequisite—Horizon Agent 2203 or later must be installed to support High Definition Color for H.264 or HEVC.

e The Horizon administrator can use agent-side group policy settings to activate or deactivate the VMware Blast features,
including High Definition Color for H.264 and HEVC.

e Horizon Agent uses a hardware codec when your system environment meets the following criteria:
o The agent machine supports the hardware codec.
o For HEVC and AV1, the client machine must have a GPU that supports the hardware codec.
VMware Blast options on the client are configured to allow use of the decoding method.
Currently, thin clients do not support AV1and HEVC 4:4:4 configurations.
Horizon Agent chooses a hardware codec according to the following order of preference:
o HEVC 4:4:4 (high-definition color)
o H.264 4:4:4 (high-definition color)
o HEVC 4:2:0 (standard-definition color)
o H.264 4:2:0 (standard-definition color)

e |f hardware codecs are not supported on both the client and agent machines, Horizon Agent chooses a software codec
according to the following order of preference and decoding methods that are allowed on the client:

o BlastCodec (high-definition color)

o H.264 4:4:4 (high-definition color)

o H.264 4:2:0 (standard-definition color)
o Adaptive (high-definition color)

Enable Scanner Redirection

Scanner Redirection feature enables you to scan information from VDI desktops using scanning and imaging devices that are
connected to your thin client. Scanner Redirection supports standard scanning and imaging devices that are compatible with
TWAIN and Scanner Access Now Easy (SANE) formats. The scanner redirection feature is applicable only for Blast sessions.

Prerequisites

Ensure that the Scanner Redirection feature is installed in the VMware Horizon session. You must select this feature in the
VMware Horizon Agent wizard during the Horizon agent installation.

Steps

Log in to the ThinOS client.

From the system menu, click Admin Policy Tool.

In the Advanced tab, click Broker & Session, and expand VMware Horizon Settings.

N N

Configure the following options based on your preference:

e |f the Scanner Class ID starts with 06, click the Allow USB Imaging Family Device (Scanner) Redirection toggle
switch to enable the Scanner Redirection feature.

e |[f the Scanner Class ID does not start with 06, enter the Scanner VID and PID in the format vid-xxxx pid-yyyy in
the Include Vid/Pid USB Device Redirection field.

122 Configuring connection brokers



5. Click Save & Publish.
6. Launch the Horizon View desktop on ThinOS.

7. Open the VMware Scanner Redirection menu from the Windows system tray.
The available scanners are listed and can be selected based on your preference.

Enable Serial Port Redirection

Serial Port redirection feature enables you to redirect serial (COM) ports such as integrated RS232 ports or USB ports that are
connected locally to serial-USB adapters. You can connect the serial devices to serial ports on your thin client and then use the
serial devices in VDI desktops. The serial port redirection feature is applicable only for Blast sessions.

To use the Serial Port Redirection feature, you must install the feature in the VMware Horizon session. This feature is installed in
the VMware Horizon Agent during the Horizon Agent installation. After the Serial Port Redirection feature is enabled in the VDI
session, do the following:

1. Launch a Horizon View desktop on ThinOS.
2. Open the VMware Serial Port Redirection menu from the Windows system tray.

The available serial ports are listed and can be selected based on your preference. In Windows Device Manager, the serial
port is displayed as Serial Port Redirection over VMware Horizon (COM1).

Enable Session Collaboration

Session Collaboration redirection feature enables you to invite other users to join your remote desktop session. The session
collaboration feature is applicable only for Blast sessions.

®| NOTE: You cannot accept the invitation and join the remote desktop session of other users. This is a limitation on ThinOS.
By default, the session collaboration feature is enabled in the VMware session. To invite a user to join your desktop session, do
the following:

1. Launch a Horizon View desktop on ThinOS.
2. Click the VMware Session Collaboration icon from the Windows system tray.
3. Enter the username or email address and click Send.

Enable Battery State Redirection

Battery State Redirection feature enables you to redirect the battery information of the ThinOS device to a remote desktop.

To use the Battery State Redirection feature, you must ensure that the Enable Battery State Redirection Agent Policy
Setting is enabled in Group Policy Management Editor. By default, this feature is enabled. The battery state redirection feature
is applicable only for Blast sessions.

Relative mouse

When you enable the relative mouse feature, Horizon Client uses relative coordinates to transmit data about the mouse pointer
movement and improve the mouse performance. The relative mouse feature is applicable for both PColP and Blast-enabled thin
clients.

®| NOTE: The touch screen may not work when the relative mouse feature is enabled. This is a VMware limitation.

Enable relative mouse using Admin Policy Tool or Wyse Management Suite

Steps
1. On the ThinOS client, start Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.

2. On the Advanced tab, expand Session Settings, and click either Blast Session Settings or PColP Session Settings
based on your preference.

3. Click the Enable Relative Mouse when launching session toggle key to enable the relative mouse feature.
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4. Click Save & Publish.

NOTE: To disable the relative mouse feature, press Ctrl+ Alt key combination in a Blast session or press Ctrl +Alt+Down
key combination in a PColP session.

Enable relative mouse using session menu

Steps
1. On the ThinOS client, launch a PColP session or a Blast session.

2. In the system tray, click the PColP icon to view the active PColP sessions, or click the VMware icon to view the active Blast
sessions.

3. Select a session from the menu.
4. Enable Relative Mouse.
@ NOTE: To disable the relative mouse feature, press Ctrl+ Alt key combination in a Blast session or press Ctrl +Alt+Down
key combination in a PColP session.

Configure Workspace ONE Mode

VMware Workspace ONE mode enables you to connect to remote desktops and applications through the Workspace ONE Web
Portal. As a Horizon administrator, you can enable the Workspace ONE mode on a Connection Server instance. Horizon Client
users are redirected to a Workspace ONE server to launch their remote desktops and applications.

Steps
1. Open the VMware Connection Server console.
2. Go to Settings > Servers > Connection Server and click the Authentication tab.

3. From the Delegation of authentication to VMware Horizon (SAML 2.0 Authentication) drop-down list, select
Required.

Click Manage SAML Authenticators to add your Authenticator.
Select the Enable Workspace ONE mode check box.

Enter the Workspace ONE Server hostname and click OK.

Log in to the ThinOS client.

From the desktop menu, click System Setup, and then click Remote Connections.
The Remote Connections dialog box is displayed.
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9. In the Broker Setup tab, select VMware Horizon from the Select Broker Type drop-down list.
10. Enter the server URL in the Broker Server field.

11. Click OK and restart the thin client.
The VMware Workspace ONE login window is displayed.

12. Enter the user credentials and click Sign In.

®
®

NOTE: The ThinOS lock terminal is not supported in Workspace ONE Mode. When you attempt to lock the terminal, a
warning message is displayed prompting for automatic sign-off. Click Continue if you want to sign out from the session.

NOTE: The Remember this setting option in Workspace ONE web portal is not supported due to the customized

browser limitation.

Unified Access Gateway

ThinOS supports Unified Access Gateway (UAG) that is used to securely access remote desktops and applications that are
outside a corporate firewall. For information about the latest version of Unified Access Gateway, see Unified Access Gateway
Documentation at docs.vmware.com.

VMware Horizon 7.11 with Unified Access Gateway 3.8 and later uses SAML-based multifactor authentication. It supports many
modern cloud-based solutions including the Azure multifactor authentication.
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Configure Unified Access Gateway on ThinOS

Prerequisites

e Configure the Unified Access Gateway (UAG) setting on the server side. For more information about configuring the
server-side settings for UAG, see the VMware Unified Access Gateway documentation at docs.vmware.com.

e Open the connection server admin page, and specify the UAG information in the following sections:
o HTTP(s) Secure Tunnel
o PColP Secure Gateway
o Blast Secure Gateway

Steps
1. Start the ThinOS client.

2. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

3. On the Broker Setup tab, select VMware Horizon from the Select Broker Type drop-down list.
4. In the Broker Server field, enter the Unified Access Gateway URL.
B. Click OK.

Configure Microsoft Azure Multifactor authentication with VMware Unified
Access Gateway

Prerequisites

Configure the Unified Access Gateway (UAG) settings and Azure Multifactor authentication settings on the server side. For
more information about configuring the server-side settings, see the Microsoft Azure MFA with VMware UAG documentation at
docs.vmware.com.

Steps
1. Start the ThinOS client.

2. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.

On the Broker Setup tab, select VMware Horizon from the Select Broker Type drop-down list.
In the Broker Server field, enter the Unified Access Gateway FQDN.

Click OK.

On the Azure Sign In window, enter the Azure account.

Click Next.

Enter the password to log in to the session.
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Device Certificate authentication with Unified Access Gateway and
Passthrough

About this task

With the client device certificate authentication feature, Unified Access Gateway authenticates the thin client system. After
successful device authentication, you must complete user authentication. For more information about this feature, see the
VMware documentation at docs.vmware.com.

Steps

Go to Wyse Management Suite or Admin Policy Tool.
Go to Login Experience > Login Settings.

Disable Login Use Smartcard Certificate Only.

Click Save.

Import the PFX certificate into ThinOS.

SNV SR
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6. Configure the Horizon Broker agent with the UAG server address.
7. Start the Broker agent login process.
8. Select the certificate to log in.

Figure 25. Selecting a certificate

X.509 Certificate Authentication

About this task

You can configure the X.509 certificate authentication in Unified Access Gateway to allow ThinOS to authenticate with
certificates. For more information about this feature, see the VMware documentation at docs.vmware.com

Steps

Connect the smartcard reader to the ThinOS client.
Configure the Horizon Broker agent with UAG server address.
Insert the smartcard in the smartcard reader.

Select the valid certificate.

Enter the PIN to login.

onoN

RADIUS Authentication

About this task

RADIUS offers a wide range of third-party, two-factor authentication options. To use RADIUS authentication on Unified Access
Gateway, you must have a configured RADIUS server that is accessible on the network from Unified Access Gateway.

Steps

1. Configure the Horizon Broker agent with UAG server address.
2. Enter the RADIUS username and passcode to log in.

RSA SecurlD Authentication

About this task

After the Unified Access Gateway appliance is configured as the authentication agent in the RSA SecurlD server, add the RSA
SecurlD configuration information to the Unified Access Gateway appliance.

Steps

1. Configure the Horizon Broker agent with the UAG server address.
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2. Enter the RSA username and passcode to log in.

‘ VMware Horizon Client

LOGIN @

Figure 26. Enter RSA username and passcode

SAML Authentication

About this task

If you are using SAML version 2.0 identity provider, you can directly integrate the identity provider with the Unified Access
Gateway (UAG) to support Horizon client user authentication.

To use SAML third-party integration with UAG, you must use Horizon Connection Server 7.11 or later versions.

To integrate the UAG with the identity provider, do the following:

Steps

1. Configure the identity provider with the service provider (UAG) information.
2. Upload the metadata file of the identity provider to the UAG.

3. Configure the Horizon settings on the UAG Admin console.

Next steps

No additional configuration is required in ThinOS. But, after the Broker agent connection is established, you are prompted to do
a third-party authentication.

Configure the VMware integrated printing settings

About this task

The VMware Integrated Printing feature allows you to print to a local or network printer without installing additional printer
drivers in the remote desktop. The USB redirection feature enables you to print from a remote desktop using a USB printer that
is connected to the local client device. For each printer configured locally on ThinOS, you must map the printer to the VMware
Blast desktop. ThinOS Blast printer mapping is equivalent to VMware client printer redirection.

Currently ThinOS supports only PS printer in blast session since VMware has removed Thin print support from VMware Horizon
8.0 and VMware Horizon Client 2006. Ensure that the Agent version is later than 7.9, and that you select the component
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VMware Integrated Printing. Certain PS model printers may not work in Blast session as it depends on the VMware integration
printing support.

To map your printer, do the following:

@ NOTE: LPT printer is considered as an example to explain the printer mapping scenario. Printer mapping in ThinOS works
similar to LPT for LPD and SMB printers.

Steps
1. Power on the ThinOS client with the VMware View broker configured in the Broker Setup tab.
2. Set the connection protocol as All Supported from the Connection Protocol drop-down list.

8. Go to Global Connection Settings > Session, and retain the Exclude printer devices check box selection. This option is
selected by default.

4. Plug in a USB printer to the ThinOS client terminal.

5. Go to System Setup > Printer.
The Printer Setup dialog box is displayed.

6. In the Printer Setup dialog box, do the following:
a. From the Select Port drop-down list, select LPT 1.
b. Enter valid printer name and printer identification.
Cc. Select the Enable the printer device check box.
d. Click OK to save the configuration.

7. Click the Options tab, and do the following:

a. Set LPT1: <Printername>as default printer.
b. Click OK to save the configuration.

8. Connect to a VMware Blast session and go to Control Panel > Devices and Printers.

The printer that is configured locally in ThinOS is mapped to the session. The mapped printer’s driver is VMWARE
POSTSCRIPT Driver and the port is VMWPORT.

The VMware Integrated Printing feature allows the ThinOS local printer to be mapped to the VMware Blast session without
installing the printer driver in the session.

Configure the USB Printer Redirection in VMware Blast and PColP session

Steps
1. Connect a USB printer to the ThinOS client.

2. Go to Global Connection Settings > Session and clear the Exclude printer devices check box. This option is selected by
default.

3. Log off from VMware Broker agent, and then log in again.
4. Login to a Blast or a PColP session.

5. Go to Control Panel > Devices and Printer and verify if the printer driver is automatically installed.
After the printer driver installation is complete, the redirected printer is listed in the Printers section.
NOTE: The drivers of certain printers may not get installed on the target Windows server automatically as the
installation depends on the Windows server. In such scenarios, the drivers must be installed manually.

USB Redirection in a VDI session

Upgrading to the ThinOS 9.1.3112 eliminates the local USB driver dependency on the USB redirection feature.

From ThinOS 9.1.3112 onwards, you can directly use the USB redirection feature in a VDI session without attaching the USB
driver installed locally on your thin client. The local USB driver is automatically detached when using USB redirection in the VDI
session. As a result, the USB redirection in the VDI session is fast and more reliable.

After upgrade, if you are configuring the USB settings on your local thin client, do either of the following:

e Using Global Connection Settings:
1. On the local ThinOS client, go to the Global Connection Settings > Session on local ThinOS Ul.
2. Verify if the USB device redirection is selected, and click OK.

e Using Admin Policy Tool:

128 Configuring connection brokers



1. On the Admin Policy Tool, go to Advanced > Session Settings > Global Session Settings > Local Resources and
USB redirection.

2. Ensure that the USB redirection option is enabled, and click Save and Publish.

Apply these setting changes when you are using the USB Redirection for the first time, after you upgrade from ThinOS 9.1.2X or
older versions to 9.1.3112. The setting changes are not required after the first instance. If you are configuring the USB settings
using Wyse Management Suite policy settings, you do not have to enable the USB redirection option again after upgrade.

There are no visible Ul changes on the ThinOS client. However, the USB redirection speed is improved in the VDI session.
USB Redirection in a PColP session

For PColP session, ensure that the Group Policy is enabled to make the USB redirection work. Do the following to enable the
GPO feature:

1. Open a PColP session and press WIN+R to open the Run window.
2. Enter gpedit.msc to open the Local Group Policy Editor.

3. Go to Computer Configuration > Administrative Templates > PColP Session Variables > Not Overridable
Administrator Settings, open Configure PColP USB allowed and unallowed device rules, select Enable, and click

Apply.
NOTE: These steps are applicable to PColP session in VMware Horizon broker and Teradici Cloud Access broker. For

Teradici Remote Workstation Card and Amazon WorkSpace session, USB redirection is not supported by third party.

NOTE: Currently, the SDK integrated in ThinOS for PColP does not support the USB redirection feature for all USB drives.
This is a limitation from the third party SDK. For Headset and Camera, PColP does not support redirection in a session. Use
RTAV for audio and video devices.

Enable Multimedia Redirection in Blast session

Steps

1. Access the VMware Horizon connection server from the browser.

2. Go to Settings > Global Policy.

3. Change the Multimedia Redirection (MMR) drop-down value to Allow.
The default value is Deny.

4. Click OK.

NOTE: Multimedia Redirection (MMR) is enabled on ThinOS client side by default and there is no configuration item
to disable MMR from ThinOS client. To disable the MMR feature, select the value as Deny in the VMware Horizon
connection server. MMR feature uses Windows Media player as the default video player.

Smartphone sync

From ThinOS 9.1.4234, you can sync your iPhone or Android smartphone into a VMware Blast session.

®| NOTE: Among the Android smartphones, only Huawei and Samsung phones are tested.

Sync Huawei Android smartphone

Prerequisites

e Download and install HiSuite in Blast session, from https://consumer.huawei.com/en/support/.
e Install HiSuite app on your Huawei smartphone.

Steps

Launch the Blast session.

Open HiSuite from the Blast session.

Connect your Huawei smartphone to the client.

N N

Accept the access request on your phone.
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A window that prompts you to enter a verification code from the phone, is displayed in the Blast session.

5. Open the HiSuite app on your phone and enter the verification code from the phone in the Blast session.
6. Click or tap Connect.

Sync Samsung Android smartphone and iPhone

Steps

1. Go to the Admin Policy Tool or Wyse Management Suite policy settings.

2. In the Advanced tab, expand Session Settings.

3. Click Blast Session Settings.

4. Enable the Allow USB Imaging Family Device Redirection option.

5. Click Save & Publish.

6. Launch the Blast session and connect your Samsung smartphone or iPhone to the device.
7. Accept the access request on your Samsung smartphone or iPhone.

VMware Horizon Kiosk Mode

VMware Horizon VDI Broker agent can be connected to Kiosk Mode by entering the username as Client Mac.

Prerequisites

For information about Kiosk Mode authentication and configuration, go to docs.vmware.com.

Steps
1. From the desktop menu, click System Setup > Remote Connections.
The Remote Connections dialog box is displayed.
2. Click the General Options tab, and do the following:
a. Enter the username as Client Mac in the Default Sign-on Username field.

®| NOTE: Client Mac is hard code username, and it is case-sensitive.

b. Leave the Default Sign-on password field empty.
C. Leave the Default Sign-on Domain field empty.
3. Click OK to save your settings.
NOTE: In earlier ThinOS versions, you must click the LOGIN button to log in to VMware Horizon Broker agent when
Kiosk Mode is configured in ThinOS. From ThinOS 2205, VMware Horizon logs in automatically if the Kiosk Mode
account Client Mac is configured as the ThinOS default user.

Configuring other brokers

You can configure other brokers in Remote Connections. Leostream, Parallels RAS, and Systancia Workplace brokers are
supported from ThinOS 2303.

e In the Select Broker Type drop-down list under Remote Connections > Broker Setup, Other Broker option has been
added that supports Leostream and Parallels RAS Broker agents.
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Figure 27. Other Broker option in Remote Connections
e You can also configure the other Broker agents in Wyse Management Suite and Admin Policy Tool by going to Broker
Settings > Other Broker Settings.
1. In the Broker Server field, you can configure the Broker agent server address by adding the URL of the other Broker
agent.
2. In the Auto Connect List field, you can configure the desktop and applications that must be automatically connected.
3. In the Notice to Broker Connection, when using Parallels RAS Broker agent, Enable Password Variables must be
enabled in Login Experience > Login Session.
o The server certificate must be imported in ThinOS before connecting to the Broker agent.
o The Broker agent URL must be in FQDN format.

Leostream

e |eostream connection broker version is 9.0.40.10.

e | eostream agent version is 7.3.8.0.

e Remote Desktop Protocol (RDP) is supported during Leostream desktop sessions. AVD application package must also be
installed.

Parallel RAS (Remote Application Server)

e Parallel Remote Application Server (RAS) version is 18.0.22497.
e Remote Desktop Protocol (RDP) is supported during desktop and application sessions. AVD application package must also be
installed.

Systancia Workplace

Systancia Workplace is an application and desktop virtualization solution.
NOTE: ThinOS 2303 provides only experimental support for Systancia Workplace and is going to be supported in future

ThinOS releases.

e Supports Systancia Workplace Broker agent.
e Supports RDP for VDI sessions using the Systancia Workplace broker. AVD application package must also be installed.
e Known Issue
o If Systancia Workplace Broker agent does not respond in 5 s, login fails with a timeout error message. As a workaround,
log in again when facing the timeout error.

Special Peripheral Support

Bloomberg keyboard support

ThinOS 9.1.2101 supports Bloomberg Keyboard STB 100. The keyboard has two connection methods. One method uses a single
USB cable to the USB port of the system. The second method is to connect dual USB cables to a KVM USB switch.
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In a single USB cable connection, the keyboard device ID is vid-1188_pid-9545. All the six interfaces are under this device
ID.

In the dual USB cable connection, the keyboard device IDs are vid-1188_pid-9525 for one device and
vid-1188_pid-9535 for the other five devices.

Configure Bloomberg keyboard in Citrix sessions

Steps

1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. On the Advanced tab, expand Peripheral Management, and click USB Redirection.
3. Click Add Row in the vUSB Force Redirect section:

e Redirect the entire keyboard into the session—The keyboard feature keys, fingerprint reader, and the KVM Keyboard are
redirected into the session.

o For Bloomberg keyboard that is connected with a single USB cable, add one row and enter the device ID. For
example, enter 0x11889545 to configure the device.

o For Bloomberg keyboard that is connected with dual USB cables, add two rows and enter the device IDs. For
example, enter 0x11889525 in one row and 0x11889535 in the other.

e Split keyboard and partly redirect into the session—You can redirect the keyboard feature keys, fingerprint reader, or the
KVM Keyboard individually.

o For Bloomberg keyboard that is connected with a single USB cable, add one row and enter the device ID. For
example, enter 0x11889545010100. This configuration means that the interface 010100 is redirected into session
and other interfaces are not redirected.

o For Bloomberg keyboard that is connected with dual USB cables, add one row and enter the device ID. For example,
enter 0x11889545030001. This configuration means that the interface 030001 is redirected into session and other
interfaces are not redirected.

4. Click Save & Publish.

Configure Bloomberg keyboard in PColP sessions

Steps
1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. On the Advanced tab, expand Peripheral Management, and click USB Redirection.
3. Click Add Row in the vUSB Force Redirect section.
The Keyboard Feature keys, fingerprint reader, and the KVM Keyboard are redirected into the session.

e For Bloomberg keyboard that is connected with a single USB cable, enter the device ID 0x11889545 to configure the
device.

e For Bloomberg keyboard that is connected with dual USB cables, add two rows in the vUSB Force Redirect section,
enter 0x11889525 in one row and 0x11889535 in the other.

®| NOTE: PColP does not support USB device splitting.

4, Click Save & Publish.

Redirect Bloomberg keyboard in VMware Horizon Blast sessions

Steps

1. On the ThinOS client, open Admin Policy Tool or go to the ThinOS 9.x policy settings on Wyse Management Suite.
2. In the Advanced tab, click Broker Settings, and expand VMware Horizon Settings.

e Redirect the entire keyboard into the session—The keyboard feature keys, fingerprint reader, and the KVM Keyboard are
redirected into the session.

o For Bloomberg keyboard that is connected with a single USB cable, enter vid-1188_pid-9545 in the Include
Vid/Pid USB Device Redirection field.

o For Bloomberg keyboard that is connected with dual USB cables, enter
vid-1188_pid-9525;vid-1188_ pid-9535 in the Include Vid/Pid USB Device Redirection field.
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e Split keyboard and partly redirect into the session—You can redirect the keyboard feature keys, fingerprint reader, or the
KVM Keyboard individually.

o For Bloomberg keyboard that is connected with a single USB cable:
a. Enter vid-1188_pid-9545 in the Include Vid/Pid USB Device Redirection field.
b. Enable the Allow Auto USB Device Splitting Redirection button.
c. Enter vid-1188 pid-9545(exintf:00;exintf:01;exintf:02) in the Split Vid/Pid Device field.

@ NOTE: This configuration means that the interfaces 03, 04, and 05 are redirected into session and the other
interfaces 00, 01, and 02 are not redirected. 03, 04, and 05 are audio related interfaces. The analog headset
from the audio port in Bloomberg keyboard can be redirected into the Blast session.

o For Bloomberg keyboard that is connected with dual USB cables:
a. Enter vid-1188_pid-9535 in the Include Vid/Pid USB Device Redirection field.
b. Enable the Allow Auto USB Device Splitting Redirection button.
c. Enter vid-1188 pid-9535(exintf:00;exintf:01) in the Split Vid/Pid Device field.

@ NOTE: This configuration means that the interfaces 02, 03, and 04 are redirected into session and the other
interfaces 00 and 01 are not redirected. 02, 03, and 04 are audio related interfaces. The analog headset from
the audio port in Bloomberg keyboard can be redirected into the Blast session.

3. Click Save & Publish.

Mapping Bloomberg keyboard in VMware Blast sessions

You can connect the keyboard using either single or dual USB cables. No setting changes or redirection is required. All the
function keys work without any redirection.

If you have set force redirection, see Remove Bloomberg keyboard force redirection settings for VMware Blast.

Remove Bloomberg keyboard force redirection settings for VMware Blast

Steps

1

Open the Admin Policy Tool on your thin client or go to the ThinOS 9.x policy settings on Wyse Management Suite.

2. Click the Advanced tab.
3.
4

Expand Session Settings, and click Blast Session Settings.

Remove the following Bloomberg keyboard entries from the Include Vid/Pid USB Device Redirection field.
e vid-1188_pid-9545

e vid-1188_pid-9525

e vid-1188_pid-9535

Click Save & Publish.

Bloomberg keyboard limitations

Hot plugging the Bloomberg keyboard is not supported for Bloomberg keyboard redirection. Configure the keyboard before
logging in to the Broker agent and launching the session.

Disconnecting the Bloomberg keyboard cables when it is redirected into session may cause the session to close or the
system to randomly reboot.
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Confirm the USB interface redirection

This section contains the steps to confirm whether the USB audio device is redirected into the VDI session. You can confirm the

USB redirection from the Device Manager, from the Audio Manager, or from the ThinOS Event Log.

Find the Vendor ID or Product ID of the connected device in ThinOS

This section contains the steps to find the Vendor ID (VID) or Product ID (PID) of your device in ThinOS.

Steps

N N
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Connect the USB device into the thin client.

Go to Settings > System Tools > Devices.

Expand USB Bus to find the name of your connected USB device.

Expand the name of the connected USB device to find the device Class, VID, PID, and the device interface.

For example, if your connected USB device is Nuance PowerMic II-NS, the details are displayed as the following:

%% System Tools

Certificates Packages

USB Bus
AHCI root HUB

Figure 28. VID and PID

usb[Class 09 Subclass 00 Protocol _00]

Dell Universal Receiver (class 00 VID 413cPID 3

ukbd[Class 03 Subclass 01 Protocol_01]
uhid[Class_03 Subclass 01 Protocol 02]
uhid[Class_03 Subclass 00 Protocol_00]
PowerMicll-NS (class_00 VID_0554 PID_1001)
uaudio[Class_01 Subclass_01 Protocol_00]
ush[Class_01 Subclass 02 Protocol_00]
usb[Class 01 Subclass 02 Protocol _00]
uhid[Class_03 Subclass 00 Protocol 00]
FSR 4ZUSB (class_00 VID_214a PID_0002)
ums[Class_03 Subclass 01 Protocol 02]

uhub[Class_09 Subclass 00 Protocol _00]

v OK

e Device name—PowerMicll-NS
e Device class—class_00
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e VID—VID_0554
PID—PID_1001
Device interface—four interfaces belong to this device.
o wuaudio (Class_01 Subclass_01 Protocol_00)
o usb (Class_01 Subclass_02 Protocol_00)
o usb (Class_01 Subclass_02 Protocol_00)
o uhid (Class_03 Subclass_00 Protocol_00)

Disable the USB device local driver during USB device redirection

Steps

1. In Wyse Management Suite setting or ThinOS local Admin Policy Tool, go to Advanced > Peripheral Managment > USB
Redirection > vUSB Force Redirect.

2. Click Add Row.
3. Enter Oxvvvvpppp,NoDriver or Oxvvvvppppccsspp,NoDriver.

Results

0xvvvvpppp,NoDriver disables the local driver of the whole device; v stands for vendor ID and p for production ID.
Oxvvvvppppccsspp,NoDriver disables the local driver of one class of one device and applies only to multifunction devices
with different classes.

Confirm the USB interface redirection from Device Manager in ThinOS

Steps
1. Go to Settings > Peripherals.

The Peripherals dialog box is displayed.
2. Click the Audio tab.

3. Expand USB Bus to find the name of your connected USB device. If the USB redirection is successful, all the information
under the USB device displays a usb prefix.

For example, if your connected USB device is Nuance PowerMic II-NS, the details are displayed as the following:
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System Tools

Devices Certificates

USE Bus
XHCI root HUB

ush[Class 09 Subclass 00 Protocol_00]

Dell Universal Receiver (class_00 VID_413c PID_301c)
ukbd[Class 03 Subclass 01 Protocol 01]
uhid[Class_03 Subclass 01 Protocol _02]
uhid[Class_03 Subclass 00 Protocol 00]

PowerMicll-NS (class_00 VID_0554 PID_1001)
usb[Class 01 Subclass 01 Protocol _00]
usb[Class 01 Subclass 02 Protocol _00]
usb[Class_01 Subclass_02 Protocol_00]
usb[Class_03 Subclass_00 Protocol_00]

FSR 4ZUSB (class 00 VID 214a PID_0002)
ums[Class_03 Subclass 01 Protocol _02]

uhub[Class_09 Subclass_00 Protocol_00]

+ DK * Cancel

Figure 29. USB redirection

usb (Class_01 Subclass_01 Protocol_00)
usb (Class_01 Subclass_02 Protocol_00)
usb (Class_01 Subclass_02 Protocol_00)
usb (Class_03 Subclass_00 Protocol_00)

Confirm the USB interface redirection from Audio Manager in ThinOS

Steps

1

136

Go to Settings > Peripherals.
The Peripherals dialog box is displayed.

Click the Audio tab. If the USB redirection is successful, the USB device is not displayed in drop-down lists under Playback
Devices or Record Devices.
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Confirm the USB interface redirection from ThinOS Event Log

Steps
1. Go to System Information > Event Log.
2. Verify the logs in the Event Log tab to confirm whether the USB redirection is successful.

For example, the thin client has only two audio devices HD audio-1 and PowerMicll-NS:

e |f your logs display the following details, it means that the USB device is redirected into the VDI session and the ThinOS
playback and recording devices are changed to HD audio-1.

o Change playback to HD audio-1
o Change record to HD audio-1

e |f your logs display the following details, it means that the USB device is released from the VDI session and the ThinOS
playback and recording devices are reverted.

o Change playback to PowerMicll-NS
o Change record to PowerMicll-NS

Set playback or recording devices as default

To set the playback or recording devices as default, see Set default playback or recording devices.

Nuance PowerMic II-NS

The following are the device information of Nuance PowerMic II-NS.

e Device ID—Class 00, VID 0554, PID 1001
e Device interface:
o Audio or microphone interface—010100
o HID button interface—030000
o Mouse or track pad interfaces

PowerMicll-NS (class_00 VID_0554 PID_1001)
uaudio[Class_01 Subclass_01 Protocol_00]

usb[Class_01 Subclass_02 Protocol_00]

usb[Class_01 Subclass_02 Protocol_00]

uhid[Class_03 Subclass_00 Protocol_00]

Figure 30. Device interface

NuancePowerMic II-NS redirection in a Citrix session

Full USB redirection in a Citrix session

Except the mouse, all other interfaces are redirected to the VDI session.

Configuration in ThinOS

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
On the Advanced tab, expand Peripheral Management, and click USB Redirection.

Click Add Row in the vUSB Force Redirect section, and enter the device ID 0x05541001.

Click Save & Publish.

Noo N e
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Connecting Nuance PowerMic II-NS in a Citrix session

Launch Citrix session and connect Nuance PowerMic II-NS into the thin client.

Nuance PowerMic II-NS device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

Nuance PowerMic II-NS device is displayed in the Citrix session under Device Manager > Sound, video and game
controllers.

Nuance PowerMic II-NS device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

In the Nuance Dragon Medical One desktop application, Nuance PowerMic 11-NS is displayed in the Microphone
drop-down list. All the HID buttons, voice recording, and audio playback features work in the Nuance Dragon Medical One
desktop application.

HID buttons redirection in a Citrix session

Only the HID buttons are redirected into the VDI session. Other parts such as Audio or Microphone are kept in the ThinOS local
device.

Configuration in ThinOS for HID buttons redirection only

Steps

© ©® NN NS

_
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On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

On the Advanced tab, go to Peripheral Management > VDI Configuration Editor > Citrix Configuration Editor.
In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter ClientAudio.

In the Key field, enter AudioRedirectionV4.

In the Value field, enter True.

Go to Advanced tab, expand Peripheral Management, and click USB Redirection.

. Click Add Row in the vUSB Force Redirect section, and enter the device ID 0x05541001030000.
. Click Save & Publish.

Connecting Nuance PowerMic II-NS in a Citrix session with only HID buttons redirection

Launch Citrix session and connect Nuance PowerMic II-NS into the thin client.

Nuance PowerMic II-NS device is displayed in the ThinOS local audio device list under System Settings > Peripherals >
Audio.

Nuance PowerMic II-NS device is displayed in the Citrix session under Device Manager > Sound, video and game
controllers.

Nuance PowerMic II-NS device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

In the Nuance Dragon Medical One desktop application, Nuance PowerMic I1-NS is displayed in the Microphone
drop-down list. All the HID buttons, voice recording, and audio playback features work in the Nuance Dragon Medical One
desktop application.

NOTE: The module.ini setting in Citrix is for the Citrix multi audio feature. If you do not add this setting, Nuance
PowerMic 11-NS does not get displayed in Citrix sessions.

NuancePowerMic II-NS redirection in a VMware Blast session

Full USB redirection in a VMware Blast session

Except the mouse, all other interfaces are redirected to the VDI session.
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Configuration in ThinOS

Steps

1.

2.
3.
4

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
On the Advanced tab, expand Session Settings, and click Blast Session Settings.

Enter vid-0554_pid-1001 in the Include Vid/Pid USB Device Redirection field.

Click Save & Publish.

Connecting Nuance PowerMic II-NS in a VMware Blast session

Launch the VMware Blast session and connect Nuance PowerMic II-NS into the thin client.

Nuance PowerMic II-NS device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

Nuance PowerMic II-NS device is displayed in the VMware Blast session under Device Manager > Sound, video and
game controllers.

Nuance PowerMic II-NS device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

In the Nuance Dragon Medical One desktop application, Nuance PowerMic I1-NS is displayed in the Microphone
drop-down list. All the HID buttons, voice recording, and audio playback features work in the Nuance Dragon Medical One
desktop application.

HID buttons redirection in a VMware Blast session

Only the HID buttons are redirected into the VDI session. Other parts such as Audio or Microphone are kept in the ThinOS local
device.

Configuration in ThinOS for HID buttons redirection only

Steps

I SN

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

On the Advanced tab, go to Session Settings > Blast Session Settings.

Enter vid-0554_pid-1001 in to the Include Vid/Pid USB Device Redirection field.

Enable Allow Auto USB Device Splitting Redirection.

Enter vid-0554_pid-1001 (exintf:00;exintf:01;exintf:02) in to the Spit Vid/Pid Device field.
Click Save & Publish.

Connecting Nuance PowerMic II-NS in a VMware Blast session

Launch the VMware Blast session and connect Nuance PowerMic II-NS into the thin client.

Nuance PowerMic II-NS device is displayed in the ThinOS local audio device list under System Settings > Peripherals >
Audio.

Nuance PowerMic II-NS device is not displayed in the VMware Blast session under Device Manager > Sound, video and
game controllers. Only the VMware virtual microphone or audio is displayed.

Nuance PowerMic II-NS device cannot be set as the default device from the Playback or Recording tabs under Sound in
Windows.

In the Nuance Dragon Medical One desktop application, Nuance PowerMic 11-NS is not displayed in the Microphone
drop-down list. However, all the HID buttons work in the Nuance Dragon Medical One desktop application. Voice recording
works from both VMware Blast session and Peripherals > Audio > Recorder in the local ThinOS user interface. Audio
works from both VMware blast session and ThinOS local user interface.

@ NOTE: The audio behaviors are different from Citrix sessions since VMware Blast session does not support multiple audio

devices.
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Nuance PowerMic |I-NS redirection in a PColP session

Full USB redirection in a PColP session

Except the mouse, all other interfaces are redirected to the VDI session.

Configuration in ThinOS

Steps

1. On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
2. On the Advanced tab, expand Peripheral Management, and click USB Redirection.

3. Click Add Row in vUSB Force Redirect section, and enter the device ID 0x05541001.

4. Click Save & Publish.

Connecting Nuance PowerMic II-NS in a PColP session
Launch the PColP session and connect Nuance PowerMic II-NS into the thin client.

e Nuance PowerMic II-NS device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

e Nuance PowerMic II-NS device is displayed in the PColP session under Device Manager > Sound, video and game
controllers.

e Nuance PowerMic II-NS device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

e In the Nuance Dragon Medical One desktop application, Nuance PowerMic II-NS is displayed in the Microphone
drop-down list. All the HID buttons, voice recording, and audio playback features work in the Nuance Dragon Medical One
desktop application.

@ NOTE: PColP does not support USB interface splitting function. Hence, the feature to only redirect HID buttons is not
supported in a PColP session.

Olympus RecMic DR-2200

The following are the device information of Olympus RecMic DR-2200.

e Model—2200
e Device ID—Class 00,VID 07b4, PID 0254

DR Series (class_00 VID_07b4 PID_0254)
uhid[Class_03 Subclass_00 Protocol_00]
uaudio[Class_01 Subclass_01 Protocol_00]
usb[Class_01 Subclass_02 Protocol_00]

;01 Subclass_01 Protocol_00]

usb[Class_01 Subclass_02 Protocol_00]

03 Subclass 00 Protocol_02]

Figure 31. Device information
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Olympus RecMic DR-2200 redirection in a Citrix session

Full USB redirection in a Citrix session

Configuration in ThinOS

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
On the Advanced tab, expand Peripheral Management, and click USB Redirection.

Click Add Row in the vUSB Force Redirect section, and enter the device ID 0x07b40254.

Click Save & Publish.
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Connecting Olympus RecMic DR-2200 in a Citrix session
Launch Citrix session and connect Olympus RecMic DR-2200 into the thin client.

e Olympus RecMic DR-2200 device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

e Olympus RecMic DR-2200 device is displayed in the Citrix session under Device Manager > Sound, video and game
controllers.

e Olympus RecMic DR-2200 device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

All the control buttons work in the Olympus Device Configuration Manager application.
Audio playback and audio recording works with Olympus RecMic DR-2200.

HID buttons redirection in a Citrix session

Only the HID buttons are redirected into the VDI session. Other parts such as Audio or Microphone are kept in the ThinOS local
device.

Configuration in ThinOS for HID buttons redirection only

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

On the Advanced tab, go to Peripheral Management > VDI Configuration Editor > Citrix Configuration Editor.
In the Citrix INI Settings, click Add Row.

From the File drop-down list, select module.ini.

From the Operation drop-down list, select Add or Update.

In the Section field, enter ClientAudio.

In the Key field, enter AudioRedirectionV4.

In the Value field, enter True.

© ® N OO AN

Go to Advanced tab, expand Peripheral Management, and click USB Redirection.
. Click Add Row in the vUSB Force Redirect section, and enter the device ID 0x07b40254030000.
. Click Save & Publish.

_
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Connecting Olympus RecMic DR-2200 in a Citrix session with only HID buttons redirection
Launch Citrix session and connect Olympus RecMic DR-2200 into the thin client.
e Olympus RecMic DR-2200 device is displayed in the ThinOS local audio device list under System Settings > Peripherals

> Audio.

e Olympus RecMic DR-2200 device is displayed in the Citrix session under Device Manager > Sound, video and game
controllers.

e Olympus RecMic DR-2200 device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.
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e All the control buttons work in the Olympus Device Configuration Manager application.

e Audio playback and audio recording works with Olympus RecMic DR-2200 in both ThinOS and Citrix sessions.

@ NOTE: The module.ini setting in Citrix is for the Citrix multi audio feature. If you do not add this setting, Olympus
RecMic DR-2200 does not get displayed in Citrix sessions. The recorder performance may not be clear on Windows Voice
Recorder application when the audio and recording is not redirected. Dell Technologies recommends using other third-party
voice recording applications.

Olympus RecMic DR-2200 redirection in a VMware Blast session

Full USB redirection in a VMware Blast session

Configuration in ThinOS

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
On the Advanced tab, expand Session Settings, and click Blast Session Settings.

Enter vid-07b4_pid-0254 in the Include Vid/Pid USB Device Redirection field.

Click Save & Publish.
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Connecting Olympus RecMic DR-2200 in a VMware Blast session
Launch the VMware Blast session and connect Olympus RecMic DR-2200 into the thin client.

e Olympus RecMic DR-2200 device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

e Olympus RecMic DR-2200 device is displayed in the VMware Blast session under Device Manager > Sound, video and
game controllers.

e Olympus RecMic DR-2200 device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

e While using the Olympus Device Configuration Manager application, all the HID buttons work. Audio and voice recording
features work using Olympus RecMic DR-2200.

HID buttons redirection in a VMware Blast session

Only the HID buttons are redirected into the VDI session. Other parts such as Audio or Microphone are kept in the ThinOS local
device.

Configuration in ThinOS for HID buttons redirection only

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

On the Advanced tab, go to Session Settings > Blast Session Settings.

Enter vid-07b4_pid-0254 in to the Include Vid/Pid USB Device Redirection field.

Enable Allow Auto USB Device Splitting Redirection.

Enter vid-07b4_pid-0254 (exintf:01;exintf:02;exintf:03;exintf:04 into the Spit Vid/Pid Device field.
Click Save & Publish.
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Connecting Olympus RecMic DR-2200 in a VMware Blast session
Launch the VMware Blast session and connect Olympus RecMic DR-2200 into the thin client.

e Olympus RecMic DR-2200 device is displayed in the ThinOS local audio device list under System Settings > Peripherals
> Audio.

e Olympus RecMic DR-2200 device is not displayed in the VMware Blast session under Device Manager > Sound, video
and game controllers. Only the VMware virtual microphone or audio is displayed.

142 Configuring connection brokers



Olympus RecMic DR-2200 device cannot be set as the default device from the Playback or Recording tabs under
Sound in Windows.

While using the Olympus Device Configuration Manager application, all the HID buttons work.
Audio can be recorded from a VMware Blast session and ThinOS local user interface.
Audio playback works in both VMware Blast session and ThinOS local user interface.

@ NOTE: The audio behaviors are different from Citrix sessions since VMware Blast session does not support multiple audio

devices.

Olympus RecMic DR-2200 redirection in a PColP session

Full USB redirection in a PColP session

Configuration in ThinOS

Steps

1

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.

2. On the Advanced tab, expand Peripheral Management, and click USB Redirection.
3.
4. Click Save & Publish.

Click Add Row in vUSB Force Redirect section, and enter the device ID 0x07b40254.

Connecting Olympus RecMic DR-2200 in a PColP session

Launch the PColP session and connect Olympus RecMic DR-2200 into the thin client.

Olympus RecMic DR-2200 device is not displayed in the ThinOS local audio device list under System Settings >
Peripherals > Audio.

Olympus RecMic DR-2200 device is displayed in the PColP session under Device Manager > Sound, video and game
controllers.

Olympus RecMic DR-2200 device can be set as the default device from the Playback or Recording tabs under Sound in
Windows.

While using the Olympus Device Configuration Manager application, all the HID buttons work. Audio and voice recording
features work using Olympus RecMic DR-2200.

@ NOTE: PColP does not support USB interface splitting function. Hence, the feature to only redirect HID buttons is not

supported in a PColP session.

Philips SpeechMike llI

The following are the device information of PHILIPS SpeechMike III.

Model—SpeechMike Il
Device ID—Class 00, VID 0911, PID Oc1c

SpeechMike Ill (class_00 VID_0911 PID_0
uaudio[Class_01 Subclass_01 Protocol_00]
usb[Class 01 Subclass_02 Protocol 00]
usb[Class_01 Subclass_02 Protocol_00]

uhid[Class_03 Subclass_00 Protocol_02]

uhid[Class 03 Subclass 00 Protocol _00]

ukbd[Class_03 Subclass 00 Protocol_00]

uhid[Class_03 Subclass 00 Protocol_00]

Figure 32. Device information
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Philips SpeechMike Ill redirection in a Citrix session

Full USB redirection in a Citrix session

Configuration in ThinOS

Steps

On the ThinOS client, open Admin Policy Tool or go to the Wyse Management Suite policy settings.
On the Advanced tab, expand Peripheral Management, and click USB Redirection.

Click Add Row in the vUSB Force Redirect section, and enter the device ID 0x09110clc.

Click Save & Publish.
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Connecting Philips SpeechMike Ill in a Citrix session
Launch Citrix session and connect Philips SpeechMike Ill into the thin client.

o Philips SpeechMike Il device is not displayed in the ThinOS local audio device list under S